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About This Guide

This guide explains what ConsoleOneTM is and how to install, use, and 
troubleshoot it.

HINT: This guide covers only the core ConsoleOne capabilities that you get if you 
download ConsoleOne from the Novell® Free Downloads Site (http://
www.novell.com/download). For information on ConsoleOne capabilities added by 
other products, see the documentation for those products.

This guide includes the following sections:

Chapter 1, “Getting Started,” on page 13

Chapter 2, “Administration Basics,” on page 29

Chapter 3, “Managing User Accounts,” on page 43

Chapter 4, “Administering Rights,” on page 49

Chapter 5, “Configuring Role-Based Administration,” on page 61

Chapter 6, “Extending the Novell eDirectory Schema,” on page 69

Chapter 7, “Partitioning and Replicating Novell eDirectory,” on page 79

Chapter 8, “Managing NetWare Server Resources,” on page 89

Chapter 9, “Generating Reports,” on page 99

Chapter 10, “Troubleshooting,” on page 111

Documentation Conventions
In this documentation, a greater-than symbol (>) is used to separate actions 
within a step and items in a cross-reference path.

Also, a trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk 
(*) denotes a third-party trademark.
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1 Getting Started

ConsoleOneTM is a Java*-based tool for managing your network and its 
resources. By default, it lets you manage:

Novell® eDirectoryTM objects, schema, partitions, and replicas

NetWare® server resources

If you install other Novell products, additional capabilities are snapped in to 
ConsoleOne automatically. For example, if you install Novell eDirectory, the 
capability to configure the LDAP interface to eDirectory is snapped in to 
ConsoleOne automatically.

This chapter explains what’s new in this ConsoleOne release, why you should 
use ConsoleOne instead of legacy tools like NetWare Administrator, and how 
to install and start ConsoleOne.

In This Chapter

“What’s New in This Release?” on page 13

“Why Use ConsoleOne?” on page 14

“Accessibility Improvements” on page 17

“Snap-Ins from Other Products” on page 17

“Installing and Starting ConsoleOne” on page 18

What’s New in This Release?
This release includes several core capabilities that are new since ConsoleOne 
1.2d. The following sections elsewhere in this guide describe these 
capabilities:
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“Accessibility Improvements” on page 17

“Checking Partition Continuity” on page 82

In addition, the following capabilities have been enhanced in this release of 
ConsoleOne:

Why Use ConsoleOne?
Novell is committed to ConsoleOne as a single management tool and is 
working hard to improve its capabilities and performance so you won’t need 
legacy tools like NetWare Administrator. Following are some of the 
advantages of ConsoleOne over legacy tools. A few limitations are also listed 
after the advantages.

Capability Enhancement

“Browsing and Finding 
Objects” on page 30

If a tree is running NDS eDirectory 8.5 or later and is 
configured for DNS federation, you can access 
contexts in that tree whether or not you are logged in 
to it. This enables you to make rights and 
membership assignments across trees.

“Creating User Accounts” 
on page 43

You can now create rights assignments and volume 
space restrictions for new users through a template.

“Defining and Using 
Auxiliary Classes” on 
page 72

You can now extend individual eDirectory objects 
with the properties defined in auxiliary classes. 
Previously, only applications could do this.

“Viewing and Modifying 
Server and File System 
Information” on page 90

You can now modify the properties of multiple files, 
folders, or volumes simultaneously. You can also 
launch NetWare Management Portal from the server 
object.

“Editing Object 
Properties” on page 36

You can now customize the property pages for each 
type of object by reordering, hiding, or showing 
individual pages. Your customizations are saved 
across ConsoleOne sessions.

“Installing and Starting 
ConsoleOne” on page 18

You can now install and run ConsoleOne on Linux*, 
Solaris*, and Tru64* computers in addition to 
Windows and NetWare.
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Advantage Explanation

Use on a Windows* 
computer or a NetWare 
server 

Because ConsoleOne is Java-based, it can run on Windows, NetWare, 
Linux*, Solaris*, and Tru64 UNIX*. The legacy NetWare Administrator, NDS 
ManagerTM, and Schema Manager tools run only on Windows. 

Manage the latest Novell 
products

ConsoleOne lets you manage the latest Novell products and enhancements, 
whereas NetWare Administrator and other legacy tools aren’t being updated 
to do so. For example, you can administer DirXML, Single Sign-on, and 
Certificate Server only in ConsoleOne.

Browse huge eDirectory 
trees

If your tree is running NDS 8 and has containers with thousands of objects, 
browsing it in ConsoleOne is faster and more consistent. NetWare 
Administrator is slower opening large containers and is limited by available 
RAM.

Access eDirectory 
resources through DNS 
federation

If a tree is running NDS eDirectory 8.5 or later and is configured for DNS 
federation, ConsoleOne lets you access contexts in that tree whether or not 
you are logged in to the tree. This allows you to treat multiple eDirectory trees 
as a single system for purposes of assigning rights and memberships. No 
legacy tool exposes this capability. See “Browsing and Finding Objects” on 
page 30.

Create filtered eDirectory 
replicas

If your tree is running NDS eDirectory 8.5 or later, ConsoleOne lets you create 
filtered replicas that contain only the objects and properties needed for 
synchronization with specific applications like PeopleSoft*. No legacy tool has 
this capability. See “Managing Replication” on page 85.

Generate eDirectory 
reports

ConsoleOne lets you generate reports on eDirectory objects, users, groups, 
and security. No legacy tool has these capabilities. See “Generating Reports” 
on page 99.

Create all eDirectory 
object types

ConsoleOne lets you create any object type defined in the schema of your 
eDirectory tree, including custom types you’ve added. NetWare Administrator 
can only create object types for which it has snap-ins. See “Creating and 
Manipulating Objects” on page 33.

Modify all object types, 
one at a time or several 
at once

ConsoleOne lets you generically edit any object property defined in the 
schema of your eDirectory tree, including custom properties you’ve added. No 
legacy tool has this capability. ConsoleOne also lets you modify multiple 
objects of any class in a single operation, including files and folders on 
NetWare volumes. NetWare Administrator lets you do this only on User 
objects. See “Creating and Manipulating Objects” on page 33.

Define and use auxiliary 
classes

ConsoleOne lets you define auxiliary classes and extend any eDirectory 
object with the properties defined in auxiliary classes. No legacy tool has this 
capability. See “Defining and Using Auxiliary Classes” on page 72.
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At the time of this publishing, ConsoleOne also has a few limitations 
compared to legacy tools. Most of these will no longer exist in future releases.

Assign ASN.1 identifiers 
to classes and attributes

ConsoleOne lets you assign ASN.1 identifiers to object classes and attributes 
in the schema of your eDirectory tree. No legacy tool has this capability. See 
“Defining Custom Object Classes and Properties” on page 70.

Set up role-based 
administration

ConsoleOne lets you create roles in eDirectory so you can delegate 
administrative responsibilities. A role is a list of specific application functions 
that a person can perform. For an application function to be added to a role, 
it must exist as a task object in your eDirectory tree. For details, see 
“Configuring Role-Based Administration” on page 61.

Limitation Explanation

Can’t manage print 
services

For now, you should use NetWare Administrator to manage network print 
services.

Can’t remotely repair 
eDirectory or check 
partition continuity 

For now, you should use the legacy NDS Manager tool to remotely repair 
eDirectory on individual servers, to check partition continuity, or to abort a 
partition operation that was started by another administrator.

Can’t generate 
eDirectory schema 
reports

For now, you should use the legacy Schema Manager tool to generate reports 
on the schema of your eDirectory tree, unless you design your own report 
forms to generate schema reports in ConsoleOne. See “Designing Custom 
Reports” on page 108. 

Can’t create or run new 
user setup scripts

ConsoleOne lets you create all aspects of user templates except for setup 
scripts. Also, ConsoleOne can’t execute a setup script when creating a new 
user account from a template. You must use NetWare Administrator to 
perform these tasks.

Can’t manage some 
older Novell products

A few older Novell products haven’t shipped ConsoleOne snap-ins yet, such 
as NetWare for SAA*. For now, you can use NetWare Administrator to 
manage these products.

Performance can be 
sluggish on older 
hardware

Because ConsoleOne is Java-based, it can be sluggish when run on older 
hardware. If you have the hardware configuration recommended in “Installing 
and Starting ConsoleOne” on page 18, performance is reasonably good. The 
biggest performance booster is adding RAM.

Minor user-interface 
quirks

ConsoleOne still has a few minor quirks in the user interface. For details, see 
“Known Quirks and Limitations” on page 115.

Advantage Explanation
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Accessibility Improvements
ConsoleOne 1.3 includes enhancements in the software and documentation to 
make accessibility easier for people with disabilities.

If you are unfamiliar with the control or shortcut keys used in Java software, 
you can find a list of these keys at the Swing Component Keystroke 
Assignments (http://java.sun.com/j2se/1.3/docs/api/javax/swing/doc-files/
Key-Index.html) Web site.

To navigate in the JavaHelp online help system, you can use the tab keys to 
navigate to control icons. JavaHelp loses focus when the text window is 
active, although the up and down arrows will scroll the help text. You can also 
use the following JavaHelp controls:

Ctrl+T = next link

Ctrl+Shift+T = previous link

Ctrl+Space = activate selected link

JavaHelp 1.1 is currently inaccessible via JAWS screen reader software. To 
access JavaHelp with a screen reader, use the IBM Self-Voicing Kit available 
from the AlphaWorks (http://www.alphaworks.ibm.com/formula/
selfvoicingkit) Web site.

Snap-Ins from Other Products
If you installed or will install a product that includes ConsoleOne snap-ins and 
you want to retain those snap-ins in this release of ConsoleOne, make sure 
those snap-ins are installed in the same place as this release of ConsoleOne. 
The following are some points to consider:

ConsoleOne 1.2 snap-ins are compatible with this release of ConsoleOne, 
but ConsoleOne 1.1 snap-ins aren’t.

If your product provides only ConsoleOne 1.1 snap-ins, you might want 
to install this release of ConsoleOne in a different place than ConsoleOne 
1.1. By default, ConsoleOne 1.1 is installed on the NetWare server in 
SYS:\PUBLIC\MGMT\CONSOLE1.

Novell products typically install ConsoleOne snap-ins on the SYS 
volume of a NetWare server. For example, NDS 8 installs an LDAP snap-
in in SYS:\PUBLIC\MGMT\CONSOLEONE\1.2.
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If you install this release of ConsoleOne on the SYS volume of a NetWare 
server, it overwrites ConsoleOne 1.2x and disables ConsoleOne 1.1. 
However, existing ConsoleOne 1.2 snap-ins are retained.

If you install this release of ConsoleOne locally on a workstation hard 
disk, other products such as eDirectory might not be able to find the right 
place to add snap-ins to the installation. In such a case, it is up to you to 
move any snap-ins from other products into the new installation.

Installing and Starting ConsoleOne
ConsoleOne is typically installed as part of a larger product, such as Novell 
eDirectory or NetWare. If this release of ConsoleOne hasn’t been installed by 
a larger product, you can install it using the procedure below for your 
platform.

In This Section

“Windows” on page 18

“NetWare” on page 21

“Linux” on page 23

“Solaris” on page 25

“Tru64 UNIX” on page 27

Windows
You can install and run ConsoleOne locally on a Windows workstation or 
server, or you can install it remotely on a NetWare or Windows server and run 
it through a mapped or shared drive pointing to that server. If you install 
locally on a workstation, other Novell products such as Novell eDirectory 
might not be able to add needed snap-ins to your installation. For this reason, 
we recommend a server installation.
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System Requirements for Windows 

Installing ConsoleOne on Windows

Use this procedure to install ConsoleOne locally on a Windows server or 
workstation. To install ConsoleOne remotely on a NetWare server, see 
“NetWare” on page 21.

1 If a previous version of ConsoleOne is running on the Windows 
computer, exit it.

2 Insert the CD that contains ConsoleOne, or go to the Novell Free 
Downloads Site (http://www.novell.com/download).

3 Browse the CD or Web site until you find the available ConsoleOne 
packages > select the package for Windows/NetWare.
HINT: If you are using a CD that runs an installation program and you see an 
option to install just ConsoleOne, choose that option and skip to Step 6.

4 If you are using the Web site, download and unzip the ConsoleOne files 
to a temporary area. If you are using a CD, skip this step.

5 Run the installation executable file (SETUP.EXE or 
CONSOLEONE.EXE).

6 Follow the instructions on the screen to complete the installation.

Operating System One of the following (or later) releases:

Windows 95/98 with Novell ClientTM 3.2

Windows NT*/2000 with Novell Client 4.7

HINT: You can get Novell clients from the Novell Free Downloads Site (http://
www.novell.com/download).

RAM Recommended: 128 MB

Minimum: 64 MB

HINT: 128 MB is required to generate reports in ConsoleOne.

Processor Recommended: 200 MHz or faster

Disk Space 38 MB (required only for a local installation)

Screen Resolution Minimum: 800 x 600 with 256 colors
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HINT: If you are installing on a Windows server and you will run ConsoleOne 
remotely through drive sharing, don’t forget to share the folder where you install 
ConsoleOne. Some Novell products require that this share be established before 
running the installation program.

Starting ConsoleOne on Windows

If ConsoleOne is installed locally on the Windows computer, simply double-
click the ConsoleOne icon on the desktop.

If ConsoleOne is installed remotely on a NetWare or Windows server and you 
don’t have a shortcut to that installation, do the following:

1 In Windows Explorer, find the mapped or shared drive that represents the 
server volume where ConsoleOne is installed > browse to the folder 
where ConsoleOne is installed. 

By default, this is:

IMPORTANT: You must browse for ConsoleOne on a drive that is mapped to a 
letter, not a UNC path.

2 In the BIN subfolder, double-click CONSOLEONE.EXE.

3 (Optional) For future use, create a shortcut on your desktop to the remote 
CONSOLEONE.EXE file.

For help with navigating and performing basic tasks in ConsoleOne, see 
“Administration Basics” on page 29. If you encounter problems starting or 
using ConsoleOne, see “Troubleshooting” on page 111.

Configuring ConsoleOne Accessibility

To make ConsoleOne accessible to Windows assistive technologies, you must 
install the Java Access Bridge. The Java Access Bridge is a technology used 
to expose the Java Accessibility API in a Windows DLL so that Windows 
assistive technologies can provide access to applications and applets running 
with a Java Virtual Machine running on a Windows system which implement 
the Java Accessibility API.

To set up the Java Access Bridge for use with ConsoleOne, follow these steps:

Windows C:\NOVELL\CONSOLEONE\1.2

NetWare SYS:PUBLIC\MGMT\CONSOLEONE\1.2
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1 Download the Java Access Bridge from the Java Access Bridge  (http://
java.sun.com/products/accessbridge) Web site.

2 Unpack the Java Access Bridge into the C:\ACCESSBRIDGE-1_0 
directory > run the following command: 

C:\ACCESSBRIDGE-1_0\INSTALLER\INSTALL

For more information on installing and configuring the Java Access 
Bridge, see the Java Access Bridge Readme (http://java.sun.com/
products/accessbridge/README.txt).

3 Place a copy of the following files in your 
NOVELL\CONSOLEONE\1.2\CONSOLEONEEXT directory:

JACCESS-1_3.JAR
ACCESS-BRIDGE.JAR

4 Place a copy of ACCESSIBILITY.PROPERTIES in your 
NOVELL\CONSOLEONE\1.2\JRE\LIB directory.

5 Copy the following files to your Windows DLL directory (for example, 
C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM): 

JAVAACCESSBRIDGE.DLL
WINDOWSACCESSBRIDGE.DLL

NetWare
If you install ConsoleOne on a NetWare server, you can run it locally on that 
server or remotely on a Windows computer with a drive mapped to that server. 
Installing ConsoleOne on a NetWare server also allows other Novell products 
such as eDirectory to add needed snap-ins to your installation.

System Requirements for NetWare

Operating System NetWare 5 Support Pack 3 or later

HINT: You can get NetWare support packs from the Minimum Patch List site 
(http://support.novell.com/misc/patlst.htm).

Processor Recommended: 200 MHz or faster

Disk Space 38 MB

Screen Resolution Minimum: 800 x 600 with 256 colors (required only to run locally on the server)
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Installing ConsoleOne on NetWare

1 Bring down Java and any Java applications that are running on the server, 
including the server GUI. 

You can do this by entering JAVA -EXIT at the console prompt.

2 Have all users who are currently running ConsoleOne remotely through a 
connection to the server exit their ConsoleOne sessions.

3 At a Windows workstation, map a drive letter to the root of the server’s 
SYS volume.

4 At the same workstation, insert the CD that contains ConsoleOne, or go 
to the Novell Free Downloads site (http://www.novell.com/download).

5 Browse the CD or Web site until you find the available ConsoleOne 
packages > select the package for Windows/NetWare.
HINT: If you are using a CD that runs an installation program and you see an 
option to install just ConsoleOne, choose that option and skip to Step 8.

6 If you are using the Web site, download and unzip the ConsoleOne files 
to a temporary area. If you are using a CD, skip this step.

7 Run the installation executable file (SETUP.EXE or 
CONSOLEONE.EXE).

8 Follow the instructions on the screen to complete the installation. When 
you are prompted for the location to install to, select the drive that is 
mapped to the root of the server’s SYS volume.
IMPORTANT: You must select a drive that is mapped to a letter, not a UNC path.

Starting ConsoleOne on NetWare

To start ConsoleOne locally on a NetWare server, enter C1START at the 
console prompt.

To start ConsoleOne remotely from a Windows computer with a drive mapped 
to the NetWare server, see “Starting ConsoleOne on Windows” on page 20.

For help with navigating and performing basic tasks in ConsoleOne, see 
“Administration Basics” on page 29. If you encounter problems starting or 
using ConsoleOne, see “Troubleshooting” on page 111.
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Linux
You can install and run ConsoleOne locally on a Linux computer. You can also 
run it from another computer through an X terminal (remote) session, if that 
computer has an X windowing subsystem.

System Requirements for Linux

IMPORTANT: This release of ConsoleOne for Linux has been tested only on the 
IBM* 1.3 Java runtime environment (JRE). This JRE is included in the ConsoleOne 
installation package in case you don’t have it. If you do have it, you can choose not 
to install it.

IMPORTANT:  This release of ConsoleOne is compatible with NDS eDirectory 8.5 
and later releases but not with earlier releases. If the ConsoleOne installation 
program detects that an eDirectory release earlier than 8.5 is on the machine, it will 
abort the installation.

Installing ConsoleOne on Linux

1 If previous versions of ConsoleOne and eDirectory are running on the 
Linux computer, shut them down and uninstall them completely from the 
system (remove all the associated files).

2 Insert the CD that contains ConsoleOne, or go to the Novell Free 
Downloads site (http://www.novell.com/download).

Operating System One of the following (or later) releases:

Red Hat* OpenLinux 6

Caldera* eDesktop 2.4

Caldera eServer 2.3

RAM Recommended: 128 MB

Minimum: 64 MB

Processor Recommended: 200 MHz or faster

Disk Space With JRE: 32 MB

Without JRE: 5 MB

Screen Resolution Minimum: 800 x 600 with 256 colors
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3 Locate the ConsoleOne installation program (the c1-install file) on the 
CD or by downloading it from the Web site as follows:

4 Run the ConsoleOne installation program (type c1-install at the 
system prompt).

5 Follow the prompts to complete the installation. 
IMPORTANT: This release of ConsoleOne for Linux has been tested only on the 
IBM 1.3 Java runtime environment (JRE). This JRE is included in the ConsoleOne 
installation package in case you don’t have it. If you do have it and it’s already 
installed, select No when you are prompted whether to install it.

After ConsoleOne is installed, you can uninstall it at any time by entering the 
c1-uninstall command at the system prompt. The c1-install and c1-
uninstall commands can include some optional parameters for running in 
unattended mode or installing/uninstalling individual components. For details 
on the command syntax, type c1-install -h or c1-uninstall -h at 
the system prompt. For a log of ConsoleOne installation or uninstallation 
results, see the corresponding log file created in the /var directory. 

Starting ConsoleOne on Linux

At the system prompt of a local session or an X terminal (remote) session, 
enter the following command:

/usr/ConsoleOne/bin/ConsoleOne

For help with navigating and performing basic tasks in ConsoleOne, see 
“Administration Basics” on page 29. If you encounter problems starting or 
using ConsoleOne, see “Troubleshooting” on page 111.

Source Steps to Locate the c1-install File

CD Change to the ConsoleOne/Linux directory.

Web site 1. Click Management > ConsoleOne for Linux.

2. Follow the instructions on the Web site to download the 
ConsoleOne package (the c1linux.tar file).

3. Unpack the file you just downloaded (type tar xf 
c1linux.tar at the system prompt).

4. Change to the ConsoleOne/Linux directory that was 
created by unpacking the download file.
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Solaris
You can install and run ConsoleOne locally on a Solaris computer. You can 
also run it from another computer through an X terminal (remote) session, if 
that computer has an X windowing subsystem.

System Requirements for Solaris

IMPORTANT: This release of ConsoleOne for Solaris has been tested only on the 
Sun* 1.2.2-5a Java runtime environment (JRE). This JRE is included in the 
ConsoleOne installation package in case you don’t have it. If you do have it, you 
can choose not to install it.

IMPORTANT:  This release of ConsoleOne is compatible with NDS eDirectory 8.5 
and later releases but not with earlier releases. If the ConsoleOne installation 
program detects that an eDirectory release earlier than 8.5 is on the machine, it will 
abort the installation.

Installing ConsoleOne on Solaris

1 If previous versions of ConsoleOne and eDirectory are running on the 
Solaris computer, shut them down and uninstall them completely from the 
system (remove all the associated files).

2 Insert the CD that contains ConsoleOne, or go to the Novell Free 
Downloads site (http://www.novell.com/download).

3 Locate the ConsoleOne installation program (the c1-install file) on the 
CD or by downloading it from the Web site as follows:

Operating System One of the following (or later) releases:

Solaris 2.6 or 7 with the latest patch

Solaris 8

HINT: You can get Solaris patches at SunSolve Online 
(http://sunsolve.sun.com).

Disk Space With JRE: 64 MB

Without JRE: 10 MB

Screen Resolution Minimum: 800 x 600 with 256 colors
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4 Run the ConsoleOne installation program (type c1-install at the 
system prompt).

5 Follow the prompts to complete the installation. 
IMPORTANT: This release of ConsoleOne for Solaris has been tested only on the 
Sun 1.2.2-5a Java runtime environment (JRE). This JRE is included in the 
ConsoleOne installation package in case you don’t have it. If you do have it and 
it’s already installed, select No when you are prompted whether to install it.

After ConsoleOne is installed, you can uninstall it at any time by entering the 
c1-uninstall command at the system prompt. The c1-install and c1-
uninstall commands can include some optional parameters for running in 
unattended mode or installing/uninstalling individual components. For details 
on the command syntax, type c1-install -h or c1-uninstall -h at 
the system prompt. For a log of ConsoleOne installation or uninstallation 
results, see the corresponding log file created in the /var directory. 

Starting ConsoleOne on Solaris

At the system prompt of a local session or an X terminal (remote) session, 
enter the following command:

/usr/ConsoleOne/bin/ConsoleOne

For help with navigating and performing basic tasks in ConsoleOne, see 
“Administration Basics” on page 29. If you encounter problems starting or 
using ConsoleOne, see “Troubleshooting” on page 111.

Source Steps to Locate the c1-install File

CD Change to the ConsoleOne/Solaris directory.

Web site 1. Click Management > ConsoleOne for Solaris.

2. Follow the instructions on the Web site to download the 
ConsoleOne package (the c1sol.tar file).

3. Unpack the file you just downloaded (type tar xf 
c1sol.tar at the system prompt).

4. Change to the ConsoleOne/Solaris directory that was 
created by unpacking the download file.
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Tru64 UNIX
You can install and run ConsoleOne locally on a Tru64 UNIX computer. You 
can also run it from another computer through an X terminal (remote) session, 
if that computer has an X windowing subsystem.

System Requirements for Tru64 UNIX

IMPORTANT: This release of ConsoleOne for Tru64 UNIX has been tested only 
on the Compaq* 1.2.2 Java runtime environment (JRE). This JRE is included in the 
ConsoleOne installation package in case you don’t have it. If you do have it, you 
can choose not to install it.

IMPORTANT:  This release of ConsoleOne is compatible with NDS eDirectory 8.5 
and later releases but not with earlier releases. If the ConsoleOne installation 
program detects that an eDirectory release earlier than 8.5 is on the machine, it will 
abort the installation.

Installing ConsoleOne on Tru64

1 If previous versions of ConsoleOne and eDirectory are running on the 
Tru64 UNIX computer, shut them down and uninstall them completely 
from the system (remove all the associated files).

2 Insert the CD that contains ConsoleOne, or go to the Novell Free 
Downloads site (http://www.novell.com/download).

3 Locate the ConsoleOne installation program (the c1-install file) on the 
CD or by downloading it from the Web site as follows:

Operating System Compaq Tru64 UNIX 5.0a or later

RAM Recommended: 128 MB

Minimum: 64 MB

Disk Space With JRE: 20 MB

Without JRE: 5 MB

Screen Resolution Minimum: 800 x 600 with 256 colors
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4 Run the ConsoleOne installation program (type c1-install at the 
system prompt).

5 Follow the prompts to complete the installation. 
IMPORTANT: This release of ConsoleOne for Tru64 UNIX has been tested only 
on the Compaq* 1.2.2 Java runtime environment (JRE). This JRE is included in the 
ConsoleOne installation package in case you don’t have it. If you do have it and 
it’s already installed, select No when you are prompted whether to install it.

After ConsoleOne is installed, you can uninstall it at any time by entering the 
c1-uninstall command at the system prompt. The c1-install and c1-
uninstall commands can include some optional parameters for running in 
unattended mode or installing/uninstalling individual components. For details 
on the command syntax, type c1-install -h or c1-uninstall -h at 
the system prompt. For a log of ConsoleOne installation or uninstallation 
results, see the corresponding log file created in the /var directory. 

Starting ConsoleOne on Tru64 UNIX

At the system prompt of a local session or an X terminal (remote) session, 
enter the following command:

/usr/ConsoleOne/bin/ConsoleOne

For help with navigating and performing basic tasks in ConsoleOne, see 
“Administration Basics” on page 29. If you encounter problems starting or 
using ConsoleOne, see “Troubleshooting” on page 111.

Source Steps to Locate the c1-install File

CD Change to the ConsoleOne/Tru64 directory.

Web site 1. Click Management > ConsoleOne for Tru64.

2. Follow the instructions on the Web site to download the 
ConsoleOne package (the c1tru64.tar file).

3. Unpack the file you just downloaded (type tar xf 
c1tru64.tar at the system prompt).

4. Change to the ConsoleOne/Tru64 directory that was 
created by unpacking the download file.
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2 Administration Basics

In ConsoleOneTM, your network and its resources are presented as a set of 
objects that are organized into various containers, with My World at the top. 
Use the left pane to expand and collapse containers. Use the right pane to work 
with specific resources. 

Figure 1 ConsoleOne Management Tool

In general, you perform administration tasks by browsing to an object, right-
clicking it, and then selecting an action. The available actions depend on the 
type of object. For example, the New Object action is available only on 
containers.
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This chapter explains how to perform essential tasks like finding objects, 
creating and modifying objects, and organizing objects into containers. For 
information on common Novell® eDirectoryTM object types, see Novell 
eDirectory Administration Guide > Object Classes and Properties.

In This Chapter

“Browsing and Finding Objects” on page 30

“Creating and Manipulating Objects” on page 33

“Editing Object Properties” on page 36

“Organizing Objects into Containers” on page 38

“Customizing Views” on page 41

Browsing and Finding Objects
In the left pane you’ll see the "NDS" container, which holds the eDirectory 
trees that you are currently logged in to. You can cause additional eDirectory 
trees to appear in the NDS container by logging in to those trees. For trees that 
are running NDS® eDirectory 8.5 or later and are configured for DNS 
federation, you can cause specific contexts of those trees to appear in the NDS 
container without actually logging in to those trees.

Once you are in an eDirectory tree or context and its objects are listed in the 
right pane, you can use the techniques described below to locate the specific 
objects you want to manage.

In This Section

“Logging In to an eDirectory Tree” on page 31

“Logging Out of an eDirectory Tree” on page 31

“Accessing an eDirectory Context through DNS Federation” on page 31

“Jumping to an Object in the Right Pane” on page 31

“Filtering Extraneous Objects from View” on page 32

“Finding an Object by Distinguished Name” on page 32

“Finding an Object by Name and Type” on page 32

“Finding Objects by Property Values” on page 33
30 ConsoleOne User Guide

ConsoleOne User Guide
104-001316-001
August 29, 2001

Novell Confidential



Manual 99a38 July 17, 2001
Logging In to an eDirectory Tree
1 Click anywhere in the "NDS" container.

2 On the toolbar, click NDS Authenticate.

3 Fill in the Login dialog box.
HINT: To see a list of the eDirectory trees you can log in to, click the tree icon. If 
the tree you want isn’t listed, see “Can’t Find the eDirectory Tree That I Want to 
Log In To” on page 113.

4 Click Login.

The new tree is added to the NDS container in ConsoleOne.

Logging Out of an eDirectory Tree
1 Click the eDirectory tree that you want to log out of.

2 On the toolbar, click NDS Unauthenticate.

The tree is removed from the NDS container.

Accessing an eDirectory Context through DNS Federation
This procedure works only if the target eDirectory context is in a tree that is 
running NDS eDirectory 8.5 or later and is configured for DNS federation.

1 Click anywhere in the "NDS" container.

2 Click View > Set Context.

3 Enter the full DNS name for the eDirectory context that you are trying to 
access, including an ending dns and a period (.).

Example:  sales.xyz.com.dns.

4 Click OK.

If the DNS name resolves correctly, the eDirectory context you are trying to 
access should appear in the NDS container. You can browse and manage 
objects in the eDirectory context the same as in any eDirectory tree.

Jumping to an Object in the Right Pane
1 Click anywhere in the right pane.

2 Start typing the name of an object in the current container or view > press 
Enter to jump to the object.
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Filtering Extraneous Objects from View
Any filters you apply to a view remain in effect for your current ConsoleOne 
session only. When you restart ConsoleOne, they are cleared.

1 Click View > Filter.

2 (Optional) In Name, enter a wildcard pattern to apply as a filter on the 
object names. 

An asterisk (*) is the only wildcard allowed.

Example: xyz* hides all objects except those whose names start with 
"xyz."

3 Under Object Type, select the object types you want shown and deselect 
those you want hidden.

4 Click OK.

Finding an Object by Distinguished Name
1 In the left pane, click any part of the eDirectory tree that contains the 

object.

2 Begin typing the name of the object to go to.

As you type, the Go To dialog box appears.

3 Finish typing the distinguished name of the object. 

Click Help for details on using separators and other special characters.

Example: djones.salses.xyz_corp

4 Click OK.

Finding an Object by Name and Type
1 In the left pane, click the eDirectory container that you want to start 

searching from.

2 Click Edit > Find.

3 If you want to include subcontainers in the search, select Search 
Subcontainers.

4 In Name, enter all or part of the object name. 

If you enter only part of the name, include an asterisk wildcard.

Example: johnw*
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5 In Object Type, select the type of object to find.

6 Click Find.

In the search results list, you can right-click objects to perform actions 
just like in the ConsoleOne right pane.

Finding Objects by Property Values
1 In the left pane, click the eDirectory container that you want to start 

searching from.

2 Click Edit > Find.

3 In Find Type, select Advanced.

4 In the query-building area of the dialog box, specify your search criteria. 

Click Help for details.

5 Click Find.

In the search results list, you can right-click objects to perform actions 
just like in the ConsoleOne right pane.

Creating and Manipulating Objects
Once you have located the network resources (objects) you want to manage, 
you can change their behavior by modifying their properties. You can also 
delete, move, and rename objects or create new ones as needed.

In This Section

“Creating an Object” on page 34

“Modifying an Object’s Properties” on page 35

“Modifying Multiple Objects Simultaneously” on page 35

“Renaming an Object” on page 35

“Moving Objects” on page 36

“Deleting Objects” on page 36
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Creating an Object
1 Right-click the container that you want to create the object in > click New 

> click Object.

There are restrictions on the types of objects you can create in different 
container types. For details, see the documentation for your particular 
task or application.

2 Under Class, select the type of object > click OK.

3 If you get a warning that no snap-in is available to create the object, 
complete the appropriate action from the table below, depending on your 
level of understanding of the object you are creating.

4 In Name, enter a name for the new object. 

If it’s an eDirectory object, be sure to follow proper naming conventions. 
See Novell eDirectory Administration Guide > Naming Conventions for 
details.

5 Specify any other information requested in the dialog box. 

Click Help for details. (If you are using generic editors, no details are 
available.)

6 Click OK.

Understanding Level Action

Thorough—you understand 
this object type and how its 
properties are used.

Click Yes in the warning box.

You will be allowed to set the object’s 
mandatory properties using generic editors. 
After creating the object, you can set other 
properties using the generic Other property 
page.

Minimal—you understand 
what the object is but not how 
its properties are used in any 
detail.

Click No in the warning box > quit this 
procedure.

You will need to install a product that 
provides a ConsoleOne snap-in to create 
and manage this object type.
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Modifying an Object’s Properties
1 Right-click the object > click Properties.

2 Edit the property pages you want. 

Click Help for details on specific properties. See “Editing Object 
Properties” on page 36 for general information on using property pages.

3 Click OK.

Modifying Multiple Objects Simultaneously
1 Select the objects using one of the following methods:

In the right pane, Shift+click or Ctrl+click multiple objects of the 
same type

Click a group or template object to modify its members

Click a container to modify the objects it contains

2 Click File > Properties of Multiple Objects.

3 If you selected a container in Step 1, in the dialog box double-click the 
object type that you want to modify; otherwise, skip this step.

4 On the Objects to Modify page, make sure only the objects that you want 
to modify are listed. 

Add and delete objects as needed.

5 On the other property pages, specify the property values to set for all the 
selected objects. 

Click Help for details on specific properties.
IMPORTANT: See “Editing Object Properties” on page 36 for differences in how 
property pages work when editing multiple objects.

6 Click OK.

Renaming an Object
1 Right-click the object > click Rename.

2 In New Name, enter the new name. 

If it’s an eDirectory object, be sure to following proper naming 
conventions. See Novell eDirectory Administration Guide > Naming 
Conventions for details.
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3 Click Save Old Name if you want to save the old name of the object.

The old name is stored in the Other Name field of the object’s General 
Identification property page.

4 Click OK.

Moving Objects
1 In the right pane, Shift+click or Ctrl+click the objects to select them.

HINT: You can’t move a container object unless it’s a partition root. For details, 
see “Managing Partitions” on page 80.

2 Right-click your selection > click Move.

3 Click the browse button next to the Destination field > select the container 
to move the objects to > click OK.

4 If you want to create an alias in the old location for each object being 
moved, select Create an Alias for All Objects Being Moved.

This allows any operations that are dependent on the old location to 
continue uninterrupted until you can update those operations to reflect the 
new location.

5 Click OK.

Deleting Objects
1 Shift+click or Ctrl+click the objects to select them.

You can't delete a container object unless you first delete all its contents.

2 Right-click your selection > click Delete.

3 In the confirmation dialog box, click Yes.

Editing Object Properties
You can control an object's behavior by editing its properties. When using 
property pages, there are some general characteristics you need to be aware of 
as well as some characteristics that are unique to editing multiple objects 
simultaneously. You can also customize property pages.
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In This Section

“General Characteristics” on page 37

“Unique Characteristics of Editing Multiple Objects Simultaneously” on 
page 37

“Customizing Property Pages” on page 38

General Characteristics
The table below describes the general characteristics of using property pages.

Unique Characteristics of Editing Multiple Objects Simultaneously
The table below describes the unique characteristics of using property pages 
to edit multiple objects simultaneously.

Feature Notes

OK, Cancel, Apply These buttons affect all the property pages. OK and Apply save all changes to all 
pages (Apply leaves the dialog box open), and Cancel discards all changes on all 
pages.

Tabs Each tab can have multiple property pages. To select the page you want, click the 
drop-down list on the tab.

Fields that have this control beside them can have multiple values. To see all the 
values, click the control. To enter multiple values, type a value > press Enter > type 
another value > press Enter, and so on.

Disabled fields and 
options

Fields and options are disabled if:

You don’t have rights to modify the associated properties

You need to modify some other setting first to enable the fields or options

Feature Notes

Fields and lists No values are displayed in fields or lists because the existing values might 
be different for each object.

For a single-value field, any value you enter will replace the existing value in 
each object when you click OK or Apply.

For a multi-value field or list, any values you enter will be added to the 
existing values in each object when you click OK or Apply.
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Customizing Property Pages
For each type of object in ConsoleOne, you can customize the property pages 
by rearranging their order or hiding individual pages.

Your customizations are saved and used the next time you start ConsoleOne 
on the same computer.

1 Open the properties of an object of the type that you want to customize > 
click Page Options.

2 Rearrange the property pages the way you want.

2a To move a tab or page to a different position, select it > click Move 
Up or Move Down. 

You can’t move a page to a different tab.

2b To hide or show a tab or page, select it > click Disable or Enable. 

Disabled items appear gray.

3 Click OK.

Organizing Objects into Containers
Once you are in an eDirectory tree, you can organize it by creating various 
types of containers and placing objects inside them. Objects in a container are 
security equivalent to the container automatically, so make sure you manage 
the container’s rights accordingly. You can create aliases to provide access to 
a single object from multiple containers.

Check boxes Light-gray check boxes with a check in them are neutral. No changes will be 
made to these items in the existing objects when you click OK or Apply.

White check boxes and dark-gray check boxes are live. Their settings will 
replace the existing settings in each object when you click OK or Apply.

Missing items Individual fields and options are missing if they apply only to specific object 
instances. For example, it isn’t necessary to give multiple users the same 
last name, so the Last Name field is not displayed when editing multiple 
users.

Entire property pages are missing if they haven’t been designed to allow 
editing of multiple objects. For example, the generic Other page isn’t 
displayed when editing multiple objects.

Feature Notes
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Below are procedures to create common container types and aliases. For 
information on creating container types for specific applications, see the 
documentation for those applications. For general eDirectory tree design 
considerations, see Novell eDirectory Administration Guide > Designing Your 
Novell eDirectory Network.

In This Section

“Creating an Organization Object” on page 39

“Creating an Organizational Unit Object” on page 39

“Creating a Locality Object” on page 40

“Creating a Country Object” on page 40

“Creating an Alias to an Object” on page 41

Creating an Organization Object
1 Right-click the tree, country, locality, or domain object that you want to 

create the organization object in > click New > click Object.

2 Under Class, select Organization > click OK.

3 In Name, enter a name up to 64 characters long. 

Make sure to follow proper naming conventions. See Novell eDirectory 
Administration Guide > Designing Your Novell eDirectory Network for 
details.

Example: XYZ_CORP

4 If you want to assign additional property values as part of the creation 
process for the container, select Define Additional Properties.

For example, you might want to create a login script or set up intruder 
detection for the container.

5 Click OK.

Creating an Organizational Unit Object
1 Right-click the organization, organizational unit, locality, or domain 

object that you want to create the new organizational unit object in > click 
New > click Organizational Unit.
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2 In Name, enter a name up to 64 characters long. 

Make sure to follow proper naming conventions. See Novell eDirectory 
Administration Guide > Naming Conventions for details.

Example: Marketing

3 If you want to assign additional property values as part of the creation 
process for the container, select Define Additional Properties.

For example, you might want to create a login script or set up intruder 
detection for the container.

4 Click OK.

Creating a Locality Object
1 Right-click the country, locality, domain, organization, or organizational 

unit object that you want to create the locality object in > click New > 
click Object.

2 Under Class, select Locality > click OK.

3 Fill in the Name and Named By fields. 

Click Help for details.

4 Click OK.

Creating a Country Object
1 Right-click a tree or domain object > click New > click Object.

2 Under Class, select Country > click OK.

3 In Name, enter the two-letter ISO country code. 

Click Help for details.

Example: FR for France

4 If you want to assign additional property values as part of the creation 
process for the container, select Define Additional Properties.

For example, you might want to provide a more descriptive name for the 
country.

5 Click OK.
40 ConsoleOne User Guide

ConsoleOne User Guide
104-001316-001
August 29, 2001

Novell Confidential



Manual 99a38 July 17, 2001
Creating an Alias to an Object
1 Right-click the container that you want to create the alias in > click New 

> click Object.

2 Under Class, select Alias > click OK.

3 In Name, enter a name up to 64 characters long. 

Make sure to follow proper naming conventions. See Novell eDirectory 
Administration Guide > Naming Conventions for details.

Example: SalesVolumeAlias

4 Click the browse button next to the Object field > select the object you 
want the alias to represent > click OK.

5 If you want to assign additional property values as part of the creation 
process for the alias, select Define Additional Properties.

For example, you might want to assign trustees of the alias.

6 Click OK.

Users can use the alias as though it were the actual object that it 
represents.

Customizing Views
You can customize the views in the left and right panes in various ways. For 
example, you can set a different object than My World at the top of the left 
pane, and you can adjust the column width in the right pane. You can also 
show or hide the view title in the right pane. In an eDirectory tree, you can 
filter objects from view in the right pane. (See “Browsing and Finding 
Objects” on page 30.)

HINT: Most customizations to the left and right pane are lost when you exit 
ConsoleOne. Only the window size, position, and view title setting are saved. 

In This Section

“Setting the Top Object in the Left Pane” on page 42

“Showing or Hiding the View Title in the Right Pane” on page 42

“Adjusting the Column Width in the Right Pane” on page 42
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Setting the Top Object in the Left Pane
The steps to use depend on which object you want to set at the top, as 
described in the table below.

Showing or Hiding the View Title in the Right Pane
By default, the right pane contains the Console view. You can switch it to the 
Partition and Replica view or to another view if one has been added by a snap-
in. Regardless of which view the right pane contains, you can show or hide the 
view title at the top of the right pane.

Your setting to show or hide the view title is saved and used the next time you 
start ConsoleOne on the same computer.

To show or hide the view title, click View > Show View Title. A check mark 
is added to or removed from the menu item, depending on whether the view 
title is being shown or hidden.

Adjusting the Column Width in the Right Pane
1 Move the mouse pointer to the margin between the first and second 

columns.

2 When the pointer changes to a sizing arrow, drag the column to the width 
you want.

Object to Set at the Top Steps

A container that’s below the current top 
object

Right-click the container > click Set As 
Root. 

A container that’s above the current top 
object Double-click  in the left pane until 

the container appears.

My World Right-click  in the left pane > click 
Show My World.
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3 Managing User Accounts

Setting up a Novell® eDirectoryTM user account involves creating a User 
object and setting properties to control login and the user's network computing 
environment. You can use a template object to facilitate these tasks.

You can create login scripts to cause users to be connected automatically to the 
files, printers, and other network resources they need when they log in. If 
several users use the same resources, you can put the login script commands 
in container and profile login scripts.

In This Chapter

“Creating User Accounts” on page 43

“Setting Up Optional Account Features” on page 45

“Setting Up Login Scripts” on page 47

“Login Time Restrictions for Remote Users” on page 48

Creating User Accounts
A user account is a User object in the eDirectory tree. A User object specifies 
a user's login name and supplies other information used by eDirectory and 
NetWare® to control the user’s access to network resources. You can define 
user properties ahead of time in a template, before actually creating the User 
object.

In This Section

“Creating a User Object” on page 44

“Creating a User Template” on page 44
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Creating a User Object
1 Right-click the container that you want to create the User object in > click 

New > click User.

2 Fill in the New User dialog box. 

Click Help for details.

2a To apply a template during creation of the user object, select Use 
Template.

2b To set additional user properties during creation of the user object, 
select Define Additional Properties.

3 Click OK.

4 If the Set Password dialog box appears, set the user’s login password > 
click OK.
IMPORTANT: If this dialog box appears and you cancel it, an eDirectory 
password (object-key pair) won't be created for the user account and the user 
won't be able to log in unless you set up some other means of authentication, such 
as an NMAS password. You can set an eDirectory password later on the Password 
Restrictions property page of the User object. If you leave the password blank and 
click OK, the User object is created with a blank (null) eDirectory password and the 
user can log in without entering a password.

Creating a User Template
1 Right-click the container that you want to create the Template object in > 

click New > click Object.

2 Under Class, select Template > click OK.

3 Fill in the New Template dialog box. 

Click Help for details.

3a To clone an existing Template or User object, select Use Template or 
User.

3b To set template properties immediately after creating the Template 
object, select Define Additional Properties. 

After clicking OK, you’ll see property pages that look similar to 
those of a User object. Help is available on all the property pages.

4 Click OK.
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Setting Up Optional Account Features
After creating a User object, you can optionally set up the user's network 
computing environment, implement extra login security features, and set up 
an accounting of the user’s NetWare server usage.

In This Section

“Setting Up a User’s Network Computing Environment” on page 45

“Setting Up Extra Login Security for a User” on page 45

“Setting Up an Accounting of a User’s NetWare Server Usage” on page 
46

Setting Up a User’s Network Computing Environment
1 Right-click the User or Template object that you want to set up the 

network computing environment for > click Properties.

Use a Template object if you haven’t created the User object yet.

2 On the General tab, select the Environment page.

3 Fill in the property page. 

Click Help for details.

4 Click OK.

Setting Up Extra Login Security for a User
1 Right-click the User or Template object that you want to set up login 

security for > click Properties.

Use a Template object if you haven’t created the User object yet.

2 On the Restrictions tab, fill in the property pages you want. 

Click Help for details on any page.

Page Use to

Password Restrictions Set up a login password.

Address Restrictions Restrict the locations the user can log in from.
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3 Click OK.

4 To set up intruder detection for all the User objects in a container:

4a Right-click the container > click Properties.

4b On the General tab, select the Intruder Detection page.

4c Fill in the property page. 

Click Help for details.

4d Click OK.

Setting Up an Accounting of a User’s NetWare Server Usage
1 Right-click the User or Template object that you want to set up the 

accounting for > click Properties.

Use a Template object if you haven’t created the User object yet.

2 On the Restrictions tab, select the Account Balance page.

3 Fill in the property page. 

Click Help for details.

4 Click OK.

5 Use NetWare Administrator to set up one or more NetWare servers to 
charge for network services. 

See the NetWare Administrator online help for details.

Time Restrictions Restrict the times when the user can be logged 
in. If the user will log in remotely, see “Login 
Time Restrictions for Remote Users” on page 
48.

Login Restrictions Limit the number of concurrent login 
sessions.

Set a login expiration and lockout date.

Page Use to
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Setting Up Login Scripts
A login script is a list of commands that executes when a user logs in. It is 
typically used to connect the user to network resources like files and printers. 
Login scripts execute on the user's workstation in the following order:

1. Container login script

2. Profile login script

3. User login script

During login, if the system doesn’t find any of these login scripts, it skips to 
the next one in the list. If none are found, the system executes a default script 
that maps a search drive to the SYS:PUBLIC folder on the user's default 
server. The default server is set on the Environment property page of the user 
object.

In This Section

“Creating a Login Script” on page 47

“Assigning a Profile to a User” on page 48

Creating a Login Script
1 Right-click the object that you want to create the login script on > click 

Properties.

2 On the Login Script page, enter the login script commands you want. 

See Novell Client for Windows > Login Script Commands and Variables 
(http://www.novell.com/documentation/lg/noclienu/docui/index.html#../
noclienu/data/ho2m1x3b.html) for details.

3 Click OK.

4 If you created the login script on a profile object, assign the profile to the 
users you want as explained below.

To Have the Login Script Apply To Create It On

One user only The User object

One or more users that haven’t been created yet A Template object

All the users in a container The container object

A set of users in one or more containers A Profile object
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Assigning a Profile to a User
1 Right-click the User or Template object that you want to assign the profile 

to > click Properties. 

Use a Template object if you haven’t created the User object yet.

2 On the Login Script page, click the browse button next to the Profile field 
> select the profile object > click OK.

3 Click OK.

4 Ensure that the user effectively has the Browse right to the Profile object 
and the Read right to the Login Script property of the profile object. 

See “Viewing Effective Rights” on page 56 for details.

Login Time Restrictions for Remote Users
On the Time Restrictions property page of a User object, you can restrict the 
times when the user can be logged in to eDirectory. (By default, there are no 
login time restrictions.) If you set a login time restriction and the user is logged 
in when the restricted time arrives, the system issues a warning to log out 
within five minutes. If the user is still logged in after five minutes, he or she 
is logged out automatically and loses any unsaved work.

If a user logs in remotely from a different time zone than the server processing 
the login request, any login time restrictions that have been set for the user are 
adjusted for the time difference. For example, if you restrict a user from 
logging in Mondays from 1:00 a.m. to 6:00 a.m. and the user logs in remotely 
from a time zone that is one hour later than the server, the restriction 
effectively becomes 2:00 a.m. to 7:00 a.m. for that user.
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4 Administering Rights

Rights are system flags that you can set on individual network resources to 
control access to those resources. When you assign rights, you always link 
them with a specific user, group, or other Novell® eDirectoryTM object that is 
the trustee (possessor) of the rights. In ConsoleOneTM, you can grant a trustee 
rights to two different kinds of resources:

eDirectory objects

Rights to these resources are stored in and applied by eDirectory. For 
details, see Novell eDirectory Administration Guide > eDirectory Rights.

Files and folders on NetWare® volumes

Rights to these resources are stored in and applied by the NetWare file 
system. For details, see “About NetWare Rights” on page 58.

When a user tries to access a resource, the system (eDirectory or NetWare) 
calculates the user’s effective rights to that resource. In doing so, the system 
checks not only the user’s explicit rights assignments but also any security 
equivalences held by the user and any filters that block the inheritance of 
explicit rights assignments. This chapter explains how to perform the tasks 
that control users’ effective rights to resources.

In This Chapter

“Assigning Rights Explicitly” on page 50

“Granting Equivalence” on page 53

“Blocking Inheritance” on page 55

“Viewing Effective Rights” on page 56

“About NetWare Rights” on page 58
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Assigning Rights Explicitly
When the default rights assignments in your eDirectory tree provide users 
with either too much or not enough access to resources, you can create or 
modify explicit rights assignments. When you create or modify a rights 
assignment, you start by selecting either the resource that you are controlling 
access to or the trustee (the eDirectory object that possesses, or will possess, 
the rights).

HINT: To manage users’ rights collectively rather than individually, make a group, 
role, or container object the trustee. To restrict access to a resource globally (for all 
users), see “Blocking Inheritance” on page 55. If the resource is a file or folder on 
a NetWare volume, you can also control access globally by setting attributes (see 
“Viewing and Modifying Server and File System Information” on page 90).

In This Section

“Controlling Access to the NetWare File System, by Resource” on page 
50

“Controlling Access to the NetWare File System, by Trustee” on page 51

“Controlling Access to Novell eDirectory, by Resource” on page 52

“Controlling Access to Novell eDirectory, by Trustee” on page 52

Controlling Access to the NetWare File System, by Resource
1 Right-click the resource (file, folder, or volume) that you want to control 

access to > click Properties.
NOTE: Select a volume or folder to control access to all the resources below it.

2 On the Trustees page, edit the list of trustees and their rights assignments 
as needed. 

For descriptions of the individual access rights, see “About NetWare 
Rights” on page 58.

2a To add an object as a trustee, click Add Trustee > select the object > 
click OK > under Access Rights, assign the trustee’s rights.

2b To modify a trustee’s rights assignment, select the trustee > under 
Access Rights, modify the rights assignment as needed.
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2c To remove an object as a trustee, select the object > click Delete 
Trustee > Yes. 

The deleted trustee will no longer have explicit rights to the file or 
folder but might still have effective rights through inheritance or 
security equivalence.

3 Click OK.

Controlling Access to the NetWare File System, by Trustee 
1 Right-click the trustee (the object that possesses, or will possess, the 

rights) > select Properties.

2 On the Rights to Files and Folders page, click Show > select the NetWare 
volume containing the file system that you want to control access to > 
click OK.

The Files and Folders list is filled in with any files and folders that the 
trustee currently has rights assignments to on the selected volume.

3 Edit the rights assignments as needed. 

For descriptions of the individual rights, see “About NetWare Rights” on 
page 58.

3a To add a rights assignment, click Add > select the file or folder to 
control access to > click OK > under Rights, assign the trustee’s 
rights.

3b To modify a rights assignment, select the file or folder to control 
access to > under Rights, modify the trustee’s rights as needed.

3c To remove a rights assignment, select the file or folder to control 
access to > click Delete > Yes. 

The trustee will no longer have explicit rights to the file or folder but 
might still have effective rights through inheritance or security 
equivalence.

4 Repeat Step 2 and Step 3 as needed to edit the trustee’s rights assignments 
on other NetWare volumes.

5 Click OK.
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Controlling Access to Novell eDirectory, by Resource
1 Right-click the eDirectory resource (object) that you want to control 

access to > click Trustees of This Object.
NOTE: Choose a container to control access to all the objects below it.

2 Edit the list of trustees and their rights assignments as needed. 

Click Help for details.

2a To modify a trustee’s rights assignment, select the trustee > click 
Assigned Rights > modify the rights assignment as needed > click 
OK.

2b To add an object as a trustee, click Add Trustee > select the object > 
click OK > assign the trustee’s rights > click OK.

When creating or modifying a rights assignment (in the Rights 
Assigned To dialog box), you can grant or deny access to the object 
as a whole, to all the properties of the object, and to individual 
properties. Click Help in the dialog box for details.

2c To remove an object as a trustee, select the object > click Delete 
Trustee > Yes. 

The deleted trustee will no longer have explicit rights to the object or 
its properties but might still have effective rights through inheritance 
or security equivalence.

3 Click OK.

Controlling Access to Novell eDirectory, by Trustee
1 Right-click the trustee (the object that possesses, or will possess, the 

rights) > select Rights to Other Objects.

2 In the search dialog box, specify the part of the eDirectory tree to be 
searched for eDirectory objects that the trustee currently has rights 
assignments to. 

Click Help for details.

3 Click OK in the search dialog box.

A dialog box appears showing the progress of the search. When the search 
is done, the Rights to Other Objects page appears with the results of the 
search filled in. 

4 Edit the trustee’s eDirectory rights assignments as needed. 

Click Help for details.
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4a To add a rights assignment, click Add Object > select the object to 
control access to > click OK > assign the trustee’s rights > click OK.

4b To modify a rights assignment, select the object to control access to 
> click Assigned Rights > modify the trustee’s rights assignment as 
needed > click OK.

When creating or modifying a rights assignment (in the Rights 
Assigned To dialog box), you can grant or deny access to the object 
as a whole, to all the properties of the object, and to individual 
properties. Click Help in the dialog box for details.

4c To remove a rights assignment, select the object to control access to 
> click Delete Object > Yes. 

The trustee will no longer have explicit rights to the object or its 
properties but might still have effective rights through inheritance or 
security equivalence.

5 Click OK.

Granting Equivalence
A user who is security equivalent to another eDirectory object effectively has 
all the rights of that object, both in eDirectory and in the NetWare file system. 
A user is automatically security equivalent to the groups and roles that he or 
she belongs to. All users are implicitly security equivalent to the [Public] 
trustee and to each container above their User objects in the eDirectory tree, 
including the Tree object. You can also explicitly grant a user security 
equivalence to any eDirectory object.

NOTE: The tasks in this section allow you to delegate administrative authority 
through eDirectory rights. If you have administration applications that use RBS 
roles, you can also delegate administrative authority by assigning users 
membership in those roles as explained in “Assigning RBS Role Membership and 
Scope” on page 63.

In This Section

“Granting Security Equivalence by Membership” on page 54

“Granting Security Equivalence Explicitly” on page 54

“Setting Up an Administrator Over an Object’s Specific eDirectory 
Properties” on page 55
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Granting Security Equivalence by Membership
1 If you haven’t already done so, create the group or role object that you 

want the users to be security equivalent to. 

See “Creating and Manipulating Objects” on page 33 for details.

2 Grant the group or role the eDirectory and NetWare rights that you want 
the users to have. 

See “Assigning Rights Explicitly” on page 50 for details.

3 Edit the membership of the group or role to include those users who need 
the rights of the group or role.

For a group object, use the Members property page.

For an organizational role object, use the Occupant field on the 
Identification property page.

For an RBS role object, use the Members of Role property page. 

See “Assigning RBS Role Membership and Scope” on page 63 for 
details.

4 Click OK.

Granting Security Equivalence Explicitly
1 Right-click either the user or the object that you want the user to be 

security equivalent to > click Properties.

2 Grant the security equivalence as follows:

If you chose the user, on the Memberships tab select the Security 
Equal To page > click Add > select the object that you want the user 
to be security equivalent to > click OK.

If you chose the object that you want the user to be security 
equivalent to, on the Security Equal to Me page click Add > select 
the user > click OK.

The contents of these two property pages are synchronized by the system.

3 Click OK.
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Setting Up an Administrator Over an Object’s Specific eDirectory 
Properties

1 If you haven't already done so, create the user, group, role, or container 
object that you want to make a trustee of the object’s specific properties.

If you create a container as a trustee, all objects inside and below the 
container will have the rights you grant. You must make the property 
inheritable or the container and its members will not have rights below its 
level.

2 Right-click the highest-level container that you want the administrator to 
manage > click Trustees of This Object.

3 On the property page, click Add Trustee > select the object that represents 
the administrator > click OK.

4 In the Rights Assigned To dialog box, click Add Property.

5 Deselect the Show All Properties check box.

6 For each property that the administrator will manage, assign the needed 
rights. 

Be sure to select the Inheritable check box on each rights assignment. 
Click Help for details.

7 Click OK.

8 Click OK in the Properties dialog box.

Blocking Inheritance
In eDirectory, rights assignments on containers can be inheritable or non-
inheritable. In the NetWare file system, all rights assignments on folders are 
inheritable. In both eDirectory and NetWare, you can block such inheritance 
on individual subordinate items so that the rights aren't effective on those 
items, no matter who the trustee is. One exception is that the Supervisor right 
can’t be blocked in the NetWare file system.

In This Section

“Blocking Inherited Rights to a File or Folder on a NetWare Volume” on 
page 56

“Blocking Inherited Rights to an eDirectory Object or Property” on page 
56
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Blocking Inherited Rights to a File or Folder on a NetWare Volume
1 Right-click the file or folder > click Properties.

2 On the Inherited Rights Filter page, edit the filter as needed.

To block a right, deselect its check box. To let a right flow through, select 
its check box. The Supervisor right can’t be blocked. The other check 
boxes are disabled if you don't have the Supervisor or Access Control 
right to the file or folder. For descriptions of the individual rights, see 
“About NetWare Rights” on page 58.
NOTE: This filter won’t block rights that are explicitly granted a trustee on this file 
or folder, since such rights aren’t inherited.

3 Click OK.

Blocking Inherited Rights to an eDirectory Object or Property
1 Right-click the eDirectory object > click Properties.

2 On the NDS Rights tab, select the Inherited Rights Filters page.

This displays a list of the inherited rights filters that have already been set 
on the object.

3 On the property page, edit the list of inherited rights filters as needed.

To edit the list of filters, you must have the Supervisor or Access Control 
right to the ACL property of the object. You can set filters that block 
inherited rights to the object as a whole, to all the properties of the object, 
and to individual properties. Click Help for details.
NOTE: These filters won’t block rights that are explicitly granted a trustee on this 
object, since such rights aren’t inherited.

4 Click OK.

Viewing Effective Rights
Effective rights are the actual rights users can exercise on specific network 
resources. They are calculated by the system (eDirectory or NetWare) based 
on explicit rights assignments, inheritance, and security equivalence. You can 
query the system to determine a user's effective rights to any resource.
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In This Section

“Viewing Effective Rights to a File or Folder on a NetWare Volume” on 
page 57

“Viewing Effective Rights to an eDirectory Object or Property” on page 
57

Viewing Effective Rights to a File or Folder on a NetWare Volume
1 Right-click the file, folder, or volume > click Properties. 

Select a volume to view effective rights at the root of the file system.

2 On the Trustees page, click Effective Rights.

3 If the object whose effective rights you want to view isn't shown in the 
Trustee field, click the browse button next to the field > select the trustee 
you want > click OK.

4 View the effective rights. 

For descriptions of the individual rights, see “About NetWare Rights” on 
page 58.

5 Click OK.

Viewing Effective Rights to an eDirectory Object or Property
1 Right-click the eDirectory object > click Trustees of This Object.

2 On the NDS Rights tab, select the Effective Rights page.

3 If the object whose effective rights you want to view isn't shown in the 
For Trustee field, click the browse button next to the field > select the 
trustee you want > click OK.

4 View the effective rights you want.

You can view effective rights to the object as a whole, to all the properties 
of the object, and to individual properties. Click Help for details.

5 Click OK.
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About NetWare Rights
This section describes the specific rights that users can have to files and 
folders on NetWare volumes, the possible sources of those rights, and how the 
NetWare file system calculates users’ effective rights to files and folders.

In This Section

“Descriptions of Rights” on page 58

“Sources of Rights” on page 59

“How NetWare Calculates Effective Rights” on page 59

Descriptions of Rights
The following table describes the individual rights that a trustee can have to a 
file or folder on a NetWare volume.

Right Description

Supervisor Grants the trustee all rights to the file or folder and any subordinate items. This 
right can't be filtered (blocked) on the current file or folder or on subordinate 
items, nor can it be revoked on individual subordinate items.

Read Grants the trustee the ability to open and read the file or folder and any 
subordinate items. This includes the ability to execute program files.

Write Grants the trustee the ability to open and write to (modify) the file or folder and 
any subordinate items.

Create Grants the trustee the ability to create new items and salvage deleted items 
in the folder and any subfolders.

Inheritable Makes the rights to the selected property flow to all objects below.

Erase Grants the trustee the ability to delete the file or folder and any subordinate 
items.

Modify Grants the trustee the ability to change the name and attributes of the file or 
folder and any subordinate items. The trustee can't see or modify the actual 
contents of files.

File Scan Grants the trustee the ability to see (in a listing or browser) the file or folder 
and any subordinate items, including its path back to the root of the volume.

Access Control Grants the trustee the ability to change the trustee (rights) assignments and 
inherited rights filter of the file or folder.
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Sources of Rights
A given file or folder can have multiple rights assignments associated with it, 
each linked with a different trustee (possessor) of the rights. Rights to a folder 
are inherited by the trustee to items within the folder, so the trustee can 
exercise the rights on subordinate items without having an explicit assignment 
on those items. You can, however, place a filter on individual subordinate 
items to block specific rights from being inherited. Such filters apply globally 
to all trustees holding the specified rights.

Besides having explicit and inherited rights to a file or folder, a user can also 
have rights to a file or folder through security equivalence to another 
eDirectory object. For example, if a user is a member of an eDirectory group 
or role and that group or role has been granted certain rights, the user 
effectively has those additional rights through security equivalence. For more 
information, see Novell eDirectory Administration Guide > eDirectory Rights.

How NetWare Calculates Effective Rights
A user’s effective rights are calculated by NetWare each time the user tries to 
access a file or folder on a NetWare volume. You can view a user’s effective 
rights to any file or folder as explained in “Viewing Effective Rights” on page 
56. Following is the process used by NetWare to calculate effective rights.

This process is similar to, but not the same as, the process used by eDirectory 
to calculate users’ effective rights to eDirectory objects and properties. For 
information on that process, see Novell eDirectory Administration Guide > 
eDirectory Rights.

1. Checks whether the user effectively has the Supervisor right to the 
NetWare server where the target file or folder resides. (eDirectory 
supplies this information to NetWare.)

If so, the user effectively has all rights in the file system of the server, 
and the rest of this process is skipped.

If not, continues with the next step.

2. Determines which eDirectory objects the user is security equivalent to. 
(eDirectory supplies this information to NetWare.)

3. Descends to the next level in the file system along the path to the target 
file or folder.
HINT: The next level below the NetWare server is the root folder of the volume.
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4. Checks whether the user, or any of the objects that the user is security 
equivalent to, is assigned the Supervisor right at the current level.

If so, the user effectively has all rights from this level down in the file 
system, and the rest of this process is skipped.

If not, continues with the next step.

5. Does the following for the user and each object that the user is security 
equivalent to:

a. Checks whether the user (or object) is assigned any non-Supervisor 
rights at the current level. If so, sets the effective rights of the user (or 
object) to the rights specified in the assignment and skips to Step 6. 
If not, continues with the next substep.

b. Removes from the current effective rights any rights that are blocked 
by an inheritance filter at the current level.

6. If the current level of the file system is the target file or folder, the user’s 
final effective rights are the sum of his or her current effective rights and 
the current effective rights of each object that the user is security 
equivalent to. If the target file or folder hasn’t been reached yet, returns 
to Step 3.
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5 Configuring Role-Based 
Administration

ConsoleOneTM gives you the option to extend the schema of your Novell® 
eDirectoryTM tree to allow the creation of role-based services (RBS) objects. 
This enables administration applications to expose their functions as RBS 
module and task objects in your tree. You can then create RBS role objects that 
define the particular tasks that different users can perform in those 
administration applications.

NOTE: This approach to delegating administration works only if you have 
administration applications that use RBS objects. You can also delegate 
administration using eDirectory rights as explained in “Granting Equivalence” on 
page 53. 

In This Chapter

“Setting Up Role-Based Services” on page 61

“Defining RBS Roles” on page 62

“Assigning RBS Role Membership and Scope” on page 63

“Creating RBS Objects for Custom Applications” on page 64

Setting Up Role-Based Services
Before administration applications can add RBS objects to your eDirectory 
tree, the schema of the tree must be extended to allow RBS object types. 
Typically, administration applications perform this schema extension 
automatically during installation. Regardless, you can complete the procedure 
below to ensure that your tree has the needed schema extensions.
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Installing RBS Schema Extensions to Your eDirectory Tree
1 Click anywhere in an eDirectory tree.

2 Click Tools > Install.

3 Follow the instructions in the wizard to complete the installation. 

Be sure to select Role Based Services on the second screen. Help is 
available throughout the wizard.

Defining RBS Roles
RBS roles specify the tasks that users are authorized to perform in specific 
administration applications. Defining an RBS role includes creating an RBS 
role object and specifying the tasks that the role can perform. In some cases, 
administration applications might provide a few predefined RBS role objects 
that you can modify.

The application tasks that RBS roles can perform are exposed as RBS task 
objects in your eDirectory tree. These objects are added automatically during 
installation of one or more administration applications. They are organized 
into one or more RBS modules, which are containers that correspond to the 
different functional modules of the application.

HINT: If your organization has developed a custom administration application that 
uses RBS objects, you can create the RBS objects for it manually as explained in 
“Creating RBS Objects for Custom Applications” on page 64.

In This Section

“Creating an RBS Role Object” on page 62

“Specifying the Tasks That RBS Roles Can Perform” on page 63

Creating an RBS Role Object
1 Right-click the container that you want to create the RBS role object in > 

click New > click Object.

2 Under Class, select RBS:Role > click OK.

3 Enter a name for the new RBS role object. 

Be sure to follow proper eDirectory naming conventions. (See Novell 
eDirectory Administration Guide > Naming Conventions.)

Example: Password Administrator Role

4 Click OK.
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Specifying the Tasks That RBS Roles Can Perform
1 Right-click an RBS role or RBS task object > click Properties.

RBS task objects are located only in RBS module containers.

2 On the Role Based Services tab, make the associations you want:

For an RBS role, select the Role Content page > edit the list of tasks 
that the role can perform.

For an RBS task, select the Member Of page > edit the list of roles 
that can perform the task.

3 Click OK.

Assigning RBS Role Membership and Scope
Once you have defined the RBS roles needed in your organization, you can 
assign the membership of each role. In doing so, you specify the scope in 
which each member can exercise the functions of the role. Depending on the 
administration application associated with the role functions, the scope is 
specified either as a context in the eDirectory tree or as an object that 
represents some other (non-eDirectory) kind of scope.

HINT: If an administration application defines scope in non-eDirectory terms, it will 
extend the schema of your eDirectory tree to include the needed scope object 
class. You can then create scope objects as explained in “Creating an Object That 
Represents a Non-eDirectory Scope” on page 66.

1 Right-click either the RBS role object or the object that represents the 
users who you want to assign as role members > click Properties.

You can assign users as role members individually or in groups, 
organizations, or organizational units. However, if you want each user to 
exercise the role within a different scope, you must assign role 
memberships individually.

2 On the Role Based Services tab, assign the role memberships you want:

For an RBS role object, select the Members of Role page > edit the 
list of members and their scopes as needed. 

Click Help for details.

For a user, group, organization, or organizational unit object, select 
the Assigned Roles page > edit the list of role memberships and 
scopes as needed.

Click Help for details.
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If you want a single role membership to have multiple, non-overlapping 
scopes (such as two different branches of the eDirectory tree), you must 
list that role membership multiple times, each with a different scope.

3 Click OK.

Creating RBS Objects for Custom Applications
Typically, administration applications that use RBS objects add the needed 
objects to your eDirectory tree automatically during installation. However, if 
your organization has developed a custom administration application that uses 
RBS objects, you can create the needed RBS objects manually. The following 
are the types of RBS objects you can create:

Object Type Container 
or Leaf

Purpose Example

Module Container Represents a module of the 
administration application, so that the 
application’s tasks can be logically 
contained and uniquely identified.

An application might have User 
and Server modules that each 
contain a Create task.

Task Leaf Represents a specific application 
function.

Reset Login Password.

Scope Leaf Represents the scope in which a role 
member can exercise the functions of the 
role, if the application defines scope in 
non-eDirectory terms.

NOTE: Before you can create a scope 
object, its class must exist in the schema 
of your eDirectory tree. A scope class is a 
subclass of RBS:External Scope.

An application that defines scope 
in Domain Name Service (DNS) 
terms might let you create scope 
objects such as:

com_xyz

com_xyz_usa

com_xyz_usa_ny

Role Leaf Represents an administrative role. It lists 
the particular application tasks that role 
members can perform. See “Defining 
RBS Roles” on page 62 to create this 
object type.

For a User Administration 
application, you might create roles 
such as:

Rights Manager

Password Administrator

Employment Data Entry
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In This Section

“Creating an RBS Module Object” on page 65

“Creating an RBS Task Object” on page 66

“Creating an Object That Represents a Non-eDirectory Scope” on page 
66

Creating an RBS Module Object
1 Right-click the organization or organizational unit that you want to create 

the RBS module object in > click New > click Object.

2 Under Class, select RBS:Module > click OK.

3 In Name, enter a name for the module. 

Be sure to follow proper eDirectory naming conventions. (See Novell 
eDirectory Administration Guide > Naming Conventions.)

Example: User Administration Module

4 Depending on how the administration application will use the module 
object, complete the appropriate steps:

Application Will Read 
the Object to 
Determine How to 
Invoke the Actual 
Module?

Steps

No Click OK. You’re done creating the module object.

Yes 1. Select Define Additional Properties > click OK.

2. On the Information page, specify the module’s 
URL and software type if they are needed by 
the application.

3. On the Path page (Role Based Services tab), 
list any other modules required for execution 
of this module. Click Help for details.

4. Click OK.
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Creating an RBS Task Object
1 Right-click the RBS module container that you want to create the RBS 

task object in > click New > click Object.

2 Under Class, select RBS:Task > click OK.

3 In Name, enter a name for the task. 

Be sure to follow proper eDirectory naming conventions. (See Novell 
eDirectory Administration Guide > Naming Conventions.)

Example: Reset Login Password

4 Depending on how the administration application will use the task object, 
complete the appropriate steps:

Creating an Object That Represents a Non-eDirectory Scope
1 If the class of object you will create isn’t defined yet in the schema of your 

eDirectory tree, use Schema Manager to define it. 

See “Defining a Custom Object Class” on page 71.
IMPORTANT: When completing the Class Creation wizard, be sure to set the 
Effective Class flag and select RBS:External Scope as the class to inherit from.

2 Right-click the container that you want to create the scope object in > 
click New > click Object.

3 Under Class, select the object class that represents the non-eDirectory 
scope > click OK.

Application Will Read 
the Object to 
Determine How to 
Invoke the Actual 
Task?

Steps

No Click OK. You’re done creating the task object.

Yes 1. Select Define Additional Properties > click OK.

2. On the Information page, specify the 
application function (entry point) to be invoked 
and any parameters to be passed on 
invocation.

3. Click OK.
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4 In Name, enter a name for the scope. 

Be sure to follow proper eDirectory naming conventions. (See Novell 
eDirectory Administration Guide > Naming Conventions.)

Example: DNS Scope com_xyz_usa

5 Depending on how the administration application will use the scope 
object, complete the appropriate steps:

Application Will Read 
the Object to 
Determine the Actual 
Scope to Enforce?

Steps

No Click OK. You’re done creating the scope object.

Yes 1. Select Define Additional Properties > click OK.

2. On the property pages, specify the scope 
information required by the application. Click 
Help for details on specific pages.

3. Click OK.
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6 Extending the Novell eDirectory 
Schema

The schema of your Novell® eDirectoryTM tree defines the classes of objects 
that the tree can contain, such as users, groups, and printers. It specifies the 
properties (attributes) that comprise each object type, including those that are 
required when creating the object and those that are optional. For details, see 
Novell eDirectory Administration Guide > Object Classes and Properties and 
Schema.

To extend the schema of your eDirectory tree, you need the Supervisor right 
to the entire tree. To view the current schema, click anywhere in the tree, then 
click Tools > Schema Manager. A list of the available classes and properties 
appears, as shown below. Double-click a class or property to see information 
about it.
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Figure 2 Schema Manager

To extend the schema, see the appropriate section of this chapter.

In This Chapter

“Defining Custom Object Classes and Properties” on page 70

“Defining and Using Auxiliary Classes” on page 72

“Deleting Unused Classes and Properties” on page 77

Defining Custom Object Classes and Properties
You can define your own custom types of properties and add them as optional 
properties to existing object classes as needed. (You can’t add mandatory 
properties to existing classes.) You can also define entirely new classes of 
objects that contain both standard and custom properties.

In This Section

“Defining a Custom Property” on page 71

“Adding Optional Properties to a Class” on page 71

“Defining a Custom Object Class” on page 71
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Defining a Custom Property
1 Click anywhere in the eDirectory tree whose schema you want to extend.

2 Click Tools > Schema Manager.

3 On the Attributes tab, click Create.

4 Follow the instructions in the wizard to define the new property. 

Help is available throughout the wizard.

Adding Optional Properties to a Class
1 Click anywhere in the eDirectory tree whose schema you want to extend.

2 Click Tools > Schema Manager.

3 On the Classes tab, select the class you want to modify > click Add.

4 In the list on the left, double-click the properties you want to add.

If you add a property by mistake, double-click it in the list on the right.

5 Click OK.

Objects you create of this class will now have the properties you added. 
To set values for the added properties, use the generic Other property page 
of the object. 

Defining a Custom Object Class
1 Click anywhere in the eDirectory tree whose schema you want to extend.

2 Click Tools > Schema Manager.

3 On the Classes tab, click Create.

4 Follow the instructions in the wizard to define the object class. 

Help is available throughout the wizard.

If you need to define custom properties to add to the object class, cancel 
the class creation wizard and define the custom properties first as 
explained above.
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Defining and Using Auxiliary Classes
An auxiliary class is a set of properties (attributes) that are added to particular 
eDirectory object instances rather than to an entire class of objects. For 
example, an e-mail application could extend the schema of your eDirectory 
tree to include an E-mail Properties auxiliary class and then extend individual 
objects with those properties as needed. With Schema Manager, you can 
define your own auxiliary classes. Then, in the main ConsoleOneTM window, 
you can extend individual objects with the properties defined in your auxiliary 
classes.

In This Section

“Defining an Auxiliary Class” on page 72

“Extending an Object with the Properties of an Auxiliary Class” on page 
73

“Extending Multiple Objects Simultaneously with the Properties of an 
Auxiliary Class” on page 74

“Modifying an Object’s Auxiliary Properties” on page 75

“Deleting Auxiliary Properties from an Object” on page 76

“Deleting Auxiliary Properties from Multiple Objects Simultaneously” 
on page 76

Defining an Auxiliary Class
1 Click anywhere in the eDirectory tree whose schema you want to extend.

2 Click Tools > Schema Manager.

3 On the Classes tab, click Create.

4 Follow the instructions in the wizard to define the auxiliary class.

Make sure to select Auxiliary Class when setting the class flags. If you 
need to define custom properties to add to the auxiliary class, cancel the 
Class Creation wizard and define the custom properties first. See 
“Defining Custom Object Classes and Properties” on page 70 for details.
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Extending an Object with the Properties of an Auxiliary Class
1 In the main ConsoleOne window, right-click the object > click Extensions 

of This Object.

2 Depending on whether the auxiliary class that you want to use is already 
listed under Current Auxiliary Class Extensions, complete the 
appropriate action:

3 If a message appears stating that generic editors will be used, click OK.

4 On the screen that appears, set the property values you want. 

Depending on which screen you’re using, note the following:

5 Click OK.

Auxiliary Class Is 
Already Listed?

Action

Yes Quit this procedure. 

See instead “Modifying an Object’s Auxiliary Properties” 
on page 75.

No Click Add Extension > select the auxiliary class > click 
OK.

Screen Notes

Extensions tab 
(Properties 
dialog box)

Both mandatory and optional properties of the 
auxiliary class might be listed.

Click Help for details on specific properties. 

New dialog box Only mandatory properties of the auxiliary class 
are listed.

You must know the syntax of a property to set it 
correctly. For details, see Novell eDirectory 
Administration Guide > Replicas.

After setting the mandatory properties, you can set 
optional properties as explained in “Modifying an 
Object’s Auxiliary Properties” on page 75.
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Extending Multiple Objects Simultaneously with the Properties of an 
Auxiliary Class

1 In the ConsoleOne right pane, Shift+click or Ctrl+click the objects to 
select them.

The objects don’t have to be the same type.

2 Right-click your selection > click Extensions of Multiple Objects.

3 Depending on whether the auxiliary class that you want to use is already 
listed under Current Auxiliary Class Extensions, complete the 
appropriate action:
HINT: Only those extensions that are common to all the selected objects are 
listed. Those that are specific to individual objects aren’t listed.

4 If a message appears stating that generic editors will be used, click OK.

5 On the screen that appears, set the property values you want.
IMPORTANT: Each property value you set will be applied to each selected object. 
If the property already exists in the object and is single-valued, the existing value 
will be replaced. If the property already exists and is multi-valued, the new values 
will be added to the existing values.

Depending on which screen you’re using, also note the following:

Auxiliary Class Is 
Already Listed?

Action

Yes Quit this procedure. 

See instead “Modifying an Object’s Auxiliary Properties” 
on page 75. You’ll have to modify the objects one at a 
time.

No Click Add Extension > select the auxiliary class > click 
OK.
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6 Click OK.

Modifying an Object’s Auxiliary Properties
1 In the main ConsoleOne window, right-click the object > click Properties.

2 On the Extensions tab, select the property page that’s named after the 
auxiliary class. If the auxiliary class isn’t listed or if there’s no Extensions 
tab, use the generic Other page.

3 On the screen that appears, set the property values you want. Depending 
on which screen you’re using, note the following:

4 Click OK.

Screen Notes

Extensions tab Both mandatory and optional properties of the 
auxiliary class might be listed.

Click Help for details on specific properties. 

New dialog box Only mandatory properties of the auxiliary class 
are listed.

You must know the syntax of a property to set it 
correctly. For details, see Novell eDirectory 
Administration Guide > Schema.

After setting the mandatory properties, you can set 
optional properties as explained below. You’ll have 
to modify the objects one at a time.

Screen Notes

Extensions tab Both mandatory and optional properties of the 
auxiliary class might be listed.

Click Help for details on specific properties. 

Other tab Only the properties of the auxiliary class that have 
already been set are listed. Click Add to set 
additional properties.

You must know the syntax of a property to set it 
correctly. For details, see Novell eDirectory 
Administration Guide > Schema.
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Deleting Auxiliary Properties from an Object
1 In the main ConsoleOne window, right-click the object > click Extensions 

of This Object.

2 In the list of current auxiliary class extensions, select the auxiliary class 
whose properties you want to delete.

3 Click Remove Extension > Yes.

This deletes all the properties added by the auxiliary class except for any 
that the object already had innately.

Deleting Auxiliary Properties from Multiple Objects Simultaneously
1 In the ConsoleOne right pane, Shift+click or Ctrl+click the objects to 

select them. 

The objects don’t have to be the same type.

2 Right-click your selection > click Extensions of Multiple Objects.

3 Depending on whether the auxiliary class whose properties you want to 
delete is listed under Current Auxiliary Class Extensions, complete the 
appropriate action:
HINT: Only those extensions that are common to all the selected objects are 
listed. Those that are specific to individual objects aren’t listed.

Auxiliary Class Is 
Listed?

Action

Yes Select it > click Remove Extension > Yes.

This deletes all the properties added by the auxiliary class 
except for any that the object already had innately.

No Cancel the dialog box. 

You’ll have to delete the auxiliary class from each object 
one at a time. See “Deleting Auxiliary Properties from an 
Object” on page 76.
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Deleting Unused Classes and Properties
You can delete unused classes and properties (attributes) that aren’t part of the 
base schema of your eDirectory tree. We recommend that you only delete 
classes that you’ve defined and that you’re sure aren’t being used. 
ConsoleOne only prevents you from deleting classes that are currently being 
used in locally replicated partitions.

In This Section

“Deleting a Property from the Schema” on page 77

“Deleting a Class from the Schema” on page 77

Deleting a Property from the Schema
1 Click anywhere in the eDirectory tree whose schema you want to modify.

2 Click Tools > Schema Manager.

3 On the Attributes tab, select the property > click Delete > click Yes.

Deleting a Class from the Schema
1 Click anywhere in the eDirectory tree whose schema you want to modify.

2 Click Tools > Schema Manager.

3 On the Classes tab, select the class > click Delete > click Yes.
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7 Partitioning and Replicating Novell 
eDirectory

A partition is a subdivision of your Novell® eDirectoryTM tree that can be 
stored and replicated as an independent unit across multiple servers. If your 
tree is large or spans WAN links, you can partition and replicate it to improve 
network performance and fault tolerance. For details, see Novell eDirectory 
Administration Guide > Replicas and Partitions.

To perform partition and replication operations, you need the Supervisor right 
to the part of the eDirectory tree that you will partition or replicate. In your 
tree, the containers that have an  icon next to them mark the points where 
the tree is partitioned. (Each of these containers is the root of a partition.) At 
such points, you can open a special view in the right pane (illustrated below) 
to see and configure the replicas of the partition. You can also access similar 
views from server objects in the tree.

Figure 3 Partition and Replica View
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In This Chapter

“Managing Partitions” on page 80

“Managing Replication” on page 85

“About Replica States” on page 87

Managing Partitions
By default, a small eDirectory tree is stored as a single partition that is 
replicated on the first three servers in the tree. The procedures below explain 
how to perform further partitioning operations. For concepts and guidelines on 
partitioning your tree, see Novell eDirectory Administration Guide > 
Guidelines for Partitioning Your Tree and Managing Partitions and Replicas.

In This Section

“Viewing Information about a Partition” on page 80

“Splitting a Partition (Creating a Child Partition)” on page 81

“Merging a Child Partition with Its Parent Partition” on page 81

“Moving a Partition” on page 81

“Checking Partition Continuity” on page 82

Viewing Information about a Partition
1 In the left pane, right-click the root container of the partition (it should 

have an  icon next to it) > click Views > click Partition and Replica 
View.

The right pane displays a list of the servers that the partition is replicated 
on, along with the type and state of each replica. For descriptions of the 
replica types, see Novell eDirectory Administration Guide > Replicas. For 
descriptions of the replica states, see “About Replica States” on page 87.

2 View more information about the partition, such as when its replicas were 
last synchronized.

2a Make sure the partition root is still selected in the left pane.

2b On the toolbar, click Information.

The Partition Information dialog box appears. Click Help for details 
on individual information fields.
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Splitting a Partition (Creating a Child Partition)
1 Make sure you understand the overall process for creating a partition. 

See Novell eDirectory Administration Guide > Creating a Partition.

2 Right-click the container that will be the root of the new (child) partition 
> click Views > click Partition and Replica View.

The right pane should display an empty replica list. If the list isn’t empty, 
the container is already a partition root—select a different container.

3 On the toolbar, click Create Partition > OK.

Merging a Child Partition with Its Parent Partition
1 Right-click the root container of the child partition (it should have an  

icon next to it) > click Views > click Partition and Replica View.

The right pane displays a list of the servers that the partition is replicated 
on, along with the type and state of each replica. For descriptions of the 
replica types, see Novell eDirectory Administration Guide > Replicas. For 
descriptions of the replica states, see “About Replica States” on page 87.

2 Make sure the child partition is ready to be merged as explained in Novell 
eDirectory Administration Guide > Merging a Partition.

3 Make sure the child partition’s root container is still selected in the left 
pane.

4 On the toolbar, click Merge Partition > OK.

Moving a Partition
1 Make sure the partition is ready to be moved as explained in Novell 

eDirectory Administration Guide > Moving Partitions.

2 Select the root container of the partition (it should have an  icon next to 
it).

3 Click File > Move.

4 Click the browse button next to the Destination field > select the container 
to move the partition into > click OK.

5 (Recommended) Select the Create an Alias for All Objects Being Moved 
check box.

6 Click OK.
Partitioning and Replicating Novell eDirectory 81

ConsoleOne User Guide
104-001316-001
August 29, 2001

Novell Confidential



Manual 99a38 July 17, 2001
Checking Partition Continuity
Partition Continuity helps you identify whether any of a partition's replicas are 
experiencing synchronization errors. It does this by examining all of the 
servers holding replicas of a selected partition and verifying that each server 
has the same information for the partition's replica list (or replica ring). This 
operation is also known as "walking the replica ring." 

If each server holding a replica of the chosen partition does not have an 
identical replica list, or if a replica cannot synchronize with the eDirectory 
Tree for any reason, the Partition Continuity Table displays one or more errors. 
Errors appear as exclamation points inside the replica icons.

The Partition Continuity Table displays the replica list (columns) of each 
server (rows) that holds a replica of the chosen partition. To understand the 
partition grid, read it horizontally, one server at a time. Each row represents 
the replica list of that server.

Figure 4 Partition Continuity Table
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You might also see icons representing unreadable replicas. This does not 
necessarily signify that the servers can't talk.It might simply indicated that the 
client cannot contact the server for information.

You can check partition continuity in ConsoleOne from the Partition and 
Replica View.

1 Click View > Partition and Replica View.

2 Select the partition whose synchronization status you want to view.

3 Click Partition Continuity .

Using the Partition Continuity Table

You can use the Partition Continuity table for doing the following:

“Viewing Replica Information” on page 83

“Viewing Server Informations” on page 83

“Synchronizing Replica Information” on page 84

“Receiving Updates” on page 84

“Sending Updates” on page 84

Viewing Replica Information

From the Partition Continuity Table, you can view information about a replica, 
such as its type, current state, and any synchronization errors.

1 Select a row in the Partition Continuity Table.

2 Click View > Information > Replica.

3 Select the replica (column) you want to view.

4 Click OK.

You can also double-click the replica icon in the table to view replica 
information.

Viewing Server Informations

From the Partition Continuity Table, you can view information about a server 
and the replicas it holds.

1 Select a row in the Partition Continuity Table.

2 Click View > Information > Server.

You can also double-click the server column in the table to view server 
information.
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Synchronizing Replica Information

You can synchronize the replica information of every server that holds a 
replica of the selected partition with the replica information on the other 
servers.

1 Click Repair > Synchronize Immediately.

Receiving Updates

This operation forces the replica on the chosen server to receive all eDirectory 
objects from the master replica of the partition. While in process, this 
operation marks the replica on the chosen server as a new replica.

The replica state can be seen in the replica list of the server from the Tree View 
or the list of Partitions and Servers. The replica's current data will be 
overwritten with the data from the master replica.

Although eDirectory automatically synchronizes the directory data among 
replicas (so that each replica is sent the most recently updated directory 
objects), this operation lets you manually synchronize the directory objects of 
replicas if any non-master replicas get out of sync.

Perform this operation if a replica becomes corrupted or has not received 
updated data for an extended period of time.

From the Partition Continuity Table, you can identify which replicas are out 
of sync with the data of the master replica. They will appear in the partition 
grid with an exclamation point (!) on the replica icon.

You cannot select this option from a master replica. The master replica is 
assumed to be the most current and accurate copy of the partition. If it's not, 
assign one of the other replicas to be the master using the Change Replica 
Type operation. The current master replica will be changed automatically to 
read/write.

This operation may create a lot of network traffic, so it is best to run this 
operation during a period of light network traffic.

1 Click Repair > Receive Updates.

Sending Updates

When you send updates from a replica, the eDirectory objects in that replica 
are broadcast from the server the replica resides on to all the other replicas of 
the partition, including the master replica.
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The other replicas of the partition will combine the new objects sent with the 
objects they already have. If the other replicas have data in addition to the data 
sent to them, they will retain that data.

Although eDirectory automatically synchronizes the directory data among 
replicas (so that each replica is sent the most recently updated directory 
objects), this operation lets you manually synchronize the directory objects of 
replicas if any replicas get out of sync.

1 Click Repair > Send Updates.

Managing Replication
When you create a new partition, by default eDirectory replicates the partition 
on one or more servers in your eDirectory tree. The procedures below explain 
how to further configure replication of your tree’s partitions. For replication 
concepts and guidelines, see Novell eDirectory Administration Guide > 
Guidelines for Replicating Your Tree and Managing Partitions and Replicas.

In This Section

“Viewing Replication Information” on page 85

“Adding a Replica” on page 86

“Deleting a Replica” on page 86

“Modifying a Replica” on page 87

“Replicating Selected Data Only” on page 87

Viewing Replication Information
1 In the left pane, right-click either a server or a partition root (a container 

with an  icon next to it) > click Views > click Partition and Replica 
View. 

Select a server to see all its replicas, no matter which partitions they 
replicate. Select a partition root to see all the partition’s replicas, no 
matter which servers they are stored on.

The right pane displays a list of the replicas you chose, along with the type 
and state of each replica. For descriptions of the replica types, see Novell 
eDirectory Administration Guide > Replicas. For descriptions of the 
replica states, see “About Replica States” on page 87.
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2 View more information on a particular replica, such as its last 
synchronization time and any errors.

2a In the right pane, select the replica.

2b On the toolbar, click the Information button.

The Replica Information dialog box appears. Click Help for details 
on individual information fields. If there are synchronization errors, 
click the question mark next to the error number for details.

Adding a Replica
1 In the left pane, right-click the root container of the partition that you 

want to replicate (it should have an  icon next to it) > click Views > 
click Partition and Replica View.

The right pane displays a list of the servers that the partition is already 
replicated on.

2 On the toolbar, click Add Replica.

3 Next to the Server Name field, click the browse button > select the server 
to create the new replica on > click OK.

4 Select the type of replica you want. 

Click Help for details.

5 Click OK.

Deleting a Replica
1 In the left pane, right-click either the server that holds the replica, or the 

root container of the partition that the replica is a copy of (it should have 
an  icon next to it) > click Views > click Partition and Replica View.

The right pane displays a list of the replicas on the selected server or of 
the selected partition, along with the type and state of each replica. For 
descriptions of the replica types, see Novell eDirectory Administration 
Guide > Replicas. For descriptions of the replica states, see “About 
Replica States” on page 87.

2 Make sure you understand the implications of deleting the replica. 

See Novell eDirectory Administration Guide > Adding, Deleting, and 
Changing the Type of Replicas.

3 In the right pane, select the replica.

4 On the toolbar, click Delete Replica > Yes.
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Modifying a Replica
1 In the left pane, right-click either the server that holds the replica, or the 

root container of the partition that the replica is a copy of (it should have 
an  icon next to it) > click Views > click Partition and Replica View.

The right pane displays a list of the replicas on the selected server or of 
the selected partition, along with the type and state of each replica. For 
descriptions of the replica types, see Novell eDirectory Administration 
Guide > Replicas. For descriptions of the replica states, see “About 
Replica States” on page 87.

2 Make sure you understand the implications of changing the replica. 

See Novell eDirectory Administration Guide > Adding, Deleting, and 
Changing the Type of Replicas.

3 On the toolbar, click Change Replica Type.

4 Modify the replica as needed. 

Click Help for details.

4a To change the replica type, select the type you want.

4b For filtered replica types, see “Replicating Selected Data Only” on 
page 87 below.

5 Click OK.

Replicating Selected Data Only
When adding or modifying a replica as explained above, select a filtered 
replica type > click Create/Edit Filter > select only those types of objects and 
properties that you want the replica to contain.

For this to work, your tree must be running NDS eDirectory 8.5 or later.

About Replica States
An eDirectory replica can be in various different states depending on the 
partition or replication operations it is undergoing. The following table 
describes the replica states that you might see in ConsoleOne.
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State Means That the Replica Is

On Currently not undergoing any partition or replication operations

New Being added as a new replica on the server

Dying Being deleted from the server

Dead Done being deleted from the server

Master Start Being changed to a master replica

Master Done Done being changed to a master replica

Change Type Being changed to a different type of replica

Locked Locked in preparation for a partition move or repair operation

Transition Move Starting into a partition move operation

Move In the midst of a partition move operation

Transition Split Starting into a partition split operation (creation of a child partition)

Split In the midst of a partition split operation (creation of a child partition)

Join Being merged into its parent partition

Transition On About to return to an On state

Unknown In a state not known to ConsoleOne
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8 Managing NetWare Server Resources

You can manage individual NetWare® servers and the file system resources on 
both traditional NetWare volumes and NSS volumes. For example, you can 
view and modify basic server information, launch NetWare Management 
Portal, assign server operators, copy and move files and folders, and salvage 
and purge deleted files. You can control volume space allocations (on 
traditional volumes only), assign file owners and attributes, make trustee 
(rights) assignments, and view volume usage statistics. For background 
information on NetWare file systems, see NetWare 5 Documentation > 
Traditional Files Services Administration Guide (http://www.novell.com/
documentation/lg/nw51/trad_enu/data/h158rfoc.html) and Novell Storage 
Services Administration Guide (http://www.novell.com/documentation/lg/
nw51/nss__enu/data/hn0r5fzo.html).

In ConsoleOneTM, you browse NetWare servers, volumes, folders, and files 
like any other objects in your Novell® eDirectoryTM tree. Volumes and folders 
are container objects that you can expand and collapse. Servers and files are 
leaf objects that you can manipulate and set properties for.

In This Chapter

“Viewing and Modifying Server and File System Information” on page 
90

“Managing Files and Folders on NetWare Volumes” on page 93

“Salvaging and Purging Deleted Files on NetWare Volumes” on page 94

“Controlling Allocation of Volume Space” on page 95

“Creating eDirectory Objects to Facilitate File Management” on page 97
Managing NetWare Server Resources 89

ConsoleOne User Guide
104-001316-001
August 29, 2001

Novell Confidential



Manual 99a38 July 17, 2001
Viewing and Modifying Server and File System 
Information

You can view and modify information about NetWare servers, volumes, files, 
and folders. For volumes, files, and folders, this information includes 
attributes, owners, and time of last modification or backup. You can also 
launch NetWare Management Portal from a server object in your eDirectory 
tree.

HINT: Attributes control how files and folders are handled during processes like 
compression, backup, and migration. They also control access to specific files and 
folders, overriding individual trustee (rights) assignments.

For volumes, you can also view current usage statistics and information about 
which file system features are enabled and disabled. For servers, you can view 
the current status, NetWare version number, and network address. You can 
also assign console operators and record information about the resources, 
services, and users supported by the server.

In This Section

“Launching NetWare Management Portal from a Server Object” on page 
90

“Viewing or Modifying Information about a NetWare Server” on page 91

“Viewing or Modifying Information about a Volume” on page 91

“Viewing Details on the Contents of a Volume or Folder” on page 92

“Viewing or Modifying Information about a File or Folder” on page 92

“Modifying Information about Multiple Files, Folders, or Volumes 
Simultaneously” on page 92

Launching NetWare Management Portal from a Server Object
For this to work, the target NetWare server must be running the NetWare 
Management Portal software (PORTAL.NLM). This software loads by default 
in NetWare 5.1. You must also have a Web browser installed on your 
ConsoleOne workstation.

1 In your eDirectory tree, browse to the target NCP Server object.

2 Right-click the NCP Server object > click Launch Portal.
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If you get an error message, the target server might not be running 
PORTAL.NLM. Otherwise, the NetWare Portal page should appear in your 
Web browser. For information on using it, see NetWare 5.1 Documentation > 
NetWare Management Portal Utility Guide (http://www.novell.com/
documentation/lg/nw51/port_enu/data/a3l0k9x.html).

Viewing or Modifying Information about a NetWare Server
1 Right-click the NCP server object > click Properties.

2 Use the following property pages to view or modify the information you 
want. 

Click Help for details on any page.

3 Click OK.

Viewing or Modifying Information about a Volume
1 Right-click the volume > click Properties.

2 To view or change the volume owner or information about recent volume 
events, use the Dates and Times page. 

Click Help for details.

3 To view statistics on volume usage and information about which file 
system features are enabled and disabled, use the Statistics page.

Click Help for details.

4 Click OK.

Page Use To

General > Identification View the server status, NetWare version 
number, or network address

General > Error Log View or clear the server error log file

Operators View or modify the list of users who 
have console operator privileges

Resources, Supported Services, 
Users

Record the resources, services, and 
users supported by the server (for your 
information only—this information is not 
used by the system in any way)
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Viewing Details on the Contents of a Volume or Folder
1 In the left pane, right-click the volume or folder > click Views > Details 

View.

The right pane lists the files and folders and their last modification date 
and current attribute settings. To resize a column, drag its border.

2 To interpret the information in the Attributes column, see NetWare 5.1 
Documentation > Setting Directory or File Attributes (http://
www.novell.com/documentation/lg/nw51/trad_enu/data/
h8gdk9xq.html).

Viewing or Modifying Information about a File or Folder
1 Right-click the file, folder, or volume > click Properties.

Use a volume to access information about the root folder of the file 
system.

2 On the Attributes page, view or set the attributes you want. 

For details, see NetWare 5.1 Documentation > Setting Directory or File 
Attributes (http://www.novell.com/documentation/lg/nw51/trad_enu/
data/h8gdk9xq.html).

3 On the Facts page, view or modify the information you want. 

Click Help for details.

4 Click OK.

Modifying Information about Multiple Files, Folders, or Volumes 
Simultaneously

1 In the right pane, Ctrl+click or Shift+click the files, folders, or volumes 
to select them.

2 Click File > Properties of Multiple Objects. 

If this option is disabled, right-click your selection in the right pane > 
click Properties of Multiple Objects.
IMPORTANT: See “Editing Object Properties” on page 36 for differences in how 
property pages work when editing multiple objects.

3 On the Objects to Modify page, make sure only the objects you want to 
modify are listed.

Add and delete objects as needed.
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4 On the Attributes page, set the attributes you want. 

For details, see NetWare 5.1 Documentation > Setting Directory or File 
Attributes (http://www.novell.com/documentation/lg/nw51/trad_enu/
data/h8gdk9xq.html).

5 (Volumes only) On the Dates and Times page, modify the information 
you want. 

Click Help for details.

6 On the other pages, modify the information you want.

Click Help for details.

7 Click OK.

Managing Files and Folders on NetWare Volumes
Once you have browsed into the file system on a NetWare volume, you can 
perform the file management task described below.

In This Section

“Copying or Moving Files and Folders” on page 93

“Creating a File or Folder” on page 94

“Renaming a File or Folder” on page 94

“Deleting Files and Folders” on page 94

Copying or Moving Files and Folders
1 In the right pane, Ctrl+click or Shift+click the files and/or folders to select 

them.

2 Press Ctrl+C to copy or Ctrl+X to move.

3 Select the folder or volume to copy or move your selection to.

4 Press Ctrl+V to paste the selection.

5 In the confirmation dialog box, indicate whether to keep users’ trustee 
(rights) assignments to the items during the copy or move operation.

Other file and folder attributes are kept automatically, including the 
resource fork of any Mac OS* files.
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Creating a File or Folder
1 Right-click the folder or volume that you want to create the new file or 

folder in > click New > click Object.

2 Under Class, select File or Directory > click OK.

3 In Name, enter a name for the new file or folder > click OK.

If you create a file using this procedure, it will be empty.

Renaming a File or Folder
1 Right-click the file or folder > click Rename.

2 In New Name, enter a new name for the file or folder > click OK.

Deleting Files and Folders
1 In the right pane, Ctrl+click or Shift+click the files and/or folders to select 

them.

2 Press Delete.

3 In the confirmation dialog box, click Yes.

Salvaging and Purging Deleted Files on NetWare 
Volumes

You can salvage (recover) files and folders that have been deleted from 
NetWare volumes if they haven’t been purged yet. By default, NetWare 
volumes undergo purges periodically, but you can purge specific files and 
folders immediately to recover space if needed.

In This Section

“Salvaging Deleted Files and Folders” on page 95

“Purging Deleted Files and Folders” on page 95
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Salvaging Deleted Files and Folders
1 In the left pane, right-click the volume or folder that the files and folders 

were deleted from > click Views > click Deleted File View.

The deleted files and folders appear in the right pane. To resize a column 
in the right pane, drag its border.

2 Ctrl+click or Shift+click the files and/or folders that you want to salvage.

3 Right-click your selection > click Salvage.

Salvaging a folder doesn’t salvage its contents. You must salvage the 
folder first and then salvage its contents.

Purging Deleted Files and Folders
1 In the left pane, right-click the volume or folder that the files and folders 

were deleted from > click Views > click Deleted File View.

The deleted files and folders appear in the right pane. To resize a column 
in the right pane, drag its border.

2 Ctrl+click or Shift+click the files and/or folders that you want to purge.
WARNING: Purged files and folders can’t be recovered. Once you click Purge, 
you can’t cancel the operation.

3 Right-click your selection > click Purge.

Controlling Allocation of Volume Space
You can restrict the amount of volume space that individual users can use. You 
can also place limits on the size that individual folders can grow to.

Currently, you can perform these tasks only on traditional NetWare volumes, 
not on NSS volumes.

In This Section

“Restricting a User's Volume Space” on page 96

“Restricting a Folder's Size” on page 96

“Removing a User's Space Restriction on a Volume” on page 96

“Removing a Folder's Size Restriction” on page 96
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Restricting a User's Volume Space
1 Right-click the volume > click Properties > select the Users with Space 

Restrictions page.

2 In the User Name column, if the user whose space you want to restrict is 
already listed, click the user > Modify. 

Otherwise, click Add to add the user.

3 In the dialog box that appears, select Limit Volume Space > enter a space 
limit in the field > click OK.

4 Click OK in the Properties dialog box.

Restricting a Folder's Size
1 Right-click the folder > click Properties.

2 On the Facts page, select Restrict Size.

3 In Limit, enter a size limit in kilobytes.

 The limit will be rounded to the nearest 64 kilobytes.

4 Click OK.

Removing a User's Space Restriction on a Volume
1 Right-click the volume > click Properties > select the Users with Space 

Restrictions page.

2 In the User Name column, click the user > Delete.

3 Click OK.

The user is now limited only by the available space on the volume.

Removing a Folder's Size Restriction
1 Right-click the folder > click Properties.

2 On the Facts page, deselect Restrict Size.

3 Click OK.

Any size restrictions on parent folders are still operative on this folder.
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Creating eDirectory Objects to Facilitate File 
Management

When you install NetWare 4.x, 5.x, or 6 on a server, objects are automatically 
created in the eDirectory tree to let you manage the server and its volumes. 
You can create additional Server and Volume objects to manage the resources 
of servers that are in other eDirectory trees or that are running earlier NetWare 
versions. You can also create Directory Map objects to facilitate access to 
commonly used folders on NetWare volumes.

In This Section

“Creating a NetWare Server Object” on page 97

“Creating a Volume Object” on page 98

“Creating a Directory Map Object” on page 98

Creating a NetWare Server Object
1 Make sure the actual NetWare server is up and accessible on the network.

2 Right-click the container that you want to create the server object in > 
click New > click Object.

3 Under Class, select NCP Server > click OK.

4 In Name, enter the actual name of the NetWare server that this object will 
represent.

Example: SALES_SRV

5 If you want to assign additional property values as part of the creation 
process for this server object, select Define Additional Properties.

For example, you might want to assign one or more users as server 
operators.

6 Click OK.

ConsoleOne attempts to find the specified server on the network. If it fails 
(for example, if you typed the name incorrectly), the Server object isn’t 
created.
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Creating a Volume Object
1 Make sure the eDirectory tree contains a Server object for the NetWare 

server that hosts the volume.

2 Make sure the NetWare server is up and the volume is mounted and 
accessible on the network.

3 Right-click the container that you want to create the Volume object in > 
click New > Object.

4 Under Class, select Volume > click OK.

5 In the dialog box, enter a name for the Volume object > select the host 
server and physical volume that the object will represent. 

Click Help for details.

6 Click OK.

ConsoleOne attempts to find the specified volume on the network. If it 
fails, the Volume object isn’t created.

Creating a Directory Map Object
1 Right-click the container that you want to create the directory map object 

in > click New > click Object.

2 Under Class, select Directory Map > click OK.

3 In the dialog box, enter a name for the directory map object > select the 
volume and path that the object will represent. 

Click Help for details.

4 Click OK.

ConsoleOne creates the directory map object whether or not the specified 
path actually exists. Make sure it does exist or users won’t be able to use 
the directory map to map drives.
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9 Generating Reports

This release of ConsoleOneTM includes some predefined report forms that you 
can use to generate reports on the objects in your eDirectoryTM tree. Here’s an 
example of one such report:

Figure 5 Trustee Assignments Report Dialog Box

The predefined eDirectory report forms are packaged into three report catalog 
objects that you can add to your eDirectory tree. Other Novell® products 
might provide additional report catalogs that you can add to your tree. If you 
add the JReport* Designer tool (purchased separately) to your ConsoleOne 
installation, you can also design custom reports from scratch.

NOTE: Currently, you can generate reports only when running ConsoleOne on a 
Windows* computer that’s configured as explained in “Setting Up Reporting” on 
page 103. You can’t generate reports when running ConsoleOne on a NetWare® 
server.
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In This Chapter

“Available Reports” on page 100

“Setting Up Reporting” on page 103

“Generating, Printing, and Saving Reports” on page 105

“Designing Custom Reports” on page 108

Available Reports
The Novell-defined report forms included in this release of ConsoleOne are 
described below. Only the core report forms that ship with ConsoleOne are 
described. For descriptions of report forms provided by other products (such 
as ZENworksTM), see the documentation for those products. Before you can 
generate reports using Novell-defined report catalogs, you must complete the 
setup described in “Setting Up Reporting” on page 103.

Some reports forms include one or more subreports. You can ignore these—
they are a by-product of the report design. In ConsoleOne lists, subreport 
names appear in all lowercase.

In This Section

“eDirectory General Object Reports” on page 100

“eDirectory User Security Reports” on page 101

“eDirectory User and Group Reports” on page 102

eDirectory General Object Reports
This report catalog contains report forms that let you generate reports on the 
NetWare servers, print servers, and printers in your eDirectory tree. The 
following table describes the general object reports:

Report Information Provided for Each Object

NetWare File Servers NetWare server name, status, network address, operating system version, 
eDirectory version, list of operators.

Print Servers Print server name, list of printers serviced by the print server, status of each 
printer, print queues used by the print server.

Printers Printer name, print server that services the printer, list of print queues used by 
the printer.
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eDirectory User Security Reports
This report catalog contains report forms that let you generate reports on 
eDirectory login and rights security for the users in your eDirectory tree. The 
following table describes the user security reports:

Report Information Provided for Each Object

Disabled User Accounts Name of disabled user account, other (unofficial) names of the 
user, status of the account—either disabled or expired 
(expiration date and time).

Users Locked by Intruder Detection Username, whether the user account is locked due to intruder 
detection, network address from which login was attempted, 
number of failed login attempts, date and time the account will 
be unlocked if it’s currently locked. 

Security Equivalence Username, list of objects that the user is explicitly security 
equivalent to (implicit or automatic security equivalences are not 
listed).

Template Security Settings Template object name, security settings that will be applied to 
each new User object that is created from the template, 
including:

Login password requirements

Whether login is initially disabled

Login expiration date and time

Maximum number of concurrent login sessions allowed

Restrictions on the times when the user can be logged in

Group memberships

Objects that the user is explicitly security equivalent to

Trustees of the User object and their assigned rights

The user’s assigned rights to his or her own User object

The user’s assigned rights to other eDirectory objects 

The user’s assigned rights to files and folders on NetWare 
volumes

Trustee Assignments Name of resource (eDirectory object) that the trustee 
assignment controls access to, list of trustees (objects holding 
rights to the resource) and their assigned rights.
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eDirectory User and Group Reports
This report catalog contains report forms that let you generate reports on the 
users, groups, and organizational roles in your eDirectory tree. The following 
table describes user and group reports:

User Password Requirements Username, other (unofficial) names for the user, whether a login 
password is required, whether the user can change his or her 
own password, minimum password length, whether the last 
eight passwords must be unique, maximum number of days a 
password can be used, number of grace logins allowed, number 
of grace logins remaining, password expiration date and time.

Users Not Logged In Name of user who hasn’t logged in for at least 90 days, other 
(unofficial) names for the user, last login date and time.

Users with Expired Passwords Name of user whose password has expired, other (unofficial) 
names for the user, password expiration date and time, last 
login date and time.

Users with Multiple Workstation Logins Name of user who is logged in from multiple workstations, other 
(unofficial) names for the user, number of workstations the user 
is logged in from, network addresses of the workstations.

Report Information Provided for Each Object

User Contact List Username, first name, last name, telephone number, Internet e-mail address, 
postal address

Duplicate Common User 
Names

Name of duplicate user, number of users so named, first and last name of 
each user, context of each user

Group Membership Group name, general information about the group (owner, description, 
location, department, and organization), list of members of the group

Organizational Roles Organizational role name, description, list of occupants, list of other objects 
that are explicitly security equivalent to the organizational role

User Information Username, first name, last name, employee ID, description, location, 
department

User Login Scripts Username, other (unofficial) names for the user, description of the user, 
content of the user’s login script

Report Information Provided for Each Object
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Setting Up Reporting
The reporting setup you need depends on the kind of reports you want to 
generate, as summarized in the table below. Steps for completing the reporting 
setup are given after the table.

IMPORTANT: Reporting works only if you run ConsoleOne on a Windows 
computer with 128 MB of RAM. It doesn’t work if you run ConsoleOne on NetWare, 
Linux, Solaris, or Tru64. In addition, the eDirectory tree you are reporting on must 
contain a NetWare volume to install the report catalog files on. If your eDirectory 
tree doesn’t contain a NetWare server, you can’t set up reporting in ConsoleOne.

In This Section

“Installing Reporting Services Schema Extensions” on page 104

“Installing Novell-Defined Report Catalogs” on page 104

“Installing the ODBC Driver for eDirectory on a Windows Computer” on 
page 104

“Configuring the Data Source Used by a Report Catalog” on page 105

To Generate These Reports Complete This Setup

Novell-defined 
eDirectory reports, with 
minimal customization

1. Install Reporting Services extensions to the schema of your eDirectory 
tree.

2. Install the Novell-defined report catalogs in your eDirectory tree.

3. On each Windows computer that you will use to generate reports, 
install the ODBC driver for eDirectory and configure the data source 
you want.

Reports provided by 
other products, such as 
ZENworks

See the documentation for the product that provides the reports.

Custom reports designed 
from scratch

1. Complete the above setup for generating Novell-defined eDirectory 
reports.

2. Add the JReport Designer tool to your ConsoleOne installation as 
explained in “Designing Custom Reports” on page 108.
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Installing Reporting Services Schema Extensions
1 Click anywhere in an eDirectory tree.

2 Click Tools > Install.

3 Follow the instructions in the wizard to complete the installation.

Be sure to select Reporting Services on the second screen. Help is 
available throughout the wizard.

Installing Novell-Defined Report Catalogs
1 Select the container that you want to put the Report Catalog objects in.

HINT: You can install the Catalog objects in as many containers as you want. This 
lets different organizations or departments configure their reports independently.

2 Click Tools > Install Novell-Defined Reports.

3 Select the report catalogs to install and the location to store the associated 
catalog files.

See “Available Reports” on page 100 for descriptions of the Novell-
defined report catalogs.

Click Help for details on selecting the location to store the catalog files.

4 Click Install.

Installing the ODBC Driver for eDirectory on a Windows Computer
1 If ConsoleOne isn’t installed locally on the Windows computer, in 

Windows Explorer locate the mapped or shared drive that represents the 
remote server volume where ConsoleOne is installed. 

Otherwise, skip this step.

2 Browse to the folder where ConsoleOne is installed. 

By default, this is:

3 In the \REPORTING\BIN subfolder, double-click ODBC.EXE.

4 Follow the instructions in the wizard to complete the installation.

Windows C:\NOVELL\CONSOLEONE\1.2

NetWare SYS:PUBLIC\MGMT\CONSOLEONE\1.2
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Configuring the Data Source Used by a Report Catalog
1 In the Windows control panel, double-click the ODBC icon.

2 On the User DSN tab, click Add > select the ODBC driver to be used > 
click Finish.

Select Novell ODBC Driver for NDS if you want to use eDirectory as 
your data source. This is required for the Novell-defined eDirectory 
report catalogs.

3 In the Data Source Setup dialog box, enter a name for the data source and 
fill in any other information required by your reporting system > click 
OK.

The name should match the data source specified in the report catalog. 
For the Novell-defined eDirectory report catalogs, enter "NDS 
Reporting" as the name and skip the other fields in the dialog box. (They 
are ignored by the Novell-defined NDS report catalogs.)

4 Click OK.

Generating, Printing, and Saving Reports
Once you have set up reporting as explained in “Setting Up Reporting” on 
page 103, you can perform the reporting tasks described below. When 
performing these tasks, you can use either a Novell-defined report catalog or 
a custom report catalog that you have designed.

The first task below applies only if you are using a report catalog that uses the 
Novell-defined NDS Reporting data source.

In This Section

“Specifying the Part of Your eDirectory Tree (Context) to Report On” on 
page 106

“Generating and Viewing a Report” on page 106

“Printing a Report” on page 106

“Saving a Report” on page 107

“Exporting a Report” on page 107

“Viewing a Previously Saved Report” on page 107

“Customizing the Data-Selection Criteria (Query) Used to Generate a 
Report” on page 107
Generating Reports 105

ConsoleOne User Guide
104-001316-001
August 29, 2001

Novell Confidential



Manual 99a38 July 17, 2001
Specifying the Part of Your eDirectory Tree (Context) to Report On
1 Right-click the Report Catalog object that you will use to generate the 

reports > click Properties.

2 On the Identification page, click the browse button next to the Report 
Context field > select the eDirectory container that is to be the top of your 
reporting context > click OK.

Select the tree object to report on the entire tree. (This is the default.) All 
objects below the selected container will be included in your reports.

3 Click OK in the Properties dialog box.

The reporting context you set remains in effect for all reports generated 
using this report catalog, unless you change it again using this same 
procedure.

Generating and Viewing a Report
1 Right-click the Report Catalog object that contains the report form that 

you want to use > click Generate Report.

2 Select the report form and query to use. 

Click Help for details.

3 Click OK.

A status box appears while the report is being generated. After the report 
is done generating, it appears in the View Report window (this may take 
a few moments). You can then print, save, or export the report as 
explained below.

Printing a Report
1 Generate the report as explained above.

2 On the toolbar of the View Report window, click Print.

3 Select the print options you want.

4 Click OK.
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Saving a Report
1 Generate the report as explained above.

2 On the toolbar of the View Report window, click Save.

3 Enter a name for the report, or select a previously saved report to 
overwrite. 

Click Help for details.

4 Click Save.

Exporting a Report
1 Generate the report as explained above.

2 On the toolbar of the View Report window, click Export Report.

3 Select the filename, path, and format to export to. 

Click Help for details.

4 Click OK.

Viewing a Previously Saved Report
1 Right-click the report catalog object that was used to generate the report 

> click Open Report.

2 Select the form that was used to generate the report.

3 Under Available Reports, select the report.

4 Click OK.

Customizing the Data-Selection Criteria (Query) Used to Generate a 
Report

1 Right-click the Report Catalog object that you will use to generate the 
report > click Properties.

2 On the Queries page, select the form that you will use to generate the 
report.

3 Depending on what’s listed under Available Queries, perform the 
appropriate action:
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4 In the query-building dialog box, specify the data-selection criteria that 
you want to be used to generate the report. 

Click Help for details.

5 (Optional) Click Generate Report to generate the report immediately 
using the criteria you specified.

After viewing the report, close the View Report window and modify the 
query further if needed. 

6 When you are satisfied with the data-selection criteria you have specified, 
click OK in the query-building dialog box.

Designing Custom Reports
To design custom reports, you must complete the general reporting setup (see 
“Setting Up Reporting” on page 103), and then add the JReport Designer tool 
(purchased separately) to the ConsoleOne installation that you will use to 
design reports. You can then create your own custom report catalogs and 
report forms.

In This Section

“Adding JReport Designer to Your ConsoleOne Installation” on page 109

“Creating a Custom Report Catalog” on page 109

“Creating or Modifying Report Forms” on page 110

Available Queries Action

Only the default 
query is listed

Click Add.

NOTE: You can’t customize the default query on this 
page. To customize it, see instead “Designing 
Custom Reports” on page 108.

Additional (non-
default) queries are 
listed

Select the query that you want to customize > click 
Open.
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Adding JReport Designer to Your ConsoleOne Installation
1 From the Windows computer where ConsoleOne is installed, or from a 

Windows computer with a drive mapped to the NetWare server where 
ConsoleOne is installed, start a Web browser and go to the Novell 
ConsoleOne site (http://www.novell.com/products/consoleone).

2 Locate and click the JReport Designer link.

This should take you to a Jinfonet Web site where you can download a 
package called JReport Designer for Novell Reporting Services. This 
package is designed to integrate the JReport Designer tool with your 
ConsoleOne installation. If you can’t find the JReport Designer link on 
the ConsoleOne site, check the site again later. At the time of this 
publishing, the availability date for JReport Designer hasn’t been 
finalized.

3 Follow the instructions on the Jinfonet Web site to download and run the 
JReport Designer for Novell Reporting Services setup program 
(DESIGNER.EXE or SETUP.EXE).

4 Follow the prompts to complete the setup. When you are prompted for the 
installation directory, choose the location of your ConsoleOne 
installation.

By default, this is:

Creating a Custom Report Catalog
1 Right-click the container that you want to create the Report Catalog 

object in > click New > click Object.

2 Under Class, select Report Catalog > click OK.

3 In Name, enter a name for the new report catalog object. 

Be sure to follow proper eDirectory naming conventions. (See Novell 
eDirectory Administration Guide > Naming Conventions.)

Example: Custom XYZ Reports

4 Select the location to store the files associated with the report catalog, and 
select the data source to be used by the report catalog. 

Click Help for details.

Local Drive C:\NOVELL\CONSOLEONE\1.2

Network Drive SYS:PUBLIC\MGMT\CONSOLEONE\1.2
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5 Click OK.

6 In the Add Table dialog box, select the database tables that your report 
forms will query > click Add. 

Repeat this action as needed.

If you are using the Novell-defined NDS Reporting data source, most of 
the database tables correspond to eDirectory object classes.

7 Click Done in the Add Table dialog box.

8 Create the catalog’s report forms as explained below.

Creating or Modifying Report Forms
1 Right-click the report catalog object that contains (or will contain) the 

report forms > click Properties.

2 On the Forms page, create and modify the report forms you want. 

Click Help for details.

Clicking New or Open on the Forms page starts the JReport Designer 
tool. For information on using that tool, see the JReport User’s Guide 
(http://www.jinfonet.com/help/index.htm).
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10 Troubleshooting

This chapter gives solutions to problems you might encounter when setting up 
or using ConsoleOneTM. If this information doesn’t solve your problem, you 
can try the following contacts:

In This Chapter

“ConsoleOne Malfunctions or Won’t Start” on page 112

“Performance Is Sluggish” on page 113

“I Need a Completely Local Installation” on page 113

“Can’t Find the eDirectory Tree That I Want to Log In To” on page 113

“Newly Created User Can’t Log In” on page 113

“Can’t Create Volume or Directory Map Object” on page 114

“Can’t Abort Partition Operation” on page 114

“Problems Generating a Report” on page 114

“Field or Option is Disabled” on page 115

“Known Quirks and Limitations” on page 115

Contact Use to Get

Novell Support site (http://
support.novell.com/) or the vendor 
you purchased the software from

Free technical support

1-800-NETWARE Direct, charged Novell® technical support

Novell Free Downloads site (http://
www.novell.com/download/)

ConsoleOne updates
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ConsoleOne Malfunctions or Won’t Start

Possible Cause Solution

You are starting ConsoleOne 
on a Windows computer that 
doesn’t have the required drive 
mapping or Novell client 
software.

Make sure you have the system requirements and drive mappings 
specified for “Windows” on page 18.

You are starting ConsoleOne 
on a NetWare® server that 
doesn’t have NJCL 2 installed 
properly.

Remove the \NJCLV2 folder from SYS:JAVA on your server and 
reinstall ConsoleOne. This installs a new copy of NJCL 2 on your server 
so that ConsoleOne will work.

You are starting ConsoleOne 
on a Linux or Solaris computer 
that doesn’t have the correct 
Java runtime environment 
(JRE).

If you chose not to install the JRE during installation of ConsoleOne and 
your existing JRE is not the one noted in “System Requirements for 
Linux” on page 23 or “System Requirements for Solaris” on page 25, you 
might want to add the bundled JRE to your ConsoleOne installation 
(type c1-install -c jre at the system prompt). If you are sure you 
want to run with a different JRE, then set the JRE_HOME or 
C1_JRE_HOME environment variable to the location of that JRE. 
ConsoleOne determines which JRE to use as follows:

If C1_JRE_HOME is specified, that JRE is used.

If the JRE bundled with ConsoleOne is installed, that JRE is used.

If JRE_HOME is specified, that JRE is used.

Otherwise, ConsoleOne displays an error message and quits.

You are starting ConsoleOne 
remotely through an X terminal 
session on a computer that 
doesn’t have an X windowing 
subsystem.

If ConsoleOne is installed on a Linux or Solaris computer and you are 
trying to run it remotely through an X terminal session, the computer 
where you are running the terminal session must have an X windowing 
subsystem installed or it won’t work. The X terminal session must be 
configured to permit transmissions from the remote host and to use the 
local X windowing subsystem for display.
112 ConsoleOne User Guide

ConsoleOne User Guide
104-001316-001
August 29, 2001

Novell Confidential



Manual 99a38 July 17, 2001
Performance Is Sluggish

I Need a Completely Local Installation

Can’t Find the eDirectory Tree That I Want to Log In To

Newly Created User Can’t Log In

Possible Cause Solution

This is often due to insufficient RAM. 
Under tight memory conditions, 
ConsoleOne might gradually slow down.

Make sure ConsoleOne is running on the system configuration 
recommended in “Installing and Starting ConsoleOne” on 
page 18. Adding more RAM is the biggest performance 
booster, especially if you are generating reports. If 
ConsoleOne has been running for a long time, you might want 
to restart it.

Possible Cause Solution

The larger product that installed ConsoleOne 
might not provide the option to install 
ConsoleOne locally on your hard disk.

See “Installing and Starting ConsoleOne” on page 18. 
Make sure to choose a local drive during the installation 
procedure.

Possible Cause Solution

The server that you are 
viewing the network through 
can’t see all the trees.

If you are running ConsoleOne on Windows, set a different server as your 
primary server in NetWare Connections (see the red N on the Windows 
taskbar). Then redisplay the list of trees in ConsoleOne.

Possible Cause Solution

If you cancelled the Set Password dialog box when 
creating the User object, an object-key pair 
(eDirectoryTM password) wasn't created for the user 
account.

Go to the Password Restrictions property page of 
the User object and click Change Password to 
create an object-key pair (eDirectory password).
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Can’t Create Volume or Directory Map Object

Can’t Abort Partition Operation

Problems Generating a Report

Possible Cause Solution

The eDirectory tree you 
are trying to create the 
Volume or Directory Map 
object in doesn’t contain 
a NetWare server.

The tree must contain a NetWare server that hosts a NetWare volume or you 
can’t create a Volume or Directory Map object in the tree.

NOTE: To provide access from your tree to NetWare file systems in other 
trees, you can create NetWare Server and Volume objects in your tree that 
point to the NetWare servers and volumes in the other trees. The NetWare 
Server objects must be created before the Volume or Directory Map objects.

Cause Solution

ConsoleOne doesn’t yet have the capability to abort 
a partition operation started by another administrator.

Use the legacy NDS® ManagerTM tool.

Possible Cause Solution

Insufficient RAM Some of the larger reports require a lot of memory to generate. You should 
have at least 128 MB RAM on the Windows computer that you’re using to 
generate the report.

Report catalog is 
corrupted

Delete and recreate the Report Catalog object. Then try generating the report 
again. To create a Report Catalog object, you must have a NetWare volume 
in your eDirectory tree to install the report catalog files on.

You might not have 
completed the required 
reporting setup

See “Setting Up Reporting” on page 103.
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Field or Option is Disabled

Known Quirks and Limitations
The following are known quirks and limitations of this release of ConsoleOne. 
Most of these should no longer exist in future releases.

Possible Cause Solution

You might need to modify some other 
setting before the field or option becomes 
available.

Click Help for information about using specific fields and 
options.

You might not have rights to access the 
information or perform the operation 
associated with the field or option.

Check your effective rights to the eDirectory property 
associated with the field or option. (See “Viewing Effective 
Rights” on page 56.) If necessary, contact your network 
administrator to get the rights you need.

Quirk or Limitation Workaround

eDirectory searches return only the first 1,200 
objects.

If your search returns 1,200 objects and you 
suspect there are more, refine the search criteria to 
return fewer objects.

Jumping to an object in the right pane by typing its 
name doesn’t work if there are more than 1,000 
objects in the list.

Use Edit > Find to find the object, or use View > 
Filter to hide other object types and then type the 
object name.

Selecting large sets of eDirectory objects from a list 
of more than 1,000 objects doesn’t work. 
(ConsoleOne retrieves the list of objects from 
eDirectory one chunk at a time and won’t let you 
select across these invisible chunks.)

Select a smaller set of objects and repeat the 
operation as many times as needed to complete 
your task.

Applying a change to a multi-value property in 
eDirectory doesn’t work if the total data size 
exceeds 48 KB. For example, deleting 1,000 
usernames from a membership list would require 
about 48 KB if the average name were 24 
characters. (Each character is two bytes.)

Apply the change in smaller chunks.

The count of eDirectory objects in the right pane 
(shown in the bottom right corner) is an estimate if 
there are more than 1,000 objects.

If your task involves more than 1,000 objects and 
an exact count is required, use NetWare 
Administrator.
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Not all the values of a multi-value eDirectory 
property are shown if there are too many to fit in the 
RAM available to ConsoleOne.

Increase the available RAM (try closing all other 
programs) and redisplay the list. Currently, Novell 
eDirectoryTM returns all the property values to 
ConsoleOne at once. A future eDirectory release 
will return them one chunk at a time.

Property names in lists are always shown in English. 
(ConsoleOne reads them directly from the 
eDirectory schema, which is in English only.)

If this prevents you from completing your task, go 
to the Novell Web site and submit an enhancement 
request. In the meantime, use NetWare 
Administrator to complete your task.

Restricting a user’s volume space or a folder’s size 
doesn’t work on an NSS volume.

The ability to restrict space on an NSS volume will 
be added in a future release. NetWare 
Administrator doesn’t have this capability either.

Generating and printing reports doesn’t work if 
ConsoleOne is running on a non-Windows* 
computer.

Run ConsoleOne on a Windows computer with at 
least 128 MB RAM.

Most customizations to ConsoleOne views aren’t 
saved across sessions. One exception is that 
customizations to object property pages (such as 
reordering and hiding pages) are saved.

For details, see “Customizing Views” on page 41.

When running ConsoleOne on Linux, you can’t 
enter more than a couple of values at a time in multi-
value fields.

This is a problem with Java on Linux and will be 
fixed in a future release. For now, you must enter a 
couple values, close the properties, reopen the 
properties and enter a couple more values, and so 
on.

When running ConsoleOne on Solaris, if you click a 
link or menu option to go to a URL in a Web browser, 
the action fails if Netscape isn’t installed and added 
to the system’s PATH environment variable.

Install Netscape and add the directory where the 
Netscape executable file is located to your 
system’s PATH environment variable.

Quirk or Limitation Workaround
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