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About This Guide

This guide describes how to install and configure Novell® ClientTM for Windows* NT*/2000/XP 
version 4.90 and Novell Client for Windows 95/98 version 3.40 and later software.
IMPORTANT: Novell Client is not designed to run on Windows ME or Windows XP Home Edition.

If you are using a previous version of Novell Client software, you should update it to the latest 
version from Novell’s download Web site (http://www.novell.com/download). If you are using a 
previous version of Novell Client software, some of the information in this documentation might 
not apply.

This guide is intended for network administrators and is divided into the following sections:

Chapter 1, “What’s New,” on page 9

Chapter 2, “Installing Novell Clients,” on page 13

Chapter 3, “Setting Up Client Login,” on page 33

Chapter 4, “Setting Client Properties,” on page 45

Chapter 5, “Managing Novell Client,” on page 49

Chapter 6, “Printing to a Network Printer,” on page 55

Appendix A, “Troubleshooting Issues,” on page 59

Additional Documentation

For documentation on known issues, see the Novell Client Readme.

For documentation on login scripts, see the Novell Login Scripts Guide.

Documentation Updates

For the latest version of this documentation, see the Novell Clients online documentation (http://
www.novell.com/documentation/lg/noclienu/index.html).

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
within a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as UNIX*, should use forward slashes as required by your software.
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1 What’s New

The following features are new in Novell® ClientTM for Windows Support Pack 2 for NT/2000/XP 
version 4.90 and Novell Client 4.9 SP2:

Service Location Protocol (SLP) v2

Display of advanced password policy settings

User Names in E-mail Format Allowed

The Novell Client now supports user names in e-mail address format. For example:

juan.lopez@bank.com

The period and the @ sign in the user name are now supported by eDirectory as an ordinary 
part of the UserID.

The following features are new in Novell® ClientTM for Windows NT/2000/XP version 4.90 and 
Novell Client for Windows 95/98 version 3.40:

Web-based installation option

See “Installing Novell Clients from a Web Server” on page 25. 

Novell Client Update Agent

See “Upgrading the Novell Client Using Novell Client Update Agent” on page 26.

Service Pack installation options

See “Installing Service Packs” on page 29.

Contextless login and treeless login options (Windows NT/2000/XP only)

See “Setting Up LDAP Contextless Login and LDAP Treeless Login” on page 38.

Additional options on the Login dialog box

For a list of these options, see “Customizing the Novell Login Dialog Box” on page 35.

NDS Login Method for Novell Client for Windows NT/2000/XP only (also known as 
Universal Password)

The login method now integrates with and installs the NICI Client 2.6 and NMASTM Client 
2.2 by default (only the NMAS NDS® method is installed). 

IMPORTANT: On Windows 95/98, you must install NICI and NMAS after you have completed the Novell 
Client installation in order to use the new password methods. You must restart your workstation before 
installing NICI and NMAS. If you already have NICI and NMAS installed, they are not updated during the 
Novell Client install on Windows 95/98. You do not need to update them in order to work with the new 
login methods. NICI and NMAS are updated on Windows NT/XP/2000.

You can control both the installation and use of NMAS by installing the Novell Client using 
a platform-specific unattend file. In the Installation > Setup tab, there is an Install NICI and 
NMAS check box. If you uncheck this box, NICI and NMAS will not be installed. In the 
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Client > Advanced Login tab, there is an NMAS Authentication check box. If you uncheck 
this box, Novell Client will not use NMAS during authentication even if the component is 
installed. If the component is not installed and this box is checked, Novell Client login skips 
the NMAS authentication and authentication continues. 

For more information, see “Creating or Updating the Platform-Specific Configuration Files” 
on page 22.

The NDS Login Method (universal password) enforces password policy uniformly across 
multiple authentication systems (such as Native File Access). It also manages multiple types 
of password authentication methods from disparate systems. This is done by creating a 
common password that can be used by all protocols to authenticate users.

NMAS authentication adds additional security to the network. However, if your network does 
not use NMAS, login might take additional time and you might want to disable NMAS 
authentication. For more information on disabling NMAS, see ““Disabling and Uninstalling 
the NMAS Client”” and ““Disabling NMAS on the Server”” in the Novell Modular 
Authentication Services (NMAS) 2.2 Administration Guide.

Universal Passwords are only available on NetWare 6.5 servers and not enabled by default on 
the server. For more information on deploying universal passwords on a NetWare 6.5 server, 
see the NetWare 6.5 Universal Password Deployment Guide in the Novell NetWare 6.5 
documentation Web site (http://www.novell.com/documentation/lg/nw65).

Uninstall from Add/Remove Programs

See “Uninstalling Novell Client” on page 53.

Support for NetIdentity agent

The NetIdentity agent can be installed with Novell Client or as a separate installation. It 
provides background authentication to Windows Web-based applications that require Novell 
eDirectoryTM authentication such as iPrint, Novell Portal Services, eGuide, Novell Virtual 
Office, ZENworks®, NetStorage, and iManager.

For more information, see the NetWare 6.5 Security Overview in the Novell NetWare 6.5 
documentation Web site (http://www.novell.com/documentation/lg/nw65).

In addition to these features, several other features have been added to the Novell Client:

UNC Path Filter to optimize performance for service location and caching (Windows NT/
2000/XP only)

Support for files larger than 4 GB file on servers that are running NetWare 6 SP3 or NetWare 
6.5 (Windows NT/2000/XP only)

OpLock Level 2 support (Windows NT/2000/XP only)

Ability to remove the Novell Login screen from initial computer startup (Windows NT/2000/
XP only)

Improved Novell VPN support with login

Continuing improvements for Novell Cluster ServicesTM failover support

Same state of the Workstation Only check box on the Novell Login screen as the last login 
(Windows NT/2000/XP only)

For example, if you checked the Workstation Only check box the last time you logged in, the 
next time you log in, it will be checked. 

Support for Novell DFS junctions for NCPTM-based Clients (Windows NT/2000/XP only)
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When you split an NSS volume using Distributed File Services (DFS), a junction is created 
that points to where you moved the data. Junctions are transparent to users except for a 
property page that appears when users right-click the junction and select Properties. 

IMPORTANT: Several programs that ship with NetWare 6.5 require Novell Client for Windows 95/98 3.4 or 
later or Novell Client for Windows NT/2000/XP 4.9 or later. If you are using NetWare 6.5 and you are using 
ConsoleOne® 1.3.6, Server Consolidation Utility, or DNS/DHCP, you should upgrade your Novell Client to the 
latest version before running the software.

The following software is included on the Netware 6.5 Novell Clients Software CD:

Novell Client 4.9 for Windows NT/2000/XP

Novell Client 3.4 for Windows 95/98 

Novell Modular Authentication Services (NMAS) Client 2.2

Client NICI 2.6 for Windows

NetIdentity Agent 1.2

Novell NetDrive Client 4.1

Novell ConsoleOne 1.3.6 with NetWare 6.5 snap-ins

exteNdTM WorkbenchTM 4.1.1

exteNd App Server Client 5.0
IMPORTANT: On Windows 95/98, you must install NICI and NMAS after you have completed the Novell 
Client installation in order to use the new universal password methods. You must restart your workstation 
before installing NICI and NMAS. If you already have NICI and NMAS installed, they are not updated during 
the Novell Client install on Windows 95/98. You do not need to update them in order to work with the new login 
methods. NICI and NMAS are updated on Windows NT/XP/2000.
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2 Installing Novell Clients

This section explains how to install Novell® ClientTM for Windows for Windows NT/2000/XP and 
Novell Client for Windows 95/98 software on one workstation or across the network. See the 
following:

“Preparing to Install the Client Software” on page 13

“Installing Novell Client on a Workstation” on page 16

“Installing Novell Clients on Multiple Workstations” on page 19

“Installing Novell Clients from a Web Server” on page 25

“Upgrading the Novell Client Using Novell Client Update Agent” on page 26

“Installing Service Packs” on page 29

“Uninstalling Network Components during an Upgrade” on page 29

“Upgrading a Client Workstation to Windows 2000” on page 30

“Upgrading a Client Workstation to Windows XP” on page 31

Preparing to Install the Client Software
Before installing the client software, make sure the server and workstations have sufficient 
resources and the required software. The hardware and software setup for the server and client 
workstations require you to complete the following tasks:

Checking server protocols and requirements

Locating the latest Novell Client software

Checking for a valid network connection

Checking client workstation requirements

To install Novell Client on a workstation, the logged-in user must be an administrator on the 
workstation. Users without administrator rights to the workstation cannot install new software.

Supported Windows Platforms
Novell® ClientTM for Windows Support Pack 2 for NT/2000/XP version 4.90 and Novell Client 4.9 
SP2 supports the following Windows platforms:

Windows NT 4 with Service Pack 6a or later and at least 24 MB of RAM

Windows 2000 Professional

Windows 2000 Server 

Windows 2000 Advanced Server
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Windows XP Professional 

Windows XP Tablet PC Edition 

Windows Server 2003 Server Edition 

Windows Server 2003 Enterprise Edition (32-bit versions only) 
IMPORTANT: Novell Client is not designed to run on Windows ME or Windows XP Home Edition.

Checking Server Protocols and Requirements
You must prepare your servers to work with the Novell Client software. You must know what 
protocols you use on the server and make sure that the servers are configured to support long 
filenames. NetWare® 5 or later automatically supports long filenames and does not need to have 
the name space added to it. However, you must add long filename support to NetWare 3 and 
NetWare 4 servers.

You can install Novell Client with one of the following protocol options:

IP Only (NetWare 5 or later)—default for new installations

Installs the IP protocol stack, which allows the client to run in IP-only networks; the 
workstation cannot communicate with IPXTM servers.

IP with IPX Compatibility Mode (NetWare 5 or later)

Installs IP and includes Compatibility mode, which allows IPX applications to run in IP-only 
networks by converting IPX packets into IP packets. IPX Compatibility mode allows the 
client to communicate with services in IPX-only networks if the Migration Agent is installed 
on any NetWare 5 or later servers. IPX Compatibility mode requires Service Location 
Protocol (SLP) on the server.
IMPORTANT: Workstations using IPX Compatibility Mode cannot have an IPX internal network number 
configured. If you have configured an IPX internal network number on your workstation and you are 
planning to install the Novell IP Client with IPX Compatibility Mode, then remove the IPX internal network 
number before installing the client.

IP and IPX

Allows the client to run in both IP and IPX networks. The workstation uses the same protocol 
as the server it is communicating with.

IPX Only

Allows the client to run in IPX-only networks. This option does not install IP.

If you are upgrading Novell Client software and you are keeping the same protocol option, you do 
not need to select a protocol option. The previous protocol configuration remains unchanged 
unless you choose a different protocol.

Adding Long Name Space

Make sure that long filename support is installed on NetWare 3 or NetWare 4 servers. NetWare 5 
or later servers automatically support long filenames.
IMPORTANT: Each name space added to a volume requires additional server memory. If you add name 
space support to a volume on a server without sufficient memory, that volume cannot be mounted. After a 
name space is added to a volume, the name space can be removed from the volume only by deleting the 
volume and re-creating it or by using VREPAIR.

1 Load the long name space.
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At the server console prompt, enter

LOAD LONG.NAM

On versions of NetWare earlier than NetWare 4.11, use the OS/2* name space, OS2.NAM. 
For NetWare 3.11 servers, use os2opnfx.nml for long filenames. This NLMTM is a part of 
311ptd.exe and is available on the Novell Web site.

2 Add the long name space.

At the server console prompt, enter

ADD NAME SPACE LONG TO VOLUME volume_name

Downloading the Latest Client Software
Novell Client software is shipped on CD and is also available from the Novell Web site. You 
should install the latest version of the software. To download the latest Novell Client software, 
complete the following steps.

1 Create an installation directory.

2 At the Novell download Web site (http://www.novell.com/download), click the client 
software that you want to download.

3 Follow the download instructions provided with the files on the Web site.

Checking for a Valid Network Connection
To check for a valid network connection from a Windows 95/98 or Windows NT/2000/XP 
workstation:

1 Open Network Neighborhood or My Network Places (NT/2000/XP).

2 Make sure that the networks you expect to see actually appear in the window.

If you have never installed a client or created a network connection, you might not have access to 
Network Neighborhood or My Network Places. Therefore, you must install the client software 
from CD-ROM. See “Installing Novell Client on a Workstation” on page 16.

Checking for Client Workstation Incompatibilities

Windows 95/98

The following network components are not compatible with Novell Client for Windows 95/98:

Microsoft* Client for NetWare networks

Microsoft Windows ME

Microsoft file and printer sharing for NetWare networks

Microsoft Service for NDS® software

Novell NetWare workstation shell 3.x (NETX)

Novell NetWare workstation shell 4.0 and later (VLMTM) clients

Novell IPX ODITM protocol 16-bit module for the NETX and VLM clients

If any of these network components is installed, the client installation program detects the conflict 
and removes the conflicting network components.
Installing Novell Clients 15
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Windows NT/2000/XP 

Novell Client is not designed to run on Windows XP Home Edition.

Novell Client cannot be installed on Windows 2000 or Windows XP if the Local Area Connection 
Properties Page is open. Close this page before running the Novell Client install.

IPX Compatibility and Novell NetWare/IPTM Adapter will not be upgraded from Windows NT to 
Windows 2000. 

Some Windows NT 4.0 printer drivers are incompatible with Windows 2000 and XP and will not 
install. Contact Microsoft for more information.

Additional Information
“Installing Novell Client on a Workstation” on page 16

“Installing Clients from the Network” on page 20

“Installing Novell Clients from a Web Server” on page 25

Installing Novell Client on a Workstation
If you plan to install Novell Client software on a small number of workstations, or if the 
workstations are not yet connected to a network, install from the Novell Client CD or download it 
from the Novell download Web site (http://www.novell.com/download).

To install Novell Client on a workstation, the logged-in user must be an administrator on the 
workstation. Users without administrator rights to the workstation cannot install new software.

In this version of Novell Client, NICI Client 2.6 and NMASTM Client 2.2 (NDS method only) are 
installed by default on Windows NT/XP/2000. If they are already installed, they are updated 
automatically. You can control both the installation and use of NMAS by installing the Novell 
Client using a platform-specific unattend file. In the Installation > Setup tab, there is an Install 
NICI and NMAS check box. If you uncheck this box, NICI and NMAS will not be installed. In the 
Client > Advanced Login tab, there is an NMAS Authentication check box. If you uncheck this 
box, Novell Client will not use NMAS during authentication even if the component is installed. If 
the component is not installed and this box is checked, Novell Client login skips the NMAS 
authentication and authentication continues. For more information, see “Creating or Updating the 
Platform-Specific Configuration Files” on page 22.

On Windows 95/98, you must install NICI and NMAS after you have completed the Novell Client 
installation in order to use the new password methods. You must restart your workstation before 
installing NICI and NMAS. If you already have NICI and NMAS installed, they are not updated 
during the Novell Client install on Windows 95/98. You do not need to be update them in order to 
work with the new login methods.
TIP: If you are installing or upgrading Novell Client software on several workstations on the network, consider 
using the network installation explained in “Installing Clients from the Network” on page 20.

The Novell Client Setup utility installs Novell Client software on workstations running Windows. 
This utility lets you select the client that you want to install from a list of available clients. 
Administrative options are also available.
TIP: The Typical Install option installs only the basic Novell Client components. If you want to install additional 
services such as NDPS®, use the Custom Installation option. If you are upgrading Novell Client software, the 
same custom components are installed unless you choose different ones. 
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ZENworks® for Desktops Remote Management requires that you install Workstation Manager components 
during the Novell Client installation. 

To install Novell Client software on a workstation:

1 Do one of the following:

Download the latest Novell Client software and then follow the installation instructions 
included on the download page.

See “Downloading the Latest Client Software” on page 15.

Insert the Novell Clients Software CD.

If the Novell Client Setup utility does not automatically launch, run winsetup.exe from 
the root of the CD.

There are several customized parameters that you can use during the installation by running 
the installation from the command line. These include special accessibility settings, status 
logging, automatic client upgrade, and others. For more information, see “Using Setup 
Parameters with the Novell Client Installation” on page 17.

2 Click the software you want to install.

3 Follow the on-screen instructions.

After Novell Client is installed, check your network protocol configuration. See “Configuring 
Network Protocols” on page 18.

Using Setup Parameters with the Novell Client Installation
There are several customized parameters that you can use during the installation by running the 
installation from the command line. These include special accessibility settings, status logging, 
automatic client upgrade, and others.

1 Click Start > Run.

2 Type the path to the software followed by a space, a slash (/), and then the parameter.

See Table 1 on page 17 and Table 2 on page 18 for more information on the options.

For Windows 95/98, type 
path_to_the_software\setup.exe\setup_parameter

For Windows NT/2000/XP, type 
path_to_the_software\setupnw.exe\setup_parameter

Table 1 Windows NT/2000/XP Setup Parameters

Parameter Description

U Use settings in the default unattend file, unattend.txt. 

U:path Use settings in the specified unattend file. Specify the 
path to the text file.

SL Create status log entries in the default status file, 
status.log.

SL:path Create status log entries in the specified status file. 
Specify the path to the log file.
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Table 2 Windows 95/98 Setup Parameters

Configuring Network Protocols
After you install Novell Client, make sure that it is configured correctly for your network.
IMPORTANT: Before you configure network protocols, make sure you have the correct information and any 
addresses needed. If you configure protocols incorrectly, the workstation will not be able to connect to the 
network, or it might conflict with other workstations using the same address. 

1 Do one of the following: 

Windows 95/98 and Windows NT: Right-click Network Neighborhood, click 
Properties, select the protocol that you want to configure, then click Properties.

Windows 2000 and XP: Right-click My Network Places, click Properties, right-click 
Local Area Connection, select the protocol that you want to configure, then click 
Properties.

2 Configure the protocol options in each tab, then click OK.

ACU Launch Automatic Client Upgrade (ACU) and 
automatically upgrade the client if it is an older version. 

508 Enable special accessibility options in accordance with 
the Workforce Investment Act of 1998 Section 508. 

? Display help screen for setup parameters.

Parameter Description

U Use settings in the default unattend file, unattend.txt. 

U:path Use settings in the specified unattend file. Specify the 
path to the text file.

SL Create status log entries in the default status file, 
status.log.

SL:path Create status log entries in the specified status file. 
Specify the path to the log file.

ACU Launch Automatic Client Upgrade (ACU) and 
automatically upgrade the client if it is an older version. 

RB Roll back to the previous version of Novell Client if the 
installation is not successful. 

NCF Enable No Cab Fix. This prevents the copying of .cab 
files during the installation.

508 Enable special accessibility options in accordance with 
the Workforce Investment Act of 1998 Section 508. 

? Display help screen for setup parameters.

Parameter Description
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For example, if your network uses DHCP to assign IP addresses automatically, click the IP 
Address tab and then click Obtain IP Address Dynamically. Or, if you must use a static IP 
address, click Specify an Address and type a valid IP address.
TIP:  Click the question mark in the upper-right corner and then click in any field for more information 
about that field.

3 Click OK.

You might be prompted to supply the Windows operating system CD. If you do not have 
access to the correct files, you might not be able to create a network connection.

You should now set the Novell Client properties for the workstation. See Chapter 4, “Setting Client 
Properties,” on page 45.

Installing Novell Clients on Multiple Workstations
You can install Novell Client software on multiple workstations two ways: 

From a Novell server

This method entails copying files to the server and modifying the login script, and it is 
sometimes called an Automatic Client Upgrade (ACU). See “Installing Clients from the 
Network” on page 20.

From a Web server

This method entails creating a small executable that downloads the Novell Client install files 
from a Web server IP address and launches the Novell Client install. See “Installing Novell 
Clients from a Web Server” on page 25.

Both methods reduce the time needed to deploy new client software in your network by setting 
client properties and optional settings in configuration files prior to installation and by automating 
the installation process so that you do not have to physically install software at each workstation. 

Before you deploy a network or Web server install, you should decide what configuration options 
best suit your network and then set these options in the platform-specific configuration file 
generated by Novell Client Install Manager (NCIMAN). The installation reads the configuration 
file in order to configure the Client. This file must be placed in the same folder as the installation 
utility.

For example, if your network does not take advantage of Novell Modular Authentication Services 
(NMASTM) or Novell International Cryptographic Infrastructure (NICI), you can disable this 
option or choose not to install these components to increase the login speed. 
IMPORTANT: In NCIMAN, you can control both the installation of the NMAS NDS method and use of NMAS. 
In the Installation > Setup tab, there is an Install NICI and NMAS check box. If you uncheck this box, NICI and 
NMAS will not be installed. In the Client > Advanced Login tab, there is an NMAS Authentication check box. If 
you uncheck this box, Novell Client will not use NMAS during authentication even if the component is installed. 
If the component is not installed and this box is checked, Novell Client login skips the NMAS authentication 
and authentication continues.

Or, if you are planning on using the Novell Update Agent to update future versions of Novell 
Client, you should enable this option now so that it can be used with future updates. See 
“Upgrading the Novell Client Using Novell Client Update Agent” on page 26 for more 
information. 
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Installing Clients from the Network
You can install Novell Client software on multiple workstations from the network by copying files 
to the server and modifying the login script. This installation is sometimes referred to as an 
Automatic Client Upgrade (ACU).

In this version of Novell Client, NICI Client 2.6.4 and NMAS Client 2.7 (NDS method only) are 
installed by default on Windows NT/XP/2000. If they are already installed, they are updated 
automatically. You can control both the installation and use of NMAS by installing the Novell 
Client using a platform-specific unattend file. In the Installation > Setup tab, there is an Install 
NICI and NMAS check box. If you uncheck this box, NICI and NMAS will not be installed. In the 
Client > Advanced Login tab, there is an NMAS Authentication check box. If you uncheck this 
box, Novell Client will not use NMAS during authentication even if the component is installed. If 
the component is not installed and this box is checked, Novell Client login skips the NMAS 
authentication and authentication continues. For more information, see “Creating or Updating the 
Platform-Specific Configuration Files” on page 22.

On Windows 95/98, you must install NICI and NMAS after you have completed the Novell Client 
installation in order to use the new password methods. You must restart your workstation before 
installing NICI and NMAS. If you already have NICI and NMAS installed, they are not updated 
during the Novell Client install on Windows 95/98. You do not need to update them in order to 
work with the new login methods.
TIP: You can install the Novell Client using the Application Launcher component of ZENworks. Application 
Launcher lets you distribute applications such as the client software to workstations and manage those 
applications as objects in the eDirectoryTM tree. For more information, see the ZENworks for Desktops 
documentation.

On Windows XP, you can install the client software from the network on workstations running the Microsoft 
Client Service for NetWare. Run the install by logging in to the server using bindery emulation.

To install Novell Client on a workstation, the logged-in user must be an administrator on the 
workstation. Users without administrator rights to the workstation cannot install new software.

You can install and upgrade the client software on all platforms when users log in. The process 
involves six tasks:

1. Creating a folder on the server.

2. Copying Novell Client files and other required files to the new folder.

3. Granting rights to the new folder.

4. Modifying the ACU configuration file.

5. (Conditional) Creating or updating the platform-specific configuration files.

6. Creating or modifying the login script.

When the login script runs, acu.exe determines if the client needs to be upgraded. This initial check 
saves network bandwidth during login because the Setup utility is run only if the client needs to 
be updated.

Creating a Folder

1 Log in to a server as Admin or as a user with Admin equivalence.

Make sure that you have rights to copy files to a network folder that all users can access, as 
well as rights to modify login scripts.

2 Create a folder in sys:public.
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For example:

sys:\public\client

Copying Files

1 Do one of the following:

From the Novell Client CD, copy the winnt or win95 directories to the new folder.

If you are installing only one platform, you need to copy only the platform directory 
(winnt or win95) for the platform you will install.

If you are installing the client in only one language or if your network does not have 
enough space to accommodate multiple language directories, you can delete the language 
directories that you do not need from the nls directory under each client directory. To 
ensure that you have all necessary files, copy the entire client directory and then delete 
only the extra language directories.

Copy the downloaded Novell Client software files to the new folder.

See “Downloading the Latest Client Software” on page 15.

2 (Conditional) If you are installing Novell Client for Windows 95/98, copy the Windows 95 or 
Windows 98 .cab files to the win95 directory.

The files are on the Microsoft Windows 95 or Windows 98 CD (and Upgrade CD) in the 
respective win95 or WIN98 folder.

Granting Rights

1 Create a Group object in the eDirectory tree.

2 Place into that group users whose workstations need to be installed or upgraded.

3 Make sure that the group has the Read and File Scan rights to the folder that you created.

If you created a folder in sys:public, the new folder should have Read and File Scan rights 
already associated with it, but you should make sure that these rights have not been changed.

4 (Conditional) If you want the results of the installation to be added to a status log file, make 
sure that the group has the Write right to that file and enable status logging in the ACU 
configuration file. If you did not create the status log file prior to running the network 
installation, you must give users the Create and Write rights to the directory.

A status log file records the success or failure of the installation. when each workstation 
completes its installation, the status log file is appended to include information on that 
workstation.

Modifying the ACU Configuration File

The Automatic Client Upgrade utility (acu.exe) determines whether the client needs to be updated 
and allows you to specify several installation options.

Option Description Settings

[LAUNCHINSTALL] Specifies whether the platform-specific Setup 
utility will be launched after acu.exe determines 
that the installation is necessary.

Launch=Yes | No  
(Default: Yes)
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To customize ACU:

1 Open the acu.ini file located in the folder that you created on the server.

2 Modify the configuration options.
IMPORTANT: We recommend that you use the acu.ini file instead of the command line switches used in 
previous versions of Novell Client. acu.ini simplifies the installation process. If you choose to use switches, they 
will override acu.ini options.

Creating or Updating the Platform-Specific Configuration Files
NOTE: If you are installing the client with the default settings, you do not need to create or modify the 
configuration files. Skip this process and proceed to Chapter 4, “Setting Client Properties,” on page 45.

[DISPLAYDIALOG] Specifies whether users will be prompted to 
begin the upgrade.

Display=Yes | No  
(Default: Yes)

[UNATTENDFILE] Specifies whether a platform-specific 
configuration will be used and where it is 
located.

Use=Yes | No  
(Default: No)

File=configuration_file_path

[STATUS LOGGING] Specifies whether a status log will be created 
and where it will be located.

If you did not create a status log file prior to 
installation, it will be created and placed in the 
installation directory on the network or in the 
directory specified in the File setting.

Use=Yes | No  
(Default: No)

File=log_file_path

[SUPPORTPACK] Specifies whether ACU looks for a Support 
Pack in the same location that the installation is 
launched from.

If this is set to Yes, then ACU executes the 
client installation (if there is one) and then 
executes the Support Pack installation (if there 
is one located in the same location as the client 
installation files).

Use=Yes | No  
(Default: Yes)

[ADMINISTRATORM
ESSAGE]

Specifies additional text that will appear when 
the user is prompted to start an ACU.

Message=the_message_you 
want_to_appear

[CLIENTLOCAL 
INSTALL]

Specifies whether the installation will be copied 
to a specified local directory and run locally. 

LocalInstall=Yes | No 
(Default: No)

LocalDirectory=directory_wh
ere_you_want_the_installati
on_copied  
(Default: 
c:\novell\clientlocalinstall)

DeleteLocalInstall=Yes | No 
(Default: No)

TIP: If you want to delete the 
files after the installation is 
complete, set 
DeleteLocalInstall to Yes.

Option Description Settings
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Each platform-specific installation utility reads a configuration file generated by Novell Client 
Install Manager in order to configure the client properties. This file provides information such as 
where to copy drivers during installation and the most recent version number. This file must be 
placed in the same folder as the installation utility.
IMPORTANT: If you are configuring Windows 95/98 workstations, options that were set in the nwsetup.ini file 
or on the command line in previous versions of Novell Client (such as Display First Screen or CAB FIX) are 
now set up in Novell Client Install Manager.

To create a configuration file:

1 Start Novell Client Install Manager (nciman.exe).

Windows 95/98: Novell Client Install Manager is located in the win95\ibm_language \admin 
folder that you copied to the server.

Windows NT/2000/XP: Novell Client Install Manager is located in the winnt\I386\admin 
folder that you copied to the server.

2 Click File > New, select the platform, then click OK.

3 Modify the installation options as needed.
IMPORTANT: If you use a platform-specific configuration file to configure Novell Client and you are using 
acu.exe, you must change the [UNATTENDFILE] option to Yes in the acu.ini file.

3a In the Installation Options list box, double-click the configuration option that you want 
to modify.

3b In the property pages, set the parameters and then click OK.

The values that you set appear in the right list box.
TIP: You can import the settings from a workstation that has been previously configured and save them 
to the configuration file. After you set up the workstation, click File > Import Registry to import the settings.

4 Modify the Client Properties as needed.

For example, if your network uses LDAP, you can enable contextless login. Or, you might 
want to change the welcome screen bitmap. 

For more information on the Client Properties, see Chapter 4, “Setting Client Properties,” on 
page 45 and Chapter 3, “Setting Up Client Login,” on page 33. Or, right-click the properties 
to view the help. 

5 Click File > Save.

You can use any filename (for example, unatt_95.txt or unatt_nt.txt).

6 Copy this file to one of the following directories:

Windows 95/98: win95\ibm_language

Windows NT/2000/XP: winnt\i386
IMPORTANT: The path to the text file cannot contain long filenames.

Creating or Modifying the Login Script

You need to modify login scripts for users whose workstations will be upgraded.

To upgrade workstations for users in a container, modify that container’s login script.

To upgrade workstations for users in a profile, modify that profile’s login script.

To upgrade specific users’ workstations, modify those users’ login scripts.
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To upgrade a workstation running bindery-based client software (such as Microsoft Client for 
NetWare Networks which ships with Windows 95 or Windows 98), edit the system login script 
(sys:public\net$log.dat).

Creating or Modifying a User Login Script in iManager

1 Click Roles and Tasks > User Management > Modify User. 

2 Specify a username and context, then click OK. 

3 Click General > Login Script.

4 Type the login script commands and information in the login script text box.

For a sample of the login script commands that you need to add to the scripts, see “Sample 
Client Installation Login Script” on page 24.
IMPORTANT: Make sure that you edit the sample login script to match the server names, directory 
paths, and specifications of your own network.

For additional information on all login script commands, see the Novell Login Scripts Guide.

5 To save the login script, click OK.

Creating or Modifying a Login Script Using ConsoleOne

1 Double-click the object whose login script you want to create or modify.

2 Click Login Script.

3 Type the login script commands and information into the login script text box.

For a sample of the login script commands that you need to add to the scripts, see “Sample 
Client Installation Login Script” on page 24.
IMPORTANT: Make sure that you edit the sample login script to match the server names, directory 
paths, and specifications of your own network.

For additional information on all login script commands, see the Novell Login Scripts Guide.

4 To save the login script and close the Details dialog box, click OK.

If the login script that you just created was a container or user login script, you’re finished and 
the client software will be installed or updated the next time users log in.

If the login script that you just created was for a Profile object, you must associate the User 
object with the Profile object and make the User object a trustee of the Profile object. See 
““Getting Around the One Profile Login Script Restriction”” in the Novell Login Scripts 
Guide.

For additional information on all login scripts, see Novell Login Scripts Guide.

Sample Client Installation Login Script

The following sample shows the commands that you add to the login script in order to install the 
client software from the network. The sample includes text for installing across an internal 
network.
TIP: In this sample, the text that is necessary to the script is represented in uppercase letters. The information 
that you should customize for your network is in lowercase letters.

REM *****  Windows 95/98 ***** 
IF (OS = "win95") OR (OS = "WIN98" AND OS_VERSION <> "V4.90") THEN 
   WRITE "Updating Novell Client for Windows 95/98." 
   #\\server1\sys\public\client\win95\ibm_enu\acu.exe 
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   IF "%ERROR_LEVEL" = "1" THEN 
        EXIT 
   END 
END 

REM ***** Windows NT/2000/XP ***** 
IF OS = "winnt" 
   WRITE "Updating Novell Client for Windows NT/2000/XP." 
   #\\server1\sys\public\client\winnt\i386\acu.exe 
   IF "%ERROR_LEVEL" = "1" THEN 
        EXIT 
   END 
END

NOTE: If you are using this sample script to replace the Microsoft Client with Novell Client for Windows95/98, 
some user intervention is necessary. Due to Microsoft Client’s limited scripting capabilities, users must close 
an open DOS box before the workstation is rebooted and the installation is completed.

What Users See

If this is a new client software installation, or if it is an upgrade from older client software, the 
software is installed or upgraded when users log in and restart the workstation. Users might see 
system messages as their workstations are upgraded, depending on how you set up the installation.

Installing Novell Clients from a Web Server
You can install Novell Client software from a Web server. Using the WRITEIP utility, you can 
create a small executable called SETUPIP that downloads the Novell Client install files from a 
Web server IP address and launches the Novell Client install. 
NOTE: To install Novell Client on a workstation, the logged-in user must be an administrator on the 
workstation. Users without administrator rights to the workstation cannot install new software.

1 From the root of the Novell Clients Software CD or from the Novell Client download, copy 
the winnt and win95 directories to the HTTP Web server. 

You can copy the files to up to five different Web servers in order to provide access during 
peak times. 
IMPORTANT: Ensure that you preserve the case, date, and time of the directories and files that are 
copied to the Web server. This is especially important on Web servers that are case sensitive such as 
Linux servers.

2 Run the writeip.exe utility from the Novell Clients Software CD or the download in the 
winnt\i386\admin or win95\ibm_language\admin directory.

For more information on downloading Novell Client, see “Downloading the Latest Client 
Software” on page 15.

3 Specify the IP address or DNS name of the Web server and the path to the client files. 

You can specify up to five locations. Each location is checked in the order in which they are 
listed until a connection is made. If you select Choose IP Address at Random, the order in 
which the locations are checked is selected randomly. This balances the load on the Web 
server. 

For example:

http://111.111.11.1/client

or

http://mycompany.com/client
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4 Specify download options, such as the location for downloading the client installation files.

Files can be downloaded to a temporary or specific directory.

If you select Allow User to Change the Download Directory, the user is prompted for the 
location of the download directory and can change the default location. 

If you do not select Delete Install Files after Install Is Compete, the Novell Client installation 
files remain on the workstation in the specified path or temporary directory.

5 Specify client install options.

If you select the Support Pack Install option, only the Support Pack software is downloaded 
and installed if needed.

If you select Automatic Client Upgrade, the client install runs only if the client software is a 
later version than the one currently installed on the workstation.

You can also specify an unattend client configuration file. The installation reads the 
configuration file in order to configure the client properties. This file provides information 
such as the most recent version number and where to copy drivers during installation. This file 
must be placed in the same folder as the installation utility. For more information on creating 
a configuration file, see “Creating or Updating the Platform-Specific Configuration Files” on 
page 22.

6 Click OK.

Setupip.exe is created. Writeip.ini, which stores the options you selected in writeip.exe, is also 
created.

7 Distribute setupip.exe by placing it on a Web site, sending it through e-mail, or distributing it 
on a diskette. 

When users double-click setupip.exe, the executable downloads the client install files from 
the specified IP address and launches the Novell Client installation.

Upgrading the Novell Client Using Novell Client Update Agent
You can simplify future client software upgrades by enabling the Novell Client Update Agent. The 
Update Agent can be run manually at any time from the N menu or can be run automatically when 
users log in to the network. 

If it is run automatically, the Update Agent determines if the preconfigured number of days have 
elapsed since the last upgrade check and then checks the specified location for a newer version of 
the client. If a newer version is found, the new install is launched. You can preconfigure the 
interval of days as well as the location of the newer client version.

1 Create a platform-specific configuration file using the Novell Client Install Manager utility. 

See “Creating or Updating the Platform-Specific Configuration Files” on page 22.

2 After you create this file, click Client and then click the Update Agent tab.

3 Check the Enable Automatic Update Agent check box. 

4 Set the launch interval, update source location, and whether an unattend file will be used 
during the update.

5 (Conditional) If you want the update to be launched without prompting the user, check the 
Suppress Update Prompt check box.
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6 (Conditional) If you want the Update Agent to check for a client software update and a 
Support Pack, check the Support Pack Update check box.

7 (Conditional) If the user does not have administrator rights on the workstation, check the 
Administrator Rights check box.

Novell Client must be installed by a user that has administrator rights to the workstation. If 
this box is checked, Update Agent runs as a user with administrator rights and the installation 
is completed. If this box is not checked and the user does not have administrator rights, the 
Update Agent does not run and the user is prompted that he does not have the correct rights. 

8 To save the file in the correct location, complete the steps in “Creating or Updating the 
Platform-Specific Configuration Files” on page 22.

9 (Conditional) Modify the cuagent.ini file located in the admin directory to customize the 
Update Agent.

The cuagent.ini file enables you to set the following settings: 

Option Description Settings

[AgentStatus] Specifies whether the Update Agent is enabled. If enabled, the rest of the 
.ini file is read. If disabled, the Agent does not look for an update to the 
Client

Disabled=Yes | No  
(Default: No)

[LaunchUpdate] Specifies whether the Client Install will be launched and whether the 
users will be prompted before the Client Install is launched. If 
SuppressUpdatePrompt is set to Yes and the Update Agent determines 
that an update is needed, the Client Install is launched automatically.

Launch=Yes | No  
(Default: Yes)

SuppressUpdatePrompt= 
Yes | No

(Default: No)

[Redirection] Specifies a path to redirect the Update Agent to a different location for 
Novell Client files. This is useful if you need to locate the files on a 
different server. 

The path can be a mapped drive, UNC path, or DNS name.

You can redirect the Update Agent five times (once in each of five 
different cuagent.ini files located in different locations).

Location=path_to_update
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[AgentSettings] Specifies settings located on the Novell Client Update Agent Property 
Page. If you change settings in the cuagent.ini file, these changes are 
made in the Registry and appear in the Novell Client Update Agent 
Property Page. These changes go into effect the next time the Update 
Agent is run.

Update specifies whether the settings are transferred from the .ini file to 
the workstation's registry.

Enable Automatic Update Agent specifies whether the Update Agent is 
launched automatically. The Update Agent checks for a new version of 
the Novell Client at the designated interval and from the designated 
locations. The Update Agent is launched as a part of the login process.

Update Agent Launch Interval sets the interval (in days) that the Novell 
Client Update Agent checks for a new version of the Novell Client.

Enable Update Location specifies whether the Novell Client Update 
Agent looks for a new version of the Novell Client in the designated 
update location.

The Update Agent checks for updates in the following order of enabled 
locations: 1) Update Location, 2) Previous Install Location.

The Update Agent looks in each enabled location for valid file types and 
stops when it locates valid file types. Ensure that you have the latest files 
in the first location that the Update Agent searches.

Update Location specifies the update location.

Enable Previous Install Location specifies whether the Novell Client 
Update Agent looks for a new version of the Novell Client in the previous 
install location.

Unattend File specifies the name of the unattend file that the Update 
Agent uses to determine if the Novell Client should be updated. The 
unattend file must be located in the Update Location or the Previous 
Install Location if either is enabled.

Suppress Update Prompt specifies whether the user is prompted before 
the Client Install is launched.

Update=Yes | No  
(Default: No)

EnableAutomaticUpdateAge
nt=Yes | No 

UpdateAgentLaunchInterval
=interval_in_days

EnableUpdateLocation=Yes | 
No

UpdateLocation=update_loc
ation_path

EnablePreviousInstallLocatio
n=Yes | No

UnattendFile=log_file_path

SuppressUpdatePrompt=Ye
s | No

[AgentSettings] 
(continued)

Support Pack Update specifies whether Novell Client Update Agent 
looks for a Novell Client Support Pack in the designated update locations. 
If this is enabled, the Update Agent looks in each enabled location for 
valid file types and stops when it locates valid file types. Ensure that you 
have the latest files in the first location that the Update Agent searches.

Administrator Rights specifies whether the Novell Client Update Agent 
has administrator rights on the workstation. The Update Agent must have 
administrator rights to update the Novell Client. This is useful when the 
user who logs in to the workstation is not the workstation Administrator 
user. If this setting is set to No, the Update Agent is launched with the 
rights of the currently logged-in user.

SupportPackUpdate=Yes | 
No

AdministratorRights=Yes | 
No

[StatusLogging] Specifies whether a status log is created and where it is located. Use=Yes | No  
(Default: Yes)

File=log_file_path

[AdministratorMes
sage]

Specifies additional text that appears when the user is prompted to start 
an update.

Message=the_message_you 
want_to_appear

Option Description Settings
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10 Copy these files to the platform-specific install directories (i386 directory for Windows NT/
2000/XP or ibm_enu directory for Windows 95/98).

11 Distribute the Novell Client.

After these steps are completed and you have distributed this client configuration with the Novell 
Client installation, you can use the Novell Client Update Agent to automatically update Novell 
Client software the next time you need to update. You must first enable and distribute this client 
configuration before you can take advantage of its power.

Installing Service Packs
There are two new methods of installing Support Packs on a workstation: the Client Update Agent 
and the Web download utility. The Support Pack installs only a subset of Client files and does not 
require a version change for the Client. Support Packs can also be added to the Client (in an overlay 
manner) to allow the install of both the Client and the Support Pack in one step. Depending on the 
utility you use to deploy Service Packs, the process differs slightly.

Using Novell Client Update Agent: If you check the Support Pack Update check box on the 
Update Agent property page, the Update Agent determines if the entire Novell Client needs 
to be updated. If so, it launches the Novell Client install. If not, the Update Agent determines 
if a Support Pack needs to be updated. If so, it launches the Support Pack install. If not, it 
finishes without updating the Novell Client or the Support Pack.

Using the Web Download Utility: If you check the Support Pack Install check box when 
running the WriteIP utility (see “Installing Novell Clients from a Web Server” on page 25), 
the Web download utility (setupip.exe) does not download or install Novell Client, but rather 
attempts to download and install only the Support Pack. The IP address specified in the 
WriteIP utility must be a location on a Web server that contains the Support Pack files. If the 
IP address specified in the WriteIP utility is a location on a Web server that contains both the 
Client and the Support Pack files (in an overlay), the Web download utility downloads both 
the Client and Support Pack files but then launches only the Support Pack install. To avoid 
this unnecessary download of Client files, the administrator must create a directory called sp 
on the Web server that is contained within the winnt\i386 or win95\ibm_language directory 
and place the Support Pack files in that sp directory. The Web download utility downloads 
only the files in the sp directory and launches the Support Pack install.

Uninstalling Network Components during an Upgrade
If you are planning to upgrade to the next version of the Novell Client for Windows and you 
currently have one or more optional components installed that you would like to have uninstalled, 
you can accomplish both tasks at the same time. For example, if you currently have Novell 
Distributed Print ServicesTM installed on a workstation and you want to uninstall it so that you can 
later install Novell iPrint, you can perform the uninstall of Novell Distributed Print Services while 
you are installing the next version of the Novell Client for Windows.

1 Create an unattend file using nciman.exe. 

See “Creating or Updating the Platform-Specific Configuration Files” on page 22.

2 In the Installation group, select the components you want to remove. 

3 On the component's property page, check both the Install This Component and Remove This 
Component check boxes for each component you want uninstalled. 
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If you check only Remove This Component without checking Install this Component, the 
component will not be removed during the install.

4 Save the unattend file and then run the Client setup utility (setupnw.exe or setup.exe) with the 
/u parameter specifying the name of the unattend file. 

See “Using Setup Parameters with the Novell Client Installation” on page 17.

The client software is installed and the unwanted components are removed.

Upgrading a Client Workstation to Windows 2000
You can upgrade a Windows 95/98 or Windows NT 4.0 workstation with Novell Client software 
to Windows 2000 without uninstalling the client software.
NOTE: IPX Compatibility and Novell NetWare/IP Adapter will not be upgraded from Windows NT to Windows 
2000. 

Some Windows NT 4.0 printer drivers are incompatible with Windows 2000 and will not install. Contact 
Microsoft for more information.

Windows 95/98 to Windows 2000: Installs Novell Client version 4.51 from the Windows 2000 
CD.

Windows NT to Windows 2000: Detects the version of Novell Client software installed and does 
one of the following:

If the Novell Client version is 4.6 or earlier, Windows 2000 installs the Novell Client version 
4.51 from the Windows 2000 CD.

If the Novell Client version is 4.7 or later, Windows 2000 leaves it intact but removes all 
installed components and changes the protocol selection.

After the migration to Windows 2000 is complete, Novell Client reinstalls the previously installed 
components and restores the previously selected protocols.
IMPORTANT: In order to complete the reinstallation of the components and protocols, the user who logs in 
to the workstation after the migration must have administrator rights.

Novell Client version 4.51 on the Windows 2000 CD has limited functionality. Therefore, you will 
want to upgrade to the latest Novell Client version after you have completed the upgrade. You can 
either access the latest client software from a product CD or download it from www.novell.com/
download. After you have set up the Automatic Client Upgrade (see “Installing Clients from the 
Network” on page 20), Novell Client runs an ACU from one of the following places:

The path pointed to by the NWCLIENTDIR environment variable in the login script or at the 
command line

The path were Novell Client was installed from

Drive Z: on the network

You can choose to skip the Automatic Client Upgrade by setting the NWCLIENTDIR 
environment variable to NULL in the login script.

For more information on Automatic Client Upgrade, see “Installing Clients from the Network” on 
page 20.

For more information on installing Novell Client on individual workstations, see “Installing 
Novell Client on a Workstation” on page 16.
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Upgrading a Client Workstation to Windows XP
If you are upgrading your Windows operating system on workstations that already have the Novell 
Client installed, you must first uninstall the Novell Client to ensure a clean upgrade.

1 Uninstall Novell Client.

See “Uninstalling Novell Client” on page 53.

2 Upgrade the Windows operating system to Windows XP.

3 Install Novell Client for Windows XP.

See “Installing Novell Client on a Workstation” on page 16.

Novell Client cannot be installed on Windows XP if the Local Area Connection Properties 
Page is open. Close this page before running the Novell Client install.
TIP: On Windows XP, you can install the client software from the network on workstations running the 
Microsoft Client Service for NetWare. Run the install by logging in to the server using bindery emulation.
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3 Setting Up Client Login

You can customize the client login environment to suit your network and have greater control over 
what users can access during login. See the following:

“Setting Up Login Scripts” on page 33

“Setting Up Login Restrictions” on page 33

“Setting Up Location Profiles” on page 34

“Customizing the Novell Login Dialog Box” on page 35

“Logging In to the Network” on page 37

“Logging Out of the Network” on page 37

“Setting Up Passwords in Windows NT/2000/XP” on page 37

“Setting Up LDAP Contextless Login and LDAP Treeless Login” on page 38

Setting Up Login Scripts
When a user successfully logs in to the network, one or more login scripts are executed which 
automatically set up the workstation environment. Login scripts are similar to batch files and are 
executed by the Novell® LOGIN utility. You can use login scripts to map drives and search drives 
to directories, display messages, set environment variables, and execute programs or menus.

For more information on setting up login scripts, see the Novell Login Scripts Guide.

Setting Up Login Restrictions
Login restrictions are limitations on user accounts that control access to the network. These 
restrictions can be set in Novell iManager or ConsoleOne® for each user and include the following:

Requiring a password (you can specify its minimum length, whether it must be changed and 
how often, whether it must be unique, and whether the user can change it)

Setting the number of logins with expired password and the number of incorrect login 
attempts allowed

Setting account limits such as an account balance or expiration date

Limiting disk space for each user by specifying the maximum blocks available for each user 
on a volume

Specifying the number of simultaneous connections a user can have

Specifying (by node address) which workstations users can log in on

Restricting the times when users can log in (you can assign all users the same hours, or you 
can restrict users individually)
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When a user violates login restrictions by entering an incorrect password or the exceeding the 
number of logins with an expired password, the account is disabled and no one can log in using 
that username. This prevents unauthorized users from logging in.

Setting Up Location Profiles
Location profiles allow you to save the information from a user’s specific login into a location 
profile. When the user selects this profile during login, the profile automatically sets up login 
information such as the user’s name, server, tree, context, login script, and other applicable 
information so that the user does not have to type this information.

Location profiles are especially powerful for users who log in from multiple places. Users can have 
separate profiles for the office, home, laptop, or any other workstation they use. This simplifies the 
login process so that users do not have to remember their login information for each workstation. 
Using multiple location profiles also gives you control over what users can access from each 
workstation.

You can create a location profile on a single workstation or you can create location profiles for 
multiple workstations by using the ZENworks® Workstation Configuration policy packages.
TIP: To create and then distribute location profiles that will be used by multiple workstations, use the Novell 
ClientTM Configuration policy created in the Workstation Configuration policy package in ConsoleOne. 

For more information on using ZENworks for Desktops policy packages, see the ZENworks for Desktops 
documentation. If you have questions while setting up a policy package, click Help.

To create a location profile on a specific workstation:

1 Open the Client property pages by doing one of the following:

Right-click the N icon in the system tray, then click Novell Client Properties > Location 
Profiles.

Right-click Network Neighborhood, then click Properties > Location Profiles.

2 Type the name of the profile that you want to add, then click Add.

3 From the Service menu, select one of the following:

Login Service to configure login settings

Connection Service to configure your dial-up connection settings

4 From the Service Instance menu, do one of the following:

Select an existing service instance

Type a name for a new service instance and then click Add to specify the settings for this 
service in the Novell Client Login window or Connection Services window.

5 When you have finished creating the location profile, click OK.

TIP: When storing the profile through an eDirectoryTM login, you can use a File System Pointer. This allows 
multiple users to use the same profile, provided they all use the same path as the file system pointer.

IMPORTANT: The server volume must support long filenames. In versions of NetWare earlier than NetWare 
4.11, the OS/2 name space was required for long filename support. In NetWare 4.11 and NetWare 5 or later, 
the long.nam name space is required on the server.
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Removing a Location Profile
You might need to remove a location profile once it has been created. If you are removing a 
location profile created on an individual workstation, complete the procedure below. If you want 
to remove a location profile created in a Client Configuration policy, you can either delete the 
Client Configuration policy or change the associations of specific users with this policy.

1 Right-click the N icon in the system tray, then click Novell Client Properties > Location 
Profiles to open the Novell Client property pages.

2 Select the name of the profile that you want to remove, then click Remove.

Customizing the Novell Login Dialog Box
The Novell Login dialog box can be customized to show the features that you want users to have 
access to. Customizing gives you control over the following:

Initial Novell login

This disables the Novell login window when the workstation is started. Users must then log 
in using the N menu or Start menu.

NMAS authentication

NMASTM authentication adds additional security to the network. However, if your network 
does not use NMAS, login might take additional time and you might want to disable NMAS 
authentication. For more information on disabling NMAS, see ““Disabling and Uninstalling 
the NMAS Client”” and ““Disabling NMAS on the Server”” in the Novell Modular 
Authentication Services (NMAS) 2.2 Administration Guide.
IMPORTANT: In NCIMAN, you can control both the installation and use of NMAS. In the Installation > 
Setup tab, there is an Install NICI and NMAS check box. If you uncheck this box when you create an 
unattend file that is used to install multiple clients on your network, NICI and NMAS will not be installed. 
In the Client > Advanced Login tab, there is an NMAS Authentication check box. If you uncheck this box, 
Novell Client will not use NMAS during authentication even if the component is installed. If the component 
is not installed and this box is checked, Novell Client login skips the NMAS authentication and 
authentication continues.

OEM extended ASCII password

To enable the use of the OEM extended ASCII characters in passwords, check this box. You 
should use OEM extended ASCII characters only if you have legacy software that requires 
you to use the OEM Code Page. 

The latest versions of Novell Client support extended ASCII characters using the UNICODE 
code page and do not need this setting to be enabled in order to handle special characters such 
as Ñ, or €.

Default  policy support

After the user logs in to the network, the authentication server's \sys\public\winnt directory is 
searched for ntconfig.pol file. If the file is found, the policy is applied to the user and 
workstation.

Novell Login dialog box customization

This dialog box can be customized to control the availability of certain login options. This 
gives you control over how users log in.

Location list at the top of the dialog box
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Hiding the Location field is especially useful if you have set up only one location profile 
for a workstation. In this case, the Location field is not useful and might confuse or 
distract users.

Advanced button

If you have set up several location profiles and do not want users to change the data in 
various login fields (such as Tree, Context, Server, and Run Scripts), you can hide the 
Advanced button.

Variables button on the Script tab

If you use %2, %3, %4, or %5 in the login script, you might want to set these values in 
the location profile but not allow users to change them. In this case, it might be helpful to 
hide the Variables button.

Clear Connections check box

If you want all connections to be cleared every time users log in, or if you don’t want any 
connections to be cleared, you can set the value in the location profile and then hide the 
Clear Connections check box.
NOTE: The Clear Connections check box is never visible during initial login, because an initial login 
automatically clears all connections.

Workstation Only check box

If you do not want to allow workstation-only logins—for example, if you want to require 
that the user log in to NetWare in order to use their workstations—you can hide the 
Workstation Only check box that appears under the Password field during an.initial NT/
2000 login.

Suppress Singles Sign-on for This Login check box

This check box lets you disable the single sign-on process for the current login attempt.

Tree field

If the Novell Login dialog box is being used to log in to a specific tree, disable the Tree 
field to prevent users from changing the tree.

Tree button

If the Novell Login dialog box is being used to log in to a specific tree, disable the Tree 
button to prevent the user from changing the tree.

Context field

If the Novell Login dialog box is being used to log in to a specific tree, disable the Context 
field is disabled to prevent users from changing the context.

Context button

If the Novell Login dialog box is being used to log in to a specific tree, disable the Context 
button to prevent users from changing the context.

Force Logoff button

Force Logoff lets you terminate the previously logged-in user's Novell Client session 
even if he locked the workstation. 
WARNING: Any unsaved work that the previous user had open will be lost. To maintain open 
applications and current network connections, log in using the previously logged-in username and 
password. 

Welcome screen
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You can customize the Welcome screen with a custom bitmap and caption. 
TIP: You can also customize the Novell Login dialog box for multiple workstations using the Novell Client 
Configuration policy created in the Workstation Configuration policy package in ConsoleOne (ZENworks for 
Desktops 3) or NetWare Administrator (ZENworks for Desktops 2).

For more information on using ZENworks for Desktops policy packages, see the ZENworks for Desktops online 
documentation. If you have questions while setting up a policy package, click Help.

To show or hide any Login dialog box options:

1 Right-click the N icon in the system tray, then click Novell Client Properties > Location 
Profiles to open the Novell Client property pages.

2 Click Advanced Login.

3 In the Show On Login section of the Advanced Login property page, check the check boxes 
for the items that you want to appear and uncheck those that you do not want to appear.

4 Click OK.

Logging In to the Network
IMPORTANT: We recommend that you do not use the command line LOGIN utility.

There are several ways to initiate a Novell Client login after users have already logged in to 
NetWare or to the local workstation:

Right-click the N icon in the system tray, then click NetWare Login. 

Right-click Network Neighborhood, then click NetWare Login.

Click Start > Programs > Novell (Common) > Novell Login.

In Network Neighborhood, double-click the desired tree or server and the Novell Login will 
load automatically.

In Network Neighborhood, right-click the desired tree or server and then click either 
Authenticate or Login.

Run loginw32.exe from the DOS command prompt.

Logging Out of the Network
To log in to new NetWare services while logging out of other servers or clearing the current 
connections, use the NetWare Client Login and check the Clear Current Connections check box.

If you want to log out of both the Windows NT/2000 workstation and NetWare, press 
Ctrl+Alt+Del and then click Logout.

To log out of a specific server, right-click Network Neighborhood, click NetWare Connections, 
select the server or tree, and then click Detach. Or, right-click the N menu, click NetWare 
Connections, select the server or tree, and then click Detach.

Setting Up Passwords in Windows NT/2000/XP
We recommend that you configure NT workstations to not use any of the Microsoft password 
restrictions available in User Manager. Novell Client for Windows NT works best if password 
restrictions are set in eDirectory.
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Setting Up LDAP Contextless Login and LDAP Treeless Login
Several large Novell customers have used LDAP Contextless Login to facilitate the merging of 
several trees in to one global tree. Before LDAP Contextless Login, users were often plagued by 
having to change their context information in the login screen when changes took place in the tree 
structure. This resulted in IT costs to manage and support the change. 

LDAP Contextless Login makes it easier for users to work in the new global tree because it makes 
it unnecessary for the users to manage or know about changes to their organization’s name or its 
placement in the hierarchy. Because users no longer need to enter their context to authenticate, the 
context can be changed on the back end as many times as necessary without the users having to 
know and without the costs associated with managing and supporting these changes. 

The Lightweight Directory Access Protocol (LDAP) is an Internet communications protocol that 
lets client applications access directory information. It is based on the X.500 Directory Access 
Protocol (DAP) but is less complex than a traditional client and can be used with any other 
directory service that follows the X.500 standard. Lightweight Directory Access Protocol (LDAP) 
Services for Novell eDirectory is a server application that lets LDAP clients access information 
stored in eDirectory. 

If your network has LDAP Services for Novell eDirectory set up on your eDirectory tree and you 
are running Novell eDirectory 8.5 or later, users who are logging in to the network from Windows 
NT/200/XP can log in to the network without having to enter their context in the Novell Login 
screen. To log in, users only need to know their username, password, and the name of the tree that 
is running LDAP Services. Optionally, you can also have users log in to the network without 
having to enter the eDirectory tree name. 

User objects can be located in the tree by username or e-mail address. You can also enable wildcard 
searches. If wildcard searches bring up multiple usernames, the user is prompted to select his 
username. 

Generally, when a user connects to the network using LDAP, the connection is made through an 
LDAP client. Now, the Novell Client Login acts as an LDAP client and connects to the network. 
All LDAP clients bind (connect) to Novell eDirectory as one of the following types of users:

[Public] User (Anonymous Bind) 

Proxy User (Proxy User Anonymous Bind)

NDS or eDirectory User (NDS User Bind)
NOTE: The NDS User Bind is not used by LDAP Contextless Login. 

The type of bind and the rights assigned to the corresponding User object determine the content 
that the LDAP client can access. LDAP clients access a directory by building a request and sending 
it to the directory. When an LDAP client sends a request through LDAP Services for eDirectory, 
eDirectory completes the request for only those attributes that the LDAP client has the appropriate 
access rights to. There are additional restrictions that can be set to further secure connections.

This documentation assumes that you are familiar with LDAP. It contains links to information 
about LDAP and eDirectory; it is not meant to replace or supersede the documentation about 
LDAP running on eDirectory. If you are unfamiliar with LDAP, you should familiarize yourself 
with LDAP and how it operates in your network. 

For more information on LDAP for Novell eDirectory, see ““Understanding How LDAP Works 
with eDirectory” in the Novell eDirectory 8.7 Administration Guide.
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Before users can log in to the network without their context or tree information, you must complete 
the following tasks:

1. Set up Novell LDAP Services for eDirectory. 

See “Setting Up Novell LDAP Services for eDirectory” on page 39.

2. Do one of the following:

If you are installing Novell Client software on a few workstations, install the software and 
then configure the Novell Client property pages so that the LDAP port number and SSL 
settings in the client properties match the settings on your LDAP server. See “Setting Up 
LDAP Contextless Login on One Workstation” on page 42.

If you are installing Novell Client software on multiple workstations, preconfigure the 
LDAP contextless login property pages prior to installing the client software so that the 
LDAP port number and SSL settings in the client properties match the settings on your 
LDAP server (see “Setting Up LDAP Contextless Login on Multiple Workstations” on 
page 44). Then install the Client software.

3. Inform users about contextless login. 

See “Logging In Using LDAP Contextless Login” on page 44.

If you experience problems with LDAP Contextless Login, check the Server and Group object 
configurations. Most problems occur in the access rights given to the Proxy User. You can use any 
LDAP browser available from the Internet to check the access rights. Browse to the user and verify 
that you can read the inetOrgPerson property and other properties you are searching for, such as 
CN and MAIL. If these cannot be seen through the LDAP browser by logging in anonymously, 
contextless login cannot perform the proper searches to resolve the User object’s context in the 
tree. 

Setting Up Novell LDAP Services for eDirectory
Before users can take advantage of LDAP Contextless Login, the network must be running Novell 
LDAP Services for eDirectory 8.5 or later and you must have completed the following steps: 

1 Install and configure the LDAP Services for eDirectory on the LDAP server. 

See ““Understanding LDAP Services for Novell eDirectory”” and ““Configuring LDAP 
Services for Novell eDirectory”” in the Novell eDirectory 8.7 Administration Guide.

2 Do one of the following:

Grant the Read right to the Public Object.

See “Connecting As a [Public] User” on page 39.

Create a Proxy User Object that has the correct rights.

See “Connecting As a Proxy User” on page 40.

Connecting As a [Public] User

An anonymous bind is a connection that does not contain a username or password. If an LDAP 
client without a name and password binds to LDAP Services for eDirectory and the service is not 
configured to use a Proxy User, the user is authenticated to eDirectory as user [Public].

User [Public] is a nonauthenticated eDirectory user. By default, user [Public] is assigned the 
Browse right to the objects in the eDirectory tree. The default Browse right for user [Public] allows 
users to browse eDirectory objects but blocks user access to the majority of object attributes.
Setting Up Client Login 39



    Novell Confidential                                                                                            Manual (99a)  14 April 2004
The default [Public] rights are typically too limited for most LDAP clients. Although you can 
change the [Public] rights, changing them will give these rights to all users. Because of this, we 
recommend that you use the Proxy User Anonymous Bind. For more information, see “Connecting 
As a Proxy User” on page 40. 

To give user [Public] access to object attributes, you must do the following in iManager or 
ConsoleOne:

1 Make user [Public] a trustee of the appropriate container or containers.

2 Grant the Read right to user [Public]. 

Without the Read right, user [Public] will not be able to search containers for the User object 
information. 

You can grant the Read right to the specific attributes that LDAP Contextless Login will 
search for User objects or you can grant rights to all attributes. For example, you can grant 
rights only to the e-mail address or telephone number. When LDAP Contextless Login 
searches the tree as user [Public], it will search only these attributes.

Connecting As a Proxy User

A proxy user anonymous bind is an anonymous connection linked to an eDirectory username. If 
an LDAP client binds to LDAP for eDirectory anonymously, and the protocol is configured to use 
a Proxy User, the user is authenticated to eDirectory as the Proxy User. The name is then 
configured in both LDAP Services for eDirectory and in eDirectory. 

The key concepts of proxy user anonymous binds are as follows:

All LDAP client access through anonymous binds is assigned through the Proxy User object.

The Proxy User must have a null password and must not have any password restrictions (such 
as password change intervals). Do not force the password to expire or allow the Proxy User 
to change passwords.

You can limit the locations that the Proxy User can log in from by setting address restrictions 
for the Proxy User object.

The Proxy User object must be created in eDirectory and assigned rights to the eDirectory 
objects you want to publish. The default user rights provide Read access to a limited set of 
objects and attributes. Assign the Proxy User Read and Search rights to all objects and 
attributes in each subtree where access is needed.

The Proxy User object must be enabled on the General page of the LDAP Group object that 
configures LDAP Services for eDirectory. Because of this, there is only one Proxy User object 
for all servers in an LDAP group.

You can grant a Proxy User object rights to All Properties (default) or Selected Properties. In 
order for contextless login or treeless login to work, the Read right must be granted so that 
LDAP can search the container or tree for the User object. Typically, you assign the Proxy user 
rights to the Root of the tree so that LDAP can view the attributes of the User objects 
throughout the tree. However, you might want to restrict access by assigning Read rights only 
to individual Organizational Units that you want LDAP to search. 

For more information, see ““Configuring LDAP Objects” in the Novell eDirectory 8.7 
Administration Guide.
NOTE: LDAP Contextless Login requires clear text passwords to be enabled for LDAP. This does not affect 
the eDirectory password required during Login. They remain encrypted.
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To give the Proxy User rights to only selected properties on eDirectory 8.7 or later, complete the 
following steps.
NOTE: LDAP Contextless Login works with eDirectory 8.5 or later. However, these steps apply specifically to 
eDirectory 8.7. If you are using a compatible version other than eDirectory 8.7, check the documentation that 
corresponds to your version for steps. 

In ConsoleOne

1 Right-click the top container that the Proxy User will have rights over, then click Trustees of 
This Object > Add Trustee.

2 Browse to the Proxy User, then click OK.

3 Deselect the following:

The Browse right for the Entry Rights property

The Read and Compare rights for the All Attributes Rights property

4 Click Add Property, then check the Show All Properties check box.

5 Select an inheritable right for the Proxy User, such as mailstop (in the lowercase section of the 
list) or Title, then click OK.

To add additional inheritable rights, repeat Step 4 and Step 5.

6 Click OK > Apply > Close.

In Novell iManager

1 Click the Roles and Tasks button.

2 Click Rights Management > Modify Trustees.

3 Enter the top container the Proxy User has rights over or click the browse button to browse to 
the container in question, then click OK.

4 On the Modify Trustees screen, click Add Trustee.

5 On the Contents screen, browse to and click the Proxy User’s object.

On the same screen, you will notice that the Proxy User’s object appears in the Selected 
Objects area near the bottom.

6 Click OK.

7 On the Modify Trustees screen, click Assigned Rights for the Proxy User. 

8 Check the All Attributes Rights and Entry Rights check boxes, then click Delete Property.

9 Click Add Property, then check the Show All Properties in Schema check box.

10 Select an inheritable right for the Proxy User, such as mailstop (in the lowercase section of the 
list) or Title, then click OK.

To add additional inheritable rights, repeat Step 9 and Step 10.

11 Click Done.

To implement proxy user anonymous binds on eDirectory 8.7 or later, you must create the Proxy 
User object in eDirectory and assign the appropriate rights to that user. Assign the Proxy User Read 
and Browse rights to all objects and attributes in each subtree where access is needed. You also 
need to enable the Proxy User in LDAP Services for eDirectory by specifying the same proxy 
username. 
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In ConsoleOne

1 Right-click the LDAP Group object.

2 Click Properties > General.

3 Type the name of an eDirectory User object in the Proxy Username field.

In Novell iManager

1 Click the Roles and Tasks button.

2 Click LDAP Management > LDAP Overview.

3 On the LDAP Overview screen, click the name of an LDAP Group object to configure.

4 In the Authentication Options area, type the name and context of an eDirectory User object in 
the Proxy User field.

5 Click Apply > OK.

Setting Up LDAP Contextless Login on One Workstation
After you have set up the LDAP Group object and assigned the correct rights to the User object 
that is associated with the proxy username, you need to set up LDAP Contextless Login on the 
workstations. 

If you will be installing on a few workstations, complete these steps. If you will be installing on 
several workstations, see “Setting Up LDAP Contextless Login on Multiple Workstations” on 
page 44.

1 At the user’s workstation, right-click the N icon in the system tray and then click Novell Client 
Properties.

2 Click the LDAP Contextless Login tab.

Description: LDAP Contextless Login Property Page
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3 Do one of the following: 

To enable treeless login, check Enable Treeless Login. Enable Contextless Login is 
automatically checked for you because you must set up contextless login to enable 
treeless login.

To enable only LDAP contextless login, check the Enable LDAP Contextless Login 
check box. 

4 In the Trees field, specify the name of an eDirectory tree running LDAP services and then 
click Add.

5 In the Servers field, specify the IP address or DNS names of the server running LDAP services 
and then click Add.

Order is important for speed and efficiency because servers will be queried for their tree until 
one is found that matches the tree specified by the user.

6 (Conditional) If this is the first time this server has been added to the list, check the server 
properties on the LDAP Server Properties page that appears to make sure that the timeout 
settings and data encryption settings are correct. 

If you are using Secure Socket Layer (SSL) to establish a secure connection, you must specify 
the path and name of the certificate on the workstation. You should also check to make sure 
that the correct port number is specified. 

7 (Conditional) If there are additional servers running LDAP, repeat Step 5 and Step 6.

8 (Optional) Start searching for users in a certain context.

8a Check the Enable Context Search Scope check box.
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8b Select the tree, then click Properties.

8c Do one of the following: 

To enable a search in the specified context and any containers in that context, select 
Search Context and Subtree.

To enable a search in the specified context only, select Search Context Only.

8d  Type the distinguished context delimited by commas (standard LDAP format), then click 
Add.

For example: OU=TOKYO,O=DIGITALAIRLINE
TIP: The LDAP property page does not ensure that this context is correct. If users have problems 
logging in, check that you typed this information correctly.

8e (Optional) Add multiple contexts to be searched by repeating Step 8d for each context.

The servers and contexts are searched in order. You can set the order they are searched by 
selecting a server or context and then clicking Up or Down to move its position in the 
search list.

9 Click OK.

10 (Optional) Specify additional eDirectory trees to use by repeating Step 4 through Step 9 for 
each tree.

11 (Optional) Set the optional search and display parameters that LDAP Contextless login uses 
to search the eDirectory tree for users by clicking Settings. 

For example, because users do not need to specify their context, you might want to disable the 
Display Context parameter so that the context will not be displayed during login. 

12 Click OK to affect the changes and close the property page.

Setting Up LDAP Contextless Login on Multiple Workstations
As with all property page settings, you can set these properties for multiple workstations before 
and after installation. For more information, see “Setting Properties before Installation” on 
page 45 and “Setting Properties on Multiple Workstations after Installation” on page 46.

Logging In Using LDAP Contextless Login
When users log in to the network using LDAP Contextless Login, they must specify the necessary 
information based on the options you specified in the LDAP Contextless Login Settings Protocol 
page, the password, and the name of the tree running LDAP Services for eDirectory. The context 
information is added automatically to the Novell Login window when the username is found.

If you selected to allow wildcard searches, users can perform a wildcard search and the LDAP 
database will list all possible users that meet the wildcard search criteria.
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4 Setting Client Properties

You can optimize Novell® ClientTM for your network by using property pages to configure 
installation options and protocol support, optimize performance, configure optional client 
parameters, and set a variety of other parameters.

By default, the client is configured for high speed with moderate use of memory and data 
protection. You can adjust the client to optimize its performance in any of these areas. However, 
optimizing the client in one area might lessen performance in other areas.

The Advanced Menu Settings tab lets you set menu options and control settings such as the ability 
to send messages to the server console or how Network Neighborhood is configured. A short 
description of each setting is available in the Description field when you select the option. 
Additional information on the Advanced Settings is available in an April 1999 AppNotes® article 
(http://developer.novell.com/research/appnotes/1999/april/03/index.htm).

You can set properties for a single workstation, or you can set them for multiple workstations 
simultaneously.

Setting Properties before Installation
Use Novell Client Install Manager to set properties for one or more workstations before an 
unattended install. This method saves you from having to set each workstation individually.

1 Start the Novell Client Install Manager.

Windows NT/2000/XP: Novell Client Install Manager is located in the 
winnt\i386\admin folder that you copied to the server.

Windows 95/98: Novell Client Install Manager is located in the win95\ibm_language 
\admin folder.

2 Click File > New File > your_operating_system.

3 Modify the installation options as needed.

3a Double-click the configuration option that you want to modify in the Installation options 
list box.

3b In the property pages, set the parameters and then click OK.

The values that you set appear in the right list box.
TIP: You can set up one workstation the way you want other workstations to be set up, and then use 
Novell Client Install Manager to import the settings from that workstation’s registry and save them to the 
configuration file you will use during the ACU install. After you set up the workstation, click File > Open 
Registry to import the settings into Novell Client Install Manager.

For information about setting properties on a single workstation, see “Configuring Network Protocols” on 
page 18.

4 Click File > Save.
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You can save the file with any filename that you want to use. For example, you could rename 
the file novell.txt and then use it in conjunction with the ACU.

Setting Properties on a Single Workstation after Installation
1 At the user’s workstation, right-click the N icon in the system tray.

2 Click Novell Client Properties.

3 Set the properties that you want to change.

4 Click OK to make the changes and close the property pages.

Setting Properties on Multiple Workstations after Installation
Beginning with ZENworks® for Desktops 3 or later and NetWare® 5 or later, you can use 
ConsoleOne® to configure client properties for multiple workstations. The properties that you set 
in ConsoleOne or NetWare Administrator are pushed down to the client workstations at scheduled 
times or when specified events occur, such as when a user logs in.

To set the properties on multiple workstations after installation, refer to the corresponding 
ZENworks for Desktops documentation at Novell’s documentation Web site (http://
www.novell.com/documentation) for more information.

Using DHCP
If a DHCP server is set up on your network, the DHCP server can inform Novell Client of network-
specific configuration information.

You can easily configure Novell DHCP servers (NetWare 5 and later) to distribute this information 
to the clients. See the server configuration documentation for your NetWare product at Novell’s 
documentation Web site (http://www.novell.com/documentation) for more information.

Clients obtain configuration information from DHCP even when you statically configure the 
client’s IP address or even when the DHCP server used to supply the information is different from 
the DHCP server supplying an IP address to the client.

Using DHCP As an eDirectory Server Name Service Provider
You can set up a DHCP server to inform Novell Client workstations that use the IP protocol about 
an eDirectoryTM tree name and the IP addresses of servers that are on that tree. When using this 
feature, it is best to specify the IP addresses of the closest eDirectory servers containing partitions 
with the user information.

Using DHCP to Distribute SLP Configuration Information
You can configure the following SLP parameters through DHCP:

IP Address of SLP Directory Agents 

SLP Scopes
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Using DHCP to Distribute IPX Compatibility Information
You can configure the following IPXTM Compatibility parameters through DHCP:

IP Address of Migration Agents

CMD Network Number

Migration Agent List Stale Time
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5 Managing Novell Client

Managing Novell® ClientTM requires that you manage users’ network connections, passwords, 
rights, etc. All of these features are available from the Novell Client desktop.

Common Networking Tasks
Novell Client software is integrated with Windows. Features are integrated into standard Windows 
interfaces such as My Computer, Network Neighborhood, Control Panel, and the N icon in the 
system tray.

Instructions for performing common client tasks are provided under the N menu:

1 Right-click the N icon.

2 Click Novell Client Help > Novell Client User Guide.

NetWare File Security
NetWare® networks restrict access to network files and folders based on user accounts. For 
example, a user connected to the network using the Administrator account might be able to delete 
or rename a file that other users can only open and edit.

The NetWare file system keeps track of the rights that users have to files and directories on the 
network. When users try to access any file on a NetWare network, NetWare either grants access or 
prohibits certain things that users can do with the file.

Rights are granted and revoked by creating trustee assignments. For more information, see 
“Changing Trustee Assignments” on page 50.

File rights apply only to the file that they are assigned to. The rights can be inherited from the 
folder that contains the file. Folder rights apply not only to the folder but also to the files and 
folders it contains.

Checking File or Folder Rights
1 In Windows Explorer or Network Neighborhood/My Network Places, right-click the file that 

you want to check.

2 Click Properties > NetWare Rights.

3 In the Trustees box, click the user account. 

The rights to the file or folder are displayed on the right-hand side.
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Changing Trustee Assignments
You must have the Access Control right to change trustee assignments.

1 In Windows Explorer or Network Neighborhood, right-click the file that you want to check.

2 Click Properties > NetWare Rights.

3 Add trustees, remove trustees, or change the rights granted to trustees as needed.

Trustee assignments override inherited rights.

To change an Inherited Rights Filter, click the Inherited Rights and Filters button on the NetWare 
Rights property page.

Combining Multiple Trustees
As an administrator, you might need to apply the same trustee assignments to a group of selected 
files. You can combine trustee assignments by checking the Combine Multiple Trustees check box 
on the NetWare Rights page.

1 In Windows Explorer or Network Neighborhood, click a file.

2 Press and hold Control while clicking additional files.

3 Right-click the selected files.

4 Click Properties > NetWare Rights.

The Combine Multiple Trustees check box is enabled.

This check box is available only if you’re viewing the NetWare rights for multiple files or 
folders. Additionally, at least one of the files or folders must have at least one trustee 
assignment. The trustees and rights shown are the combined trustees and rights for all the files.

5 Check or uncheck the check box.

If you check Combine Multiple Trustees, the trustee assignments that are shown will apply to 
all selected files after you click OK or Apply.

6 Click OK.

For example, Kim is a trustee of file_a and file_b. Kim has Read, File Scan, and Access Control 
rights for file_a and Read and File Scan rights for file_b. If you select file_a and file_b and view 
their properties, Kim is shown as a trustee with Read, File Scan, and Access Control rights.

If you check Combine Multiple Trustees and then click OK, Kim is given the Access Control right 
for file_b. Therefore, Kim now has Read, File Scan, and Access Control rights for both file_a and 
file_b.

Setting Up AutoAdminLogon for Windows NT/2000/XP
Windows NT, Windows 2000, and Windows XP can automate the logon process by storing 
passwords and other pertinent information in the Registry database.
WARNING: There is a security risk to using the AutoAdminLogon feature. Usernames and passwords in the 
registry are visible to users. This feature also allows other users to start the computer and use the account to 
automatically logon even if the workstation is locked. Refer to the Microsoft recommendations on when to use 
AutoAdminLogon. For more information, see the following TID at Novell’s Support Web site (http://
support.novell.com/cgi-bin/search/tidfinder.cgi?10052847).

Use Registry Editor (regedit.exe) to add the needed logon information. 
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WARNING: Using Registry Editor incorrectly can cause serious, systemwide problems that might require 
reinstalling Windows NT or Windows 2000 to correct them.

TIP: To bypass the AutoAdminLogon process, and to log in as a different user, hold down the Shift key after 
a logout or after a Windows NT restart.

AutoAdminLogon Options
This section lists the options that you can choose from when setting AutoAdminLogon. To set the 
options, use the procedure in “Setting the AutoAdminLogon Options” on page 53.

Additional information on AutoAdminLogon is also available in Technical Information Document 
# 10052847 on the Novell Technical Support Web Site (http://support.novell.com.).

AutoAdminLogon for Windows Workstation Only

AutoAdminLogon for Windows Workstation and NetWare

Location profiles allow you to save a user’s specific login information. The profile automatically 
sets up login information such as the user’s name, server, tree, context, login script, and other 
applicable information so that the user does not have to type this information. For more 
information, see “Setting Up Location Profiles” on page 34.

NOTE: The NT Credential information in the Location Profile is not used. The NT user information in the 
registry is used instead.

Key: hkey_local_machine\software\microsoft\ 
windowsnt\currentversion\winlogon

Key: hkey_local_machine\software\novell\ login

AutoAdminLogon=1

DefaultDomain or Local WorkstationName=Name of 
Domain or Local Workstation

DefaultUserName=Windows User Name

DefaultPassword=Windows Password for the 
DefaultUserName specified above

AutoAdminLogon=0

Key: hkey_local_machine\software\microsoft\ 
windowsnt\currentversion\winlogon

Key: hkey_local_machine\software\novell\ login

AutoAdminLogon=1

DefaultDomain or Local WorkstationName=Name of 
Domain or Local Workstation

DefaultUserName=Windows User Name

DefaultPassword=Windows Password for the 
DefaultUserName specified above

AutoAdminLogon=1

DefaultLocationProfile=Name of the Location 
Profile that contains the information about the 
Novell User to log in to the NetWare network such 
as Username, Tree, Context, Server, etc.

DefaultPassword=Novell Password for the 
DefaultUserName specified in the Location Profile
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AutoAdminLogon for NetWare Only Using Dynamic Local User (DLU) for Windows

Location profiles allow you to save a user’s specific login information. The profile automatically 
sets up login information such as the user’s name, server, tree, context, login script, and other 
applicable information so that the user does not have to type this information. In this case, the 
location profile must specify an eDirectory user with Dynamic Local User (DLU) privileges on 
the Windows NT or Windows 2000 workstation. For more information, see “Setting Up Location 
Profiles” on page 34. 

AutoAdminLogon for Windows and Query for NetWare

AutoAdminLogon for NetWare under Terminal Server

Key: hkey_local_machine\software\microsoft\ 
windowsnt\currentversion\winlogon

Key: hkey_local_machine\software\novell\ login

AutoAdminLogon=0 AutoAdminLogon=1

DefaultLocationProfile=Name of the Location 
Profile that contains the information about the 
Novell User to log in to the NetWare network such 
as Username, Tree, Context, Server, etc.

DefaultPassword=Novell Password for the 
DefaultUserName specified in the Location Profile

Key: hkey_local_machine\software\microsoft\ 
windowsnt\currentversion\winlogon

Key: hkey_local_machine\software\novell\ login

AutoAdminLogon=1

DefaultDomain or Local WorkstationName=Name of 
Domain or Local Workstation

DefaultUserName=Windows User Name

DefaultPassword=Windows Password for the 
DefaultUserName specified above

AutoAdminLogon=0

AutoAdminQueryNDS=1

IMPORTANT: AutoAdminQueryNDS must be a 
DWORD value instead of a string value. 

Key: hkey_local_machine\software\microsoft\ 
windowsnt\currentversion\winlogon

Key: hkey_local_machine\software\novell\ login

 AutoAdminLogon=1

DefaultLocationProfile=Name of the Location 
Profile that contains the information about the 
Novell User to log in to the NetWare network such 
as Username, Tree, Context, Server, etc.

DefaultPassword=Novell Password for the 
DefaultUserName specified in the Location Profile
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Turn Off AutoAdminLogon

Setting the AutoAdminLogon Options
1 Start Registry Editor (regedit.exe).

2 Locate the specified Registry keys and set the values as indicated.

If a value does not exist, click Edit > New > String Value, type the name of the value, and then 
press Enter. All the values should be string values except for AutoAdminQueryNDS, which 
must be a DWORD value instead of a string value. 
IMPORTANT: If no DefaultPassword string is specified, the value of the AutoAdminLogon key is 
automatically changed from 1 (true) to 0 (false), disabling the AutoAdminLogon feature.

3 Exit the Registry Editor and log out of Windows NT or Windows 2000.

Changing Passwords in NetWare Login with AutoAdminLogon
If AutoAdminLogon is enabled, be careful when running the NetWare Login utility from the icon 
in the NetWare (Common) group. When run as a standalone utility from the icon, NetWare Login 
does not recognize that the workstation is running AutoAdminLogon.

If the primary connection’s password expires when running NetWare Login from the icon, the user 
is given the chance to synchronize all NetWare and NT passwords. Make sure that users do not 
synchronize the NT password, because NetWare Login does not update the Registry setting for 
AutoAdminLogon.

Uninstalling Novell Client
You can uninstall the Novell Client by using Add/Remove Programs.

1 Click Start > Settings > Control Panel.

2 Double-click Add/Remove Programs.

3 Locate and select the Novell Client software, then click Change/Remove. 

The Novell Client software is removed. However, some files might stay on the workstation 
until the workstation is rebooted.

4 Reboot your workstation. 

For older versions of Novell Client, use the uninstall utility or select Remove in Network 
Properties.

For Windows 95/98, double-click the uninstall utility (unc32.exe) located in the 
win95\language_directory\admin directory.

For Windows NT, in the Network Properties, click Services > Novell Client for Windows NT/
2000/XP > Remove, and then click Yes.

For Windows 2000/XP, right-click My Network Places, click Properties, right-click Local 
Area Connection, and then click Properties > Novell Client > Uninstall.

Key: hkey_local_machine\software\microsoft\ 
windowsnt\currentversion\winlogon

Key: hkey_local_machine\software\novell\ login

AutoAdminLogon=0 AutoAdminLogon=0
Managing Novell Client 53



    Novell Confidential                                                                                            Manual (99a)  14 April 2004
54   Novell Client for Windows Installation and Administration Guide



    Novell Confidential                                                                                            Manual (99a)  14 April 2004
6 Printing to a Network Printer

Printer setup can be automated so that users’ workstations attach to the network printers they use 
each time users log in to the network. Users can use the network printers without having to 
manually connecting to the printer every time they want to print.

After connecting to a network printer, users can select the printer from any application that they 
are using. See the application’s documentation for information on using printers.

Attaching to a Network Printer
A printer driver for each type of printer must be installed on the workstations.

Users can set up network printing on a workstation by specifying the name of the printer in any of 
the following programs:

Novell® iPrint

Windows Add Printer Wizard

Novell Capture Printer Port

The following can automate printer connections so that the computer connects to network printers 
each time a user log in:

NetWare® Login Script

NT/2000 Restore Connections

NT/2000 Logon Script

Setting Up Network Printing through the Windows Add Printer Wizard
1 Click Start > Settings > Printers.

2 Double-click Add Printer and follow the onscreen instructions.

3 When prompted, click Network Printer Server and select a printer you want to use from the 
Shared Printers box.

For NetWare 4 or later networks, double-click Novell Directory Services® and find the 
context for the printer. Then select a Printer object from the list.

For NetWare 3 and bindery networks, double-click NetWare Servers. Then double-click 
the name of the server that supports the queues you want to use and select the queue.

4 (Conditional) If a dialog box prompts you to install a driver for the printer, click OK and 
install it.

4a Select the name of the printer from the Driver box, then click OK.

4b Type the path to the printer driver, then click OK.
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5 Run an application and select the network printer when you print.

Specifying Capture Settings with Windows Printing
Windows does not require captured printer ports to print to a network printer. Windows can use 
print devices that are associated with network printers. This allows applications to print directly to 
a network printer.

The CAPTURE utility does not affect Windows printer devices.

Captures are global. If you capture a printer port, the port is available for network printing 
from anywhere in Windows.

Use the Capture Settings dialog box to specify printer settings for print captures created with 
Windows. This can be useful if you want to use a DOS or Windows 3.x application that relies on 
print captures and you can’t put the capture in a login script.

To access the Capture Setting dialog box:

1 Right-click the N icon in the system tray.

2 Click Novell Capture Printer Port.

3 Type the correct information in the dialog box.

4 Click Settings.

These settings apply only to printer ports that are captured from Windows. Printer ports that are 
captured in a login script or from the command line do not use these settings.

These settings do not apply to printers that appear in the Windows Printers folder.

Changing the printer settings for a specific captured printer port does not change the default printer 
settings.

Setting Up Point and Print
1 Locate printer driver files from the Windows operating system CD-ROM or the Windows 

printer driver files supplied by the printer’s manufacturer.

2 Log in as Admin or as a user with Admin-equivalent rights for the printer or print queue.

3 Select a printer or print queue in the Windows Explorer or Network Neighborhood.

4 Click File > Properties > Setup Point and Print.

5 Specify the path for the printer driver files.

You must be logged in to the tree or server where the path is located. You must also have 
sufficient rights for the specified directory to copy the files there. Users need Read and File 
Scan rights for the specified directory.

6 Click Select Printer Model.

7 Select the manufacturer of the printer.

8 Select the model of the printer.

9 Click OK.

The printer driver files are copied to the path specified in Step 5.

10 Click OK again.
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Printing DBCS Characters from DOS in Windows NT/2000/XP
In Windows NT/2000/XP, the default command window runs as a 32-bit process. In order to use 
the existing DOS printer driver for DOS-intrinsic commands, you must use a 16-bit command 
window.

This allows DOS-intrinsic commands such as COPY, TYPE, etc., to use the print driver.

The following instructions explain how to set up NT to support this. These instructions also set up 
the NT system to support the printer driver for DOS applications.

1 Edit the autoexec.nt file, found in the %systemroot%\system32 directory, adding the DOS 
printer driver for your specific printer. Add the printer driver after the following line:

 %SYSTEMROOT%\SYSTEM32\VLMSUP.EXE

Make sure that you copy the printer driver to the path you specify in the autoexec.nt file.

2 Save a copy of the winnt_directory\system32\config.nt file with another filename, such as 
config.prt.

3 Edit the new CONFIG file, adding the DOSONLY command to the file.

4 Continue the setup process using the instructions for your specific version of Windows NT.

4a Create a shortcut to the command.com program, found in the winnt_directory\system32 
directory.

4b Right-click the shortcut icon, then click Properties.

4c On the Program property page, click Windows NT and type the paths for the CONFIG 
and AUTOEXEC files that you created in Step 1 and Step 2.

4d Double-click the shortcut icon. 

A DOS window will open.

Only DOS applications can be run from this window, but anything that is printed will be rendered 
by the printer driver that you installed. Any DOS commands that affect the print driver must be 
specified in this window. DOS applications can be started by any method.

Disabling NetWare Login Dialog Boxes Brought Up by the Print 
Provider

If users log in to a workstation but do not log in to NetWare and they have NetWare printers 
installed, they will be prompted to log in to NetWare once by the QMS print provider and once by 
the NDPS® print provider. These login dialog boxes can be disabled if desired.

Windows NT/2000/XP
Windows NT/2000/XP has two registry setting options for disabling login dialog boxes:

If you set

HKLM\SOFTWARE\Novell\Print\Delay Login\Delay Login=1

the print provider tells Windows that the printer is a NetWare printer even though the user is 
not authenticated. Then, the provider waits for an action that requires authentication is 
detected before displaying a login dialog box.
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If you set

HKLM\SOFTWARE\Novell\Print\Never Login\Never Login=1

the print provider never displays the NetWare login dialog, and print jobs sent prior to 
authentication fail. A message similar to the following is displayed:

Error writing to \\TREE\QUE.context: A write fault occurred on the 
network. Do you wish to retry or cancel the job?

Windows 95/98
Windows 95/98 has two registry setting options for disabling login dialog boxes:

If you set

HKLM\SOFTWARE\Novell\Print\Never Login\Never Login=1

the print provider never displays the NetWare login dialog. Print jobs will succeed, but the 
printer will go offline. To print, you must log in to NetWare and then manually turn the printer 
online by opening the Printers folder, right-clicking the printer, and deselecting Print Offline.

If you set

HKLM\SOFTWARE\Novell\Print\Never Login\UserDialupSettings=1

the print provider sets Never Login to the dial-up connection settings and attempts to print.
NOTE: This functionality is available only in Windows 95B or later.
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A Troubleshooting Issues

This appendix provides troubleshooting information for known issues.
TIP: If you do not find a solution to your issue here, check the Novell Client Readme as well as the Novell 
Technical Support Web site (http://support.novell.com.).

Windows 95/98 Issues
The following issues will help you troubleshoot Novell® ClientTM for Windows 95/98. For 
additional issues, check the Novell Client Readme. 

Installation

Drag-and-Drop Operations Do Not Work Immediately after Installation

Drag-and-drop operations between applications on the desktop might not work immediately after 
the client is installed and the workstation is rebooted. To solve this problem, reboot again to ensure 
proper registration of the ActiveX* controls included in the client.

NDPS Required on NetWare 5.1

An update to NDPS® is required to solve a client hang. Install the dprpcnlm.nlm file, dated 
22Nov2000 or later. This update is included in NetWare® 5.1 Support Pack 3. Refer to TID 
10062546 (http://support.novell.com/cgi-bin/search/searchtid.cgi?/10062546.htm).

Update Required on NetWare 4.11 and NetWare 4.2 Servers

NetWare 4.11 and NetWare 4.2 servers require an update on the server prior to the installation of 
this Novell Client. The server update information is located in TID 2952441 (http://
support.novell.com/cgi-bin/search/searchtid.cgi?/2952441.htm). This update addresses an issue in 
which a file opened once by different threads (one open in each thread) in an application and then 
closed leaves an instance of the file open, even after exiting the application. This problem could 
cause the server to run out of memory or hang.

IP with IPX Compatibility Dependency

When using the IP with IPXTM Compatibility client configuration, make sure that the TCP/IP stack 
has been configured with a TCP/IP gateway. This can be configured through DHCP or 
defined locally. The IPX Compatibility driver and IP routing will not work properly without a 
TCP/IP gateway configured. Under Windows 95/98, the gateway can be configured by opening 
the TCP/IP Properties page from the Network Properties page. If your network is configured to 
use DHCP, you do not need to configure the gateway locally.
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IP with IPX Compatibility Needs Migration Agent

If you are using the IP with IPX Compatibility configuration on the client and are trying to connect 
to servers running IPX only, make sure that you have configured a Migration Agent (MA) on the 
network.

For more information on setting up a Migration Agent on the network, see the NetWare 5 online 
documentation (http://www.novell.com/documentation). To troubleshoot a Novell Client’s MA 
visibility or configuration, enter CMDINFO at the DOS prompt. This command should list all 
configured or discovered MAs, depending on the IPX compatibility configuration.

ZENWorks for Desktops 2 Remote Management Does Not Work after Upgrading to Novell Client for 
Windows 95/98

If you upgraded Novell Client software and chose to update Remote Management during 
installation, Remote Management will not function if you do not have ZENworks® for Desktops 
3. If you have inadvertently upgraded Remote Management and do not have ZENworks 3 for 
Desktops, do the following:

1 Uninstall Novell Client for Windows 95/98.

2 Install a previous version (with the Remote Management option selected) of Novell Client for 
Windows 95/98. 

This replaces the Remote Management functionality.

3 Install Novell Client for Windows 95/98 without selecting Remote Management.

Installing ZENWorks for Desktops 2 Remote Management and Novell Client Software for Windows 95/98 on 
a New Workstation

If you have new workstations that require ZENworks for Desktops 2 Remote Management and 
Novell Client for Windows 95/98, do one of the following:

Install Remote Management Using an Application Object

1 Install Novell Client for Windows 95/98 without selecting Remote Management.

2 Use the NAL Remote-OS Application Object to install Remote Management.

Install Remote Management Using a Previous Version of the Client

1 Install a previous version of Novell Client for Windows 95/98. 

This installs the Remote Management functionality.

2 Install Novell Client for Windows 95/98 without selecting Remote Management.

Login

Mfc42.dll Error

Novell Client runs with mfc42.dll version 4.21.7022 or later. mfc42.dll version 6.00.8267.0 is 
installed when you install Novell Client. If an older version is installed over the version installed 
by Novell Client, the client login fails with an error message similar to the following:

The ordinal 6453 could not be located in the dynamic link library mfc42.dll.

The actual message might vary, depending on the version of mfc42.dll you are using.
60   Novell Client for Windows Installation and Administration Guide

http://www.novell.com/documentation
http://www.novell.com/documentation


    Novell Confidential                                                                                            Manual (99a)  14 April 2004
To recover from this error, reinstall the correct version of mfc42.dll. you can find the correct file 
on the ZENworks CD at d:\products\win95\ibm_enu\mfc42.dll.

Copy the file to the c:\windows\system directory on your workstation.

Login Restrictions Set for IPX/SPX Prevent User from Logging In

Login restrictions are set for IPX/SPXTM and the node address. When the administrative 
workstation is reset, the new client files are automatically updated and the reboot prompt is 
displayed. After restarting, the workstations that are placed in the restriction list as being able to 
log in as Admin and which now have the new client cannot log in and no administration of the 
server can be done.

This is a problem with preferring the IP protocol. The allowed addresses assigned in eDirectoryTM 
are IPX addresses. If the server is bound to IP, the clients are designed to prefer this protocol by 
default. The result is that the client is attempting to log in to the server using IP but the address is 
restricted to allow only IPX addresses, causing an authentication failure. This is due to the IP 
address not being stored in eDirectory.

Do not bind IP to the server until static IP addresses have been assigned. Or, change your protocol 
preference to IPX.

Dial-Up Networking

Dial-Up Networking over IP: SLP Configuration

In order to use SLP name resolution with dial-up networking, you must add the directory agent’s 
IP address to the directory agent list on the Novell NetWare Client Properties Service Location tab.

1 Right-click the N icon in the system tray, then click Novell Client Properties.

2 Click the Service Location tab.

3 Add the directory agent IP address to the directory agent list, then click OK.

Dial-Up Networking over IP: Unable to See the Network

If you are using dial-up networking on the client and are unable to log in or browse the network, 
do the following:

1 Make sure that you can resolve NetWare 5 or later IP server names.

For dynamic discovery of servers, make sure that your client can locate an SLP Directory 
Agent. The agent can be configured statically or it can be configured through DHCP if your 
dial-up host supports DHCP and is configured with the proper Discovery Agent.

By default, the client uses DHCP to locate a Discovery Agent. (This assumes that a Discovery 
Agent is configured on the dial-up host network.)

The client uses an nwhost file, if present, which contains server names and their addresses. 
This might be a preferred way to run your client. (The file is created in the novell\client32 
directory on the workstation.)

The client also supports DNS names. After connecting to the dial-up host, make sure that your 
DNS server is working properly by attempting to ping your server using its DNS name. If the 
ping was successful, then use that same DNS name as your server name in the login dialog.
TIP: Isolate the problem down to name resolution by using an IP address instead of the server name. If 
the login works, the problem is in name resolution.
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2 Make sure that the IP stack is still functioning properly by pinging known active IP nodes that 
are on the dial-up host network.

3 If you are using IP with Compatibility Mode on the client and cannot see any IPX servers, 
make sure that the clients Migration Agent is configured properly.

See “Dial-Up Networking with Compatibility Mode” on page 62.

Dial-Up Networking with Compatibility Mode

In order to use Compatibility Mode to locate IPX services over a dial-up connection, you should 
statically configure the Migration Agent on the Compatibility Mode Driver property page.
NOTE: If your dial-up host supports DHCP Inform requests and is configured to hand out Migration Agents, 
you shouldn’t need to set the Migration Agent statically.

1 Click Start > Settings > Control Panel.

2 Double-click Network > Compatibility Mode Driver (CMD).

3 Uncheck the Use DHCP check box and then add a Migration Agent, using an IP address in 
dotted format (for example: 137.65.1.5). 

You can also use a DNS name, keeping in mind the dial-up environment that you are using.

4 Press OK to save the changes.

Printing

Do Not Configure a Local NPRINTER with Interrupts

Do not configure a local NPRINTER with interrupts. Use the default Polled Mode instead.

Windows NT/2000/XP Issues
The following issues will help you troubleshoot Novell Client for Windows NT/2000/XP. For 
additional issues, check the Novell Client Readme.

Installation

IPX Compatibility Mode and the IPX Internal Network Number

Workstations using IPX Compatibility Mode cannot have an IPX internal network number 
configured. If you have configured an IPX internal network number on your workstation and you 
plan to install the Novell IP Client with IPX Compatibility Mode, then remove the IPX internal 
network number before installing the client.

(Windows NT-Only) Errors Resulting from a Custom Installation of Novell Client for Windows NT

We recommend that you use the Typical Installation option for most installations of Novell Client 
software. If you are installing Novell Client and you select Custom Installation, note that the 
Novell IP gateway is not compatible with CMD (IPX Compatibility Mode Driver).

Using Remote Management with ZENworks for Desktops

If you plan to use Remote Management, make sure that Workstation Manager is installed on all 
workstations that will be managed remotely.
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NDPS Required on NetWare 5.1

An update to NDPS is required to solve a client hang. Install the dprpcnlm.nlm file, dated 
22Nov2000 or later. This update is included in NetWare 5.1 Support Pack 3. Refer to TID 
10062546 (http://support.novell.com/cgi-bin/search/searchtid.cgi?/10062546.htm).

Update Required on NetWare 4.11 and NetWare 4.2 Servers

NetWare 4.11 and NetWare 4.2 servers require an update on the server prior to the installation of 
this Client. The server update information is located in TID 2952441 (http://support.novell.com/
cgi-bin/search/searchtid.cgi?/2952441.htm). This update addresses an issue in which a file opened 
once by different threads (one open in each thread) in an application and then closed leaves an 
instance of the file open, even after exiting the application. This problem could cause the server to 
run out of memory or hang.

Password Issues

We recommend that administrators configure NT workstations to not use any of the Microsoft 
password restrictions available in User Manager. Novell Client for Windows NT/2000/XP works 
best if password restrictions are left up to eDirectory.

Login

Mfc42.dll Error

Novell Client runs with mfc42.dll version 4.21.7022 or later. mfc42.dll version 6.00.8267.0 is 
installed when you install Novell Client. If an older version is installed over the version installed 
by Novell Client, the client login fails with an error message similar to the following:

The ordinal 6453 could not be located in the dynamic link library mfc42.dll.

The actual message might vary, depending on the version of mfc42.dll you are using.

To recover from this error, reinstall the correct version of mfc42.dll. You can find the correct file 
on the ZENworks CD at d:\products\winnt\i386\libs32\mfc42.dll.

Copy the file to the %systemroot%\system32 directory on your workstation.

Copying mfc42.dll will fail if some component is using the file. If the copy fails, try renaming 
%systemroot%\system32\mfc42.dll to %systemroot%\system32\mfc42.old and then try copying 
the new version again.

Login Restrictions Set for IPX/SPX Prevent User from Logging In

Login restrictions are set for IPX/SPX and the node address. When the administrative workstation 
is reset, the new client files are automatically updated and the reboot prompt is displayed. After 
restarting, the workstations that are placed in the restriction list as being able to log in as admin 
and which now have the new client cannot log in and no administration of the server can be done.

This is a problem with preferring the IP protocol. The allowed addresses assigned in eDirectory 
are IPX addresses. If the server is bound to IP, the clients are designed to prefer this protocol by 
default. The result is that the client is attempting to log in to the server using IP but the address is 
restricted to allow only IPX addresses, causing an authentication failure. This is due to the IP 
address not being stored in eDirectory.

Do not bind IP to the server until static IP addresses have been assigned. Or, change your protocol 
preference to IPX.
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Login Script

CAPTURE Execution in a Login Script

If you use a login script that contains an external CAPTURE command using capture.exe, the 
screen might go blank with a blinking cursor in the upper-left corner. The capture eventually 
executes and the screen returns to normal.

This happens if Windows NT or Windows 2000 is set to “full screen” when the CAPTURE 
command is executed from the login script. Although the system might be working correctly, a 
slow server performing the capture with a blank screen may make it appear otherwise.

To correct this problem:

1 Double-click My Computer, then click Control Panel > MS-DOS Console.

2 In the Console Windows Properties dialog box, click the Options tab.

3 From the Display Options group, click Window.

Login Script Command SET_TIME ON/OFF Behaves Differently on NT

Novell Client for Windows NT/2000/XP Properties > Advanced Settings contains a Set Station 
Time property.

When this setting is On, the workstation time is always synchronized with the network during 
GINA Login. The login script SET_TIME command has no effect on time synchronization, 
because the time is being synchronized before the script command is processed.

When the setting is Off, the SET_TIME ON script command has an effect when scripts are run, 
and the workstation time is synchronized with the network.

Windows 2000 and XP both ignore the SET_TIME script command regardless of the client 
property setting Set Station Time=On|Off and update the time/date to the Netware Server Time/
Date at Gina Login only. Subsequent script executions do not make any difference as the script 
command seems to be ignored.

Map.exe Utility

The map.exe utility might function improperly if the computer’s DOS environment size is too 
small. If you encounter problems while running map.exe, increase the DOS environment size by 
adding or editing the SHELL= line in the winnt\system32\config.nt file. For example:

SHELL=%SYSTEMROOT%\SYSTEM32\COMMAND.COM /E:2048

Map.exe was not designed as a Windows NT/2000/XP executable and, therefore, does not 
recognize drives mapped to NT servers as network drives. Consequently, MAP will not list NT 
network drives. The Windows NT NET USE command can be used to correctly connect and list 
network drives for both NetWare and NT servers.

Map.exe Might Fail When Mapping a Drive to a Novell eDirectory Object on Windows NT

Map.exe is not IP-aware for eDirectory objects. As a result, map.exe might fail if you try to use it 
to map a drive to an eDirectory object—for example, with a command like the following:

map n .mydir.organization.company

The failure will result in a message such as the following:
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MAP-4.13-195: Directory [N .mydir.organization.company cannot be located

This error can be avoided by using one of the following solutions:

Use map n server\vol:\directory instead of map n 
.mydir.organization.company.

Unbind IP from the server that the eDirectory object points to.

Configure the Protocol Preferences of Novell Client property page to use IPX only.

Drive Mappings Automatically Root Mapped

In Windows NT/2000, all drive mappings made using the NetWare Login are root mapped. 
Because of this, programs cannot access directories above the directory that the drive is mapped 
to. This feature affects only MAP commands performed in a login script. After Windows NT has 
been started, NT allows you to map only to the root.

You can turn off the default by adding SET MAPROOTOFF="1" as the first line in the login script. 
This will globally force all NT workstations using the login script to not map root drives.

Or, you can perform the following procedure on a local workstation:

1 Right-click My Computer.

2 Click Properties > Advanced > Environment.

3 Click New to create a new variable.

4 Type MAPROOTOFF as a variable.

5 Set the value of the MAPROOTOFF variable to 1.

6 Click OK > OK.

Errors When Reconnecting Permanent Drive Mappings to Servers in Different Directory Trees

In Windows NT 4.0, users might encounter an error when restoring permanent drive mappings to 
NetWare servers in different trees. These mappings will be authenticated through Novell 
eDirectory. The user might get an Invalid Password prompt when restoring these drives. This is 
not because the password is invalid but because the client does not have a valid context for the 
secondary tree.

If this problem occurs, enter the default context for all eDirectory trees on the Client tab of the 
Novell Client Configuration page. This is accessed by right-clicking Network Neighborhood and 
then clicking Properties > Services > Novell Client for Windows NT > Properties. 

Permanent Connections

If you have a permanent drive mapping that conflicts with a drive mapping made in your login 
script, a dialog box appears indicating that an error occurred while reconnecting the drive and that 
the local device name is already in use. One of the options in this dialog box has some confusing 
results. If you check Do Not Try to Restore the Connection in the Future, and then click Yes or 
OK, the drive mapping made from your login script is removed.

If you do not check this check box, the drive mapping from your login script is preserved. This is 
a bug in Windows NT. By default, Windows NT removes any mappings on that drive letter without 
checking to see whether the existing drive mapping is the same path as the permanent connection.
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Printing Issues

NDPS and NetWare 5 

You might experience difficulties printing through NDPS if your network connection is dropped 
and later auto-reconnects. You could receive the following error messages:

Error writing to <printer>: Space to store the file waiting to be printed is 
not available on the server.

A write fault occurred while printing.

To resolve this problem, you must download and install NetWare 5 Support Pack 2 or later. Then 
complete the following:

1 At the server console, load ndpsm.nlm to load NDPS Manager on the server.

2 From the NDPS Manager main menu, select Printer Agent List.

3 Select a Printer Agent.

4 After the Printer Agent information is displayed, click Configuration: (See Form).

5 From the configuration screen, change the Security Level from High to Medium.

Remote Access Services Issues

Supporting a Large Number of Remote Access Services (RAS) Users

If you support a large number of RAS users in your network and you experience problems with 
users not being able to log in because of insufficient NetWare connections, try setting the 
Watchdog configuration parameters so that connections time out quickly when RAS connections 
terminate abnormally.

SLP Requirements for Server Name Resolution from RAS Clients

If you rely on SLP to provide the resolution of server names to IP addresses in your network and 
your RAS server does not forward IP multicast packets between the client and the network, then 
you must set up and configure SLP Directory Agents.

You can configure SLP Directory Agents through the Novell Client property pages or through 
DHCP.

IPX Compatibility Requirements for RAS Client

IPX Compatibility Mode requires the services of SLP. For more information, see “SLP 
Requirements for Server Name Resolution from RAS Clients” on page 66.

Before installing the Novell IP Client with IPX Compatibility support, make sure that the RAS 
Client is configured to perform only IP networking over the RAS connections.

Restoring RAS Connections and IPX Compatibility

You must restart your workstation before re-establishing a RAS connection if 

The RAS server assigns your client a different IP address during each RAS connection

You are using IPX Compatibility Mode to run IPX applications or to connect to IPX servers 
from your Novell IP Client
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You can avoid the changing address problem over RAS connections if you statically configure the 
IP address that your workstation uses over the dial-up adapter.

IPX Compatibility

IPX Compatibility and Multiple Network Attachments

You should be aware that limitations of the IPX stack present in Windows NT and limitations of 
16-bit IPX/SPX applications complicate operations of multihomed workstations. These 
limitations impose additional configuration requirements to make use of the services of IPX 
Compatibility from your multihomed Novell IP Client.

Workstations connected to the network through more than one network attachment are considered 
to be multihomed workstations. LAN connections and RAS connections qualify as network 
attachments.

On Windows NT, the IPX stack does not allow IPX applications to detect more than one network 
attachment to segments with the same network number. This limitation forces you to configure 
different IPX Compatibility Network Numbers (also known as CMD Network Numbers) for each 
adapter used by your workstation to access the network if you want to allow your Novell IP Client 
to simultaneously access IPX Servers through each one of the adapters. For example, you could 
allow IPX Compatibility to use the default IPX Compatibility Network Number over the LAN 
adapter but configure a different network number for IPX Compatibility to use over the RAS 
connection (WAN adapter). You should be aware that nodes utilizing IPX Compatibility on the 
same network should be configured to use the same network number in order to directly 
communicate when using Client/Server IPX applications.

The IPX stack arbitrarily selects a network attachment for 16-bit IPX/SPX applications because 
those applications expect to operate on workstations with only one network attachment. For this 
reason, you might find that your 16-bit IPX/SPX applications are capable of communicating over 
your LAN adapter only when you also have a RAS connection over a WAN adapter.

If you have a multihomed Novell IP Client and you want to use the service of IPX Compatibility 
over only one of the network attachments and you are getting unwanted results, then you can 
disable IPX Compatibility over the other network attachments. For example, if you have a 
workstation connected to the corporate network through LAN adapter A and connected to a lab 
network through LAN adapter B, and IPX Compatibility only seems to work over LAN adapter B, 
you can force IPX Compatibility to work over LAN adapter A by opening the IPX Compatibility 
property page, selecting LAN adapter B, and unchecking the Enabled check box.

IPX Compatibility and Changing IP Addresses

When the IP address of a given interface changes, you might not be able to restore the connections 
that you had to IPX servers from your Novell IP Client, or your IPX/SPX applications might stop 
working. If this occurs, you will have to restart your workstation to recover.

IP interface addresses can change because of TCP/IP manual configuration changes, because a 
DHCP lease expires and is renewed with a different address, or because your network connection 
goes down and then back up (such as when you re-establish a RAS connection).

You can avoid the changing address problem over RAS connections if you statically configure the 
IP address that your workstation uses over the dial-up adapter.
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DOS Utilities Supported Only When Used with IPX or IP Compatibility Mode

DOS utilities (CX, MAP, CAPTURE, etc.) are supported only when used with IPX or IP 
Compatibility Mode. Use the equivalent GUI-based utilities when accessing resources that are 
available only from IP servers.

Software Compatibility Issues

Microsoft SMB Client Support over IPX

Novell Client for Windows NT/2000/XP coexists with the Microsoft SMB Client over IPX 
networks. The Microsoft SMB Client utilizes NetBIOS when communicating over IPX, which 
increases the utilization of your network.

If you want to prevent the Microsoft SMB Client from communicating over NetBIOS, modify 
your workstation configuration by unbinding the workstation and server from NWLink NetBIOS 
in the Network Properties page.

Microsoft File and Print Services

Novell Client for Windows NT software does not work with Microsoft File and Print Services for 
NetWare (FPNW). This is because FPNW advertises itself as a NetWare 3.12 server but does not 
emulate a NetWare 3.12 server. It more closely emulates a NetWare 2.2 server. When the client 
attaches, it attempts to use features that are available on NetWare 3.12 servers. Because FPNW 
does not support these features, the client is unable to use FPNW.

A fix is available from Microsoft, but Novell testing indicates that the fix still does not provide a 
complete solution.
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