PRB: DDEML with Excel Error: Remote Data Not Accessible (95982)
The information in this article applies to:
- Microsoft Windows Software Development Kit (SDK) 3.1
- Microsoft Win32 Application Programming Interface (API), when used with:
- the operating system: Microsoft Windows NT 3.5
- the operating system: Microsoft Windows NT 3.51
This article was previously published under Q95982 SYMPTOMS
When data is linked between a Microsoft Excel spreadsheet and a DDEML
server application, with both applications open, the following error
message may appear:
Remote data not accessible; start application <SERVER FILENAME>.EXE?
CAUSE
Excel broadcasts an initiate to all windows, for every service/topic name
pair it finds, in an attempt to initiate a conversation with the server
application. (This can be easily verified by running DDESPY and watching
Excel broadcast its initiates.) If Excel can't get a response, or gets a
NACK (negative ACK), Excel attempts to EXEC() a new instance of the server
application.
RESOLUTION
A DDEML server application should return TRUE, in response to the
XTYP_CONNECT transaction it receives, for every service/topic name pair it
supports. Refer to page 518 of the Microsoft Windows Software Development
Kit (SDK) version 3.1 "Programmer's Reference, Volume 3: Messages,
Structures, and Functions" for more information on the XTYP_CONNECT
transaction.
MORE INFORMATION
The DDEML server application responds to Excel's initiate by sending the
XTYP_CONNECT transaction to the DDE callback function of each server
application, passing the service and topic names to the server.
If the server application fails to return TRUE to the service/topic name it
supports, Excel concludes that it is trying to initiate a DDE link to an
application that is not available, and brings up the message box above,
thus giving the user an option to start the application.
Modification Type: | Major | Last Reviewed: | 3/16/2004 |
---|
Keywords: | KB95982 |
---|
|