A USB 2.0 device stops working correctly when the device uses lots of bandwidth in Windows XP (924692)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

On a Microsoft Windows XP-based computer, you use a high-bandwidth USB 2.0 device, such as an isochronous video camera. However, after you repeatedly start and stop the USB device, it stops working correctly. This problem is more likely to occur on a system that has 256 megabytes (MB) of RAM or less. However, when the system is under heavy stress, this problem may also occur on a system that has more than 256 MB of RAM.

When this problem occurs, you may receive an error message that resembles the following:
Creation of the video preview failed.
After this problem occurs, the USB device may be marked with a yellow exclamation point in Device Manager. Additionally, other USB 2.0 devices may not enumerate correctly, may not work correctly, or both.

CAUSE

This problem is caused by a bandwidth leak in the USB 2.0 bus.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Usbehci.sys5.1.2600.299330,20811-Sep-200609:00x86SP2SP2QFE
Usbohci.sys5.1.2600.299317,15211-Sep-200609:00x86SP2SP2QFE
Usbport.sys5.1.2600.2993143,48811-Sep-200609:00x86SP2SP2QFE
Usbuhci.sys5.1.2600.299320,60811-Sep-200609:00x86SP2SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/26/2006
Keywords:kbfix kbBug kbWinXPsp3fix kbWinXPpreSP3fix kbHotfixServer kbQFE kbExpertiseBeginner KB924692 kbAudEndUser