You experience problems when you view a printer's properties in Windows XP or in Windows Server 2003 (922975)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

When you view a printer's properties in Microsoft Windows XP or in Microsoft Windows Server 2003, you may experience one or more of the following symptoms:
  • The printer icon appears as the icon for an unknown file type.
  • Nothing happens when you click Printing Preferences on the General tab.
  • Nothing happens when you click Printing Defaults on the Advanced tab.
  • The Security tab is missing.
  • A tab that is added by a third-party printer driver is missing.

CAUSE

This problem occurs if the printer is locally installed on a server, and the printer's display name meets both of the following conditions:
  • The display name starts with a reserved name that is followed by a period.
  • The display name is longer than 6 characters.
For example, this problem may occur when the display name of the printer resembles any of the following printer names:
  • PRN.001
  • COM5.AB
  • LPT3.XYZ
A reserved name may be any of the following:
  • CON
  • NUL
  • PRN
  • COM1 through COM9
  • LPT1 through LPT9
Other reserved names may also contribute to this problem.

RESOLUTION

To resolve this problem, rename the printer so that the display name of the printer does not use a reserved name.

Notes
  • We recommend that you do not use a reserved name to name a printer, a file, or any similar object in Microsoft Windows.
  • When you change a printer's display name, the users of client computers must delete and reinstall the printer on their computers.
  • You do not experience this problem when you access a shared printer's properties from a client computer.

Modification Type:MajorLast Reviewed:7/25/2006
Keywords:kbProperties kbprinters kbtshoot kbExpertiseBeginner kbprb KB922975 kbAudITPRO