You may receive an error message when you run ASP files on a Web server that is running IIS 5.0 in Medium or High application protection mode (922739)



The information in this article applies to:

  • Microsoft Internet Information Services 5.0

SYMPTOMS

Consider the following scenario. You have a Web server that is running Microsoft Internet Information Services (IIS) 5.0. IIS 5.0 is running in Medium or High application protection mode. You try to run Active Server Pages (ASP) files from the Web server. In this scenario, you may receive one of the following error messages:

Error message 1

HTTP 500 - Internal server error

Error message 2

Server Application Error
The server has encountered an error while loading an application during the processing of your request. Please refer to the event log for more detail information. Please contact the server administrator for assistance.
Additionally, the following event may be logged in the System log:Event ID: 36
Source: W3SVC
Description:
The server failed to load application '/LM/W3SVC/Number/Root/ApplicationName'. The error was 'The server process could not be started because the configured identity is incorrect'.

Related symptoms

You may also experience the following related symptoms after you experience the primary symptom:
  • When you try to expand the Component Services\Computers\My Computer node in the Component Services Microsoft Management Console (MMC) snap-in, you may receive the following error message:
    Error 80070522 "A required privilege is not held by the client."
  • You want to update the starting identity of all IIS Microsoft COM+ application packages that run out-of-process. To do this, you run the Synciwam.vbs script together with the -v option. The Synciwam.vbs script is located in the \Inetpub\AdminScripts folder on the Web server. When you do this, you may receive an error message that resembles the following error message:
    Out of process applications defined:
    Count: 1
    {3D14228D-FBE1-11d0-995D-00C04FD919C1}
    Error: 80070522:

CAUSE

This issue may occur if the remote procedure call (RPC) service is not running under the Local System account context. IIS requires the RPC service to run under the Local System account context.

RESOLUTION

To resolve this issue, configure the RPC service to run under the Local System account context. To do this, follow these steps:
  1. Click Start, click Run, type Services.msc, and then click OK. The Services MMC snap-in opens.
  2. In the right pane, locate and then double-click Remote Procedure Call (RPC).
  3. Click the Log On tab.
  4. Under Log on as, click Local System account, and then click OK.
  5. On the File menu, click Exit to close the Services MMC snap-in.
  6. Restart the computer, and then log on to the computer.
  7. Open a Web browser window.
  8. Test whether the ASP files run correctly.

Modification Type:MajorLast Reviewed:8/3/2006
Keywords:kbtshoot KB922739 kbAudDeveloper kbAudITPRO