One or more programs appear to be uninstalled when you start Windows XP Professional (922714)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1, when used with:
    • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

When you start Microsoft Windows XP Professional, one or more programs appear to be uninstalled. However, when you restart your computer, the program or programs appear to be reinstalled. This problem occurs when Group Policy assigns the programs that are uninstalled and then reinstalled.

This problem does not occur consistently.

CAUSE

This problem occurs if the following conditions are true:
  • Offline Files are configured for a Distributed File System (DFS) path that resembles the following:

    Your_Domain\Share_Name

  • The Offline Files feature determines that a shared folder that has a path that starts with Your_Domain is unavailable.
If this behavior occurs, all the shares on the computer that start with Your_Domain go offline. This behavior also occurs in the Your_Domain\SYSVOL folder.

If the SYSVOL folder is unavailable when you start the computer, Group Policy is not applied to the computer. If Group Policy is not applied to the computer, programs that Group Policy assigns are removed. This behavior occurs if the programs are configured to be removed when the policy that assigns them is not applied.

If the SYSVOL folder is available when you restart the computer, the programs that had been removed are then reinstalled.

RESOLUTION

To resolve this problem, use one of the following methods:

Method 1

Configure all server message block (SMB) shares in the domain to have paths that resemble the following example:

Server_Name\Share_Name

Method 2

Disable the Offline Files feature for all DFS paths that resemble the following path:

Your_Domain\Share_Name

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This problem is intermittent. You can reduce the incidence of this problem by taking the following measures:
  • Make sure that all the drivers for network adapters are up to date on the network.
  • Make sure that the Network Location Awareness (NLA) service is started.
For more information about how to configure Offline Files, click the following article number to view the article in the Microsoft Knowledge Base:

312171 How to configure Offline Files to synchronize when a particular network connection becomes active

This problem is solved in Microsoft Windows Vista.

Modification Type:MajorLast Reviewed:9/21/2006
Keywords:kbSMB kbGRPPOLICYprob kbtshoot kbprb KB922714 kbAudEndUser kbAudITPRO