When you start a Windows Server 2003 with Service Pack 1-based computer on which multiple minifilters are installed, the computer stops responding (922529)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
    • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems

SYMPTOMS

Consider the following scenario. You have a computer that is running Microsoft Windows Server 2003 with Service Pack 1 (SP1). The computer has many volumes. Additionally, multiple minifilters are installed on the computer. In this scenario, when you start the computer, the computer stops responding.

CAUSE

This problem occurs because of a timing issue in which the Mountmgr.sys driver causes a deadlock condition to occur when the volumes come online.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Windows Server 2003 with SP1 to install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Mountmgr.sys5.2.3790.274146,59206-Jul-200609:32x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Mountmgr.sys5.2.3790.274172,19206-Jul-200614:10x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Mountmgr.sys5.2.3790.2741155,64806-Jul-200614:11IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Minifilters are file system filters that Filter Manager (Filtmgr.sys) manages. For more information about terminology that Microsoft uses to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:7/28/2006
Keywords:kbWinServ2003preSP2fix kbExpertiseInter kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB922529 kbAudITPRO