The IIS Admin service stops responding when you try to start the IIS Admin service in IIS 6.0 (922424)



The information in this article applies to:

  • Microsoft Internet Information Services 6.0

SYMPTOMS

Consider the following scenario. Microsoft Internet Information Services (IIS) 6.0 is running on a domain controller. You do not use the default IUSER_ComputerName account as the anonymous user account for IIS 6.0. Instead, you create a new user account. Then, you configure the new user account as the anonymous user account for all Web sites on the server. In this scenario, the IIS Admin service stops responding when you try to start the IIS Admin service. Additionally, you receive an error message that states that the IUSER_ComputerName account does not exist.

CAUSE

This issue may occur if the Metabase.xml file contains entries that reference the IUSER_ComputerName account.

RESOLUTION

To resolve this issue, replace the entries that reference the IUSER_ComputerName account in the Metabase.xml file. Replace these entries by using the new user account that you configure as the anonymous user account. To do this, follow these steps:
  1. Start Notepad, and then open the Metabase.xml file.

    Note The Metabase.xml file is located in the Systemroot\System32\Inetsrv folder.
  2. Replace each IUSER_ComputerName account by using the new user account that you configure as the anonymous user account.
  3. Save the Metabase.xml file, and then close the Metabase.xml file.

MORE INFORMATION

For more information about the metabase in IIS 6.0, click the following article number to view the article in the Microsoft Knowledge Base:

814871 IIS 6.0 metabase documentation


Modification Type:MajorLast Reviewed:8/7/2006
Keywords:kbExpertiseInter kbtshoot kbprb KB922424 kbAudITPRO