Microsoft Systems Management Server 2003 Inventory Tool for Microsoft Updates cannot run when a McAfee antivirus program is installed on the same computer (922358)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

Consider the following scenario. You use the Microsoft Systems Management Server (SMS) 2003 Inventory Tool for Microsoft Updates (ITMU) to scan for updates on a computer. The computer is also running a McAfee Antivirus program. In this scenario, ITMU may not be able to start the security update scanning tool (Scanwrapper.exe).

Additionally, you may receive an error message that resembles the following in the SmsWusHandler.log:
Scan process started with cmdline = /Catalog:C:\WINNT\system32\VPCache\NOV00027\wsusscan.cab /OutputXml:C:\WINNT\system32\VPCache\NOV00027\Results.xml
SmsWusHandler 9/28/2005 3:55:10 PM 1892 (0x0764)
WUS client version detected on the machine = 5.8.0.2469.
SmsWusHandler 9/28/2005 3:55:10 PM 1892 (0x0764)
Running the SMS WUS Handler in scan mode
SmsWusHandler 9/28/2005 3:55:10 PM 1892 (0x0764) LocaleID=<1033> will be used to get localized properties.
SmsWusHandler 9/28/2005 3:55:10 PM 1892 (0x0764) Searching for all the ServicePacks now
SmsWusHandler 9/28/2005 3:55:10 PM 1892 (0x0764) Search filter - CategoryIDs contains '68C5B0A3-D1A6-4553-AE49-01D3A7827828'
SmsWusHandler 9/28/2005 3:55:10 PM 1892 (0x0764) Using C:\WINNT\system32\VPCache\NOV00027\wsusscan.cab as the offline-catalog.
SmsWusHandler 9/28/2005 3:55:10 PM 1892 (0x0764) AddScanPackageService() failed. SmsWusHandler 9/28/2005 3:55:44 PM 1892 (0x0764)
ERROR: Search() failed with hRes=0xc8000408
SmsWusHandler 9/28/2005 3:55:44 PM 1892 (0x0764) 0xc8000408 is the result value for the operation. Returning 1032 as the exit code.
SmsWusHandler 9/28/2005 3:55:44 PM 1892 (0x0764)

CAUSE

This problem occurs when the McAfee antivirus program is configured to scan the %Windir%\SoftwareDistribution folder on the site server. In this case, when the McAfee antivirus program scans the .edb file, the antivirus program locks the file. Therefore, the ITMU cannot access the .edb file.

WORKAROUND

To work around this problem, make sure that the McAfee antivirus program does not scan the %Windir%\SoftwareDistribution folder. For more information about McAfee antivirus, refer to the McAfee antivirus documentation.
For information about how to contact McAfee, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z


Modification Type:MajorLast Reviewed:7/18/2006
Keywords:kbprb KB922358 kbAudITPRO