You experience presence and delivery services issues when you use a Groove account on multiple computers (922168)



The information in this article applies to:

  • Groove Workspace 2.5 Preview Edition
  • Groove Workspace 2.5 Professional Edition
  • Groove Workspace 2.5 Project Edition
  • Groove Workspace 2.5 Standard Edition
  • Groove Virtual Office 3.0 File Sharing Edition
  • Groove Virtual Office 3.0 Professional Edition
  • Groove Virtual Office 3.0 Project Edition
  • Groove Virtual Office 3.0 Trial Edition
  • Groove Virtual Office 3.1 File Sharing Edition
  • Groove Virtual Office 3.1 Professional Edition
  • Groove Virtual Office 3.1 Project Edition
  • Groove Virtual Office 3.1 Trial Edition

SYMPTOMS

You use Groove Workspace or Groove Virtual Office on multiple computers. The sequence numbers that are associated with your account become unsynchronized. When this occurs, you experience one or more of the following presence and delivery services issues:
  • You cannot see when other users are online on one or more of the computers.
  • Other users may see your account as being offline when you are online on one or more of the computers.
  • You can receive messages only on one computer and not another.
  • You can receive workspace changes only on one computer and not another.

CAUSE

This issue occurs when the local installation of your Groove account uses a vCard that has an earlier sequence number than the vCard that is stored on the relay server that is used by your account. Therefore, Groove does not exchange certain kinds of information.

Note Groove vCards are the files that store identity information. vCards use sequence numbers so that Groove can distinguish a later version of the vCard from an earlier version of the vCard. Groove components consider the vCard that has the highest sequence number to be reliable.

RESOLUTION

To resolve this issue, perform actions that update the local vCard. Do this enough times to make the local sequence number larger than the sequence number that is on the vCard that is stored on the relay server. When the local sequence number has a large number, it is treated as being more current. Therefore, your current information carries over to the relay server.

Note In Groove Workspace 2.5 and later versions of Groove, the sequence number is increased by increments of 1,000 every time that the account is exported and imported. Minor changes, such as an identity information update or a new relay assignment, increase the sequence number by 1. Therefore, this issue is less likely to occur in current versions of Groove than in Groove Workspace 2.1. However, it is still possible.

To update your local vCard, use one of the following methods, as appropriate for your situation.

If your account always appears to be offline

  1. Save your account to a file.
  2. Double-click the file to import your account.
  3. Tell your contacts to log out of Groove and then log back on to Groove. This process updates the contacts' awareness information for your account.

If you have one computer that receives all data and other computers that do not receive the data

  1. Fetch all workspaces to the computer that receives all data.
  2. Delete the account from the other computer or computers.
  3. Save the account on the working computer.
  4. Import the saved account to one of the other computers while the first computer is online.
  5. After the two computers synchronize, save the account again.
  6. Repeat steps 4 and 5 for each additional computer. Make sure that you always import the most recent account file.
Important Do not change the sequence of these steps. If you save the account before you delete the account from the other computers, other synchronization problems may be created.

MORE INFORMATION

This sequence number issue can occur in several scenarios. However, the most common scenario is when you import an outdated account file.

For example, you create an account file, and then you change your identity information, or you upgrade Groove. In this scenario, the relay server has your new changes and the correspondingly increased sequence number. However, the older account file does not have the new changes and the increased sequence number. When you then import the older account file, the sequence number is earlier than the sequence number that is on the relay server.

Modification Type:MajorLast Reviewed:9/8/2006
Keywords:kbprb kbExpertiseInter kbtshoot KB922168 kbAudKnowledgeWorker