SYMPTOMS
After you use the Windows Installer Zapper (Msizap.exe) tool to uninstall a program, the update information for all the programs on the computer is removed. Therefore, programs that you have already updated may appear to require the same updates again. Or, updated programs may no longer work as expected.
You experience this problem if the following conditions are true:
- You use version 3.1.4000.2508 of the Msizap.exe tool or an earlier version of Msizap.exe.
- You uninstall a program that was updated through the Windows Installer program.
Note Although you can run the Msizap.exe tool as a stand-alone command-line tool, Msizap.exe is also included in other utilities. These include the following:
- The Windows Installer Cleanup Utility
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
290301
Description of the Windows Installer CleanUp Utility
- The Windows Support Tools
To install the Microsoft Windows Server 2003 Support Tools, double-click Suptools.msi in the Support\Tools folder on the Microsoft Windows Server 2003 CD.
CAUSE
This problem occurs because, when you use the Msizap.exe tool to uninstall a program that has been updated, Msizap.exe deletes the following registry subkeys:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Patches
HKEY_CLASSES_ROOT\Installer\Patches
These subkeys contain update information for all updated programs on the computer. Therefore, when these subkeys are deleted, update information is removed for all updated programs on the computer.
RESOLUTION
To resolve this problem, install the updated version of the Msizap.exe tool.
Note Although this hotfix was created for Windows Server 2003, you can also run Msizap.exe in Microsoft Windows XP and in Microsoft Windows 2000.
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
No prerequisites are required.
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 32-bit x86 version
|
Msizap.exe | 3.1.4000.2726 | 94,720 | 15-Jun-2006 | 22:51 | x86 |
Windows Server 2003, 64-bit x64 version
|
Msizap.exe | 3.1.4000.2726 | 135,680 | 15-Jun-2006 | 22:52 | x64 |
Windows Server 2003, 64-bit version for Itanium-based systems
|
Msizap.exe | 3.1.4000.2726 | 216,064 | 15-Jun-2006 | 22:52 | IA-64 |
Hotfix installation information
This hotfix extracts the updated version of the Msizap.exe file to a folder on the computer. Copy this file to the computer on which you want to run Msizap.exe.