Error message in the win32k!xxxMenuWindowProc+b4f process in Windows Server 2003 or Windows XP: "Stop 0x0000008e" (920192)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

In Microsoft Windows Server 2003 or in Microsoft Windows XP, you drag an item that is on a menu. When you do this, you receive a Stop error message that resembles the following:
***Stop: 0x0000008e (0xc0000005, 0xbf8f5be1, 0xb8f57b08, 0x00000000)
Note The Stop error message occurs in the win32k!xxxMenuWindowProc+0xb4f process.

CAUSE

This problem occurs if the menu is not validated in the Win32k.sys driver code.

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesYou must be running Windows Server 2003 with Service Pack 1 (SP1) to install this hotfix. Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, 32-bit versions
File nameFile sizeDateTimePlatformSP requirement
Gdi32.dll282,11206-Jun-200608:25x86SP1
Win32k.sys1,850,88006-Jun-200601:21x86SP1
Windows Server 2003, x64-based versions
File nameFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll610,30406-Jun-200609:04x64SP1Not Applicable
Win32k.sys4,529,15206-Jun-200609:04x64SP1Not Applicable
Wgdi32.dll285,18406-Jun-200609:04x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll907,77606-Jun-200609:06IA-64SP1Not Applicable
Win32k.sys5,554,17606-Jun-200609:06IA-64SP1Not Applicable
Wgdi32.dll285,18406-Jun-200609:06x86SP1WOW

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesYou must be running Windows XP with Service Pack 2 to apply this hotfix. Restart requirementYou must restart the computer after you install this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.1.2600.29891,839,74405-Sep-200612:33x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/19/2006
Keywords:kbWinServ2003preSP2fix kbExpertiseInter kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB920192 kbAudITPRO