The Visual C runtime heap manager is incorrectly selected during the process startup in Windows Server 2003 Service Pack 1 with the East Asian language pack installed (919136)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

On a Microsoft Windows Server 2003 Service Pack 1 (SP1)-based computer that has the East Asian language pack installed, you find that the Visual C runtime heap manager is incorrectly selected during the process startup. Because this heap manager does not have the pageheap option enabled, it prevents you from troubleshooting a spooler heap corruption issue.

CAUSE

This problem occurs because there is a problem in the East Asian language support in Windows Server 2003 SP1.

If you install the East Asian language pack, the Usp10.dll file will be loaded by the Gdi32.dll initialize routine. The Usp10.dll file will then call the malloc() function in Msvcrt.dll. At this point, the Msvcrt.dll file is loaded but it is not initialized. The malloc() function will select the heap manager for the system heap or the runtime heap.

However, if the Msvcrt.dll file is already initialized, the malloc() function always uses the system heap on a Windows Server 2003 SP1-based computer. In this case, the malloc() function selects the runtime heap manager because the Msvcrt.dll file does not detect the version of the operating system.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows Server 2003 SP1 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Usp10.dll1.422.3790.2706379,90419-May-200603:32x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/22/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB919136 kbAudITPRO kbAudDeveloper