You cannot view a sales account, a lead, or an opportunity that is owned by another user in the Turkish version of Microsoft Dynamics CRM 3.0 (917602)



The information in this article applies to:

  • Microsoft CRM client for Microsoft Office Outlook, when used with:
    • Microsoft CRM 3.0
  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

When you log on as a user who has the SalesPerson role and then try to view a sales account, a lead, or an opportunity that is owned by another user, the sales account, the lead, or the opportunity does not open. This problem occurs in the Turkish version of Microsoft Dynamics CRM 3.0.

The following error message is logged in the Application event log on the server that is running Microsoft CRM: Error Description:
Exception from HRESULT: 0x80044150.

Error Details:
Exception from HRESULT: 0x80044150.

Error Number:
0x80044150

Source File:
Not available

Line Number:
Not available

Date: date
Time: time

Type: Platform Error (3)
Server: IP address
Request URL: URLAdditionally, if the DevErrors parameter is enabled in the Web.config file, you receive the following error message.

Note You may receive this error message when the user is assigned a role that has permissions to view a sales account, a lead, or an opportunity that is owned by another user.
Microsoft CRM Unhandled Error
Details: Server Error in '/' Application.

Exception from HRESULT: 0x80044150.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x80044150.

Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: [COMException (0x80044150): Exception from HRESULT: 0x80044150.] Microsoft.Crm.Platform.ComProxy.CRMAccountClass.RetrievePrincipalAccess(CUserAuth& Caller, String AccountId, CSecurityPrincipal& Principal) +0 Microsoft.Crm.Application.Platform.Account.InternalGetPrivileges(String id, CSecurityPrincipal& securityPrincipal) +36 Microsoft.Crm.Application.Platform.Entity.GetPrivileges(CSecurityPrincipal securityPrincipal) +34 Microsoft.Crm.Security.PrivilegeCheck.Execute(User user, Entity entity) +246 Microsoft.Crm.Security.PrivilegeCheckFactory.CreatePrivilegeCheck(User user, Entity entity) +105 Microsoft.Crm.Application.Forms.EndUserForm.RetrieveDataParams() +24 Microsoft.Crm.Application.Forms.EndUserForm.Initialize(Entity entity) +67 Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity, String formId, String formType) +83 Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity) +13 Microsoft.Crm.Web.SFA.AccountDetailPage.ConfigureForm() +238 Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e) +30 System.Web.UI.Control.PreRenderRecursiveInternal() +62 System.Web.UI.Page.ProcessRequestMain() +1499

CAUSE

This problem may occur when a query for a sales account, a lead, or an opportunity on a computer that is running Microsoft SQL Server contains the letters "I" or "i". The letters "I" and "i" are evaluated differently when you use a Turkish collation in Microsoft SQL Server. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

279651 ADO Recordset field name with letter "i" is case sensitive with Turkish settings

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics CRM 3.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this hotfix on computers that are running the server components of Microsoft Dynamics CRM 3.0 and the Microsoft Dynamics CRM 3.0 client for Microsoft Office Outlook.

Prerequisites

There are no prerequisites to apply this hotfix.

Removal information

To remove this hotfix from a computer that is running Microsoft Windows 2000, Microsoft Windows XP, or Microsoft Windows Server 2003, use the Add or Remove Programs item in Control Panel. System administrators can use the Spunist.exe utility to remove this hotfix from a computer that is running Windows 2000, Windows XP, or Windows Server 2003. The Spunist.exe utility is located in the following folder:

%windir%\$NTUninstallKB917602$\Spunist

For more information about package installer parameters, click the following article number to view the article in the Microsoft Knowledge Base:

832475 Description of the new features in the package installer for Windows software updates

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The Turkish version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Crmsecurity.dll3.0.5300.1115765,23218-Apr-200606:07

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

For more information about how to modify the Web.config file to show more detailed error messages, click the following article number to view the article in the Microsoft Knowledge Base:

857192 How to modify the Web.config file to show more detailed error messages in Microsoft CRM


Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kberrmsg kbBug kbQFE kbHotfixServer kbMBSMigrate kbpubtypekc KB917602 kbAudEndUser