Error message when you try to view the service calendar in Microsoft Dynamics CRM 3.0: "An unhandled exception was generated during the execution of the current web request" (917545)



The information in this article applies to:

  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

You cannot view the service calendar in Microsoft Dynamics CRM 3.0. Additionally, you receive the following error message:
An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

CAUSE

This problem occurs when you have working hours set in Microsoft Dynamics CRM 3.0 and when one of the following conditions is true:
  • You change time zones on your computer.
  • You change from daylight saving time to standard time, or you change from standard time to daylight saving time.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics CRM 3.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this hotfix on computers that are running Microsoft Dynamics CRM 3.0 Server.

Prerequisites

There are no prerequisites to apply this hotfix.

Removal information

You cannot remove this hotfix.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Microsoft.crm.objectmodel.dll3.0.5300.1153318,28830-May-200621:21
Microsoft.crm.webservices.dll3.0.5300.1153453,45630-May-200621:21

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MinorLast Reviewed:9/13/2006
Keywords:kbfix kbBug kberrmsg kbHotfixServer kbQFE kbMBSMigrate kbpubtypekc KB917545 kbAudEndUser