Error messages when you try to save or to close an appointment in Microsoft CRM 3.0: "An error has occurred" and "General failure in scheduling engine" (917010)



The information in this article applies to:

  • Microsoft Business Solutions CRM Software Development Kit (SDK), when used with:
    • Microsoft CRM 3.0
  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

When you try to save or to close an appointment in Microsoft Dynamics CRM 3.0, you may receive the following error messages.

Error message 1
An error has occurred. For more information, contact your system administrator. Error code: 0x80040216. OK
Error message 2
General failure in scheduling engine. Ignore and Save or Cancel.

CAUSE

This problem may occur if the following conditions are true:
  • The appointment requires resources that are already scheduled for another appointment at the same time.
  • The Microsoft CRM Post Callout objects subscribe to the PostCreate callout event for appointments.
If these conditions are true, the problem occurs because the appointment is rolled back when the resources are unavailable. The PostCreate callout event cannot retrieve the information for the appointment because the appointment no longer exists.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next version of Microsoft Business Solutions CRM that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this update on computers that are running Microsoft CRM 3.0 server.

Prerequisites

To install this update, you must have installed Microsoft CRM 3.0.

Removal information

Use Add or Remove Programs in Control Panel to remove this hotfix.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Crmmsg.dll1.2.3297.12316,08818-Jan-200600:38x86
Microsoft.crm.platform.callout.manager.dll3.0.5300.109947,97606-Apr-200611:15x86
Mscrmcustom.dll3.0.5300.1093167,13631-Mar-200607:45x86
Msvcr71.dll7.10.3052.4355,03220-Mar-200602:27x86
Pkgutil.exe1.2.3297.10188,79220-Mar-200602:40x86
Microsoft.crm.platform.callout.manager.dll3.0.5300.143,78417-Nov-200504:38x86
Crmhotfix.cdfNot Applicable3,08607-Apr-200601:51Not Applicable
Mscrmcustom.dll3.0.5300.1093167,13631-Mar-200607:45x86

Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kbExpertiseBeginner kbBug kbfix kbMBSMigrate kbQFE kbHotfixServer kbpubtypekc KB917010 kbAudKnowledgeWorker