Error messages when you install the Microsoft .NET Framework 2.0 before you install Microsoft CRM: "Reports.config has invalid schema, and could not be loaded. 0x80632900" and "Server Application Unavailable" (914079)



The information in this article applies to:

  • Microsoft CRM 3.0

INTRODUCTION

Microsoft Dynamics CRM 3.0 can work with the Microsoft .NET Framework 2.0. However, you must make some configuration changes to make the software compatible. This article outlines those changes.

SYMPTOMS

If you install the .NET Framework 2.0 before you install Microsoft CRM, you may receive one of the following error messages.

Error Message 1
Reports.config has invalid schema, and could not be loaded. Error Number: 0x80632900 Request URL: http://server/CRMReports/home_reports.aspx Stack Trace: [CRMException: Reports.config has invalid schema, and could not be loaded] Microsoft.Crm.Reports.ReportTypeCache.ValidationErrorHandler(Object sender, ValidationEventArgs e) +34 System.Xml.Schema.BaseValidator.SendValidationEvent(XmlSchemaException e, XmlSeverityType severity) +58
Error Message 2
Server Application Unavailable The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request. Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.
The following error message is listed in the application event log:
It is not possible to run two different versions of ASP.NET in the same IIS process. Please use the IIS Administration Tool to reconfigure your server to run the application in a separate process. For more information, see Help and Support Center at http://support.microsoft.com.

CAUSE

This problem occurs because Microsoft SQL Server 2005 Reporting Services and the .NET Framework 2.0 are installed manually before Microsoft CRM is installed.

RESOLUTION

To resolve this problem, follow these steps:
  1. On the Microsoft CRM server, click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
  2. Expand Computer, expand Web sites, and then select Microsoft CRM v3.0 Web site.
  3. On the Action menu, click Properties.
  4. On the ASP.NET tab, locate the ASP.NET version box, click 1.1.432, and then click OK.

    Note This tab appears only after you install the .NET Framework 2.0.
  5. Expand Microsoft CRM v3.0 Web site. Then select MSCRMServices.
  6. On the Action menu, click Properties.
  7. On the ASP.NET tab, locate the ASP.NET version box, click 1.1.432, and then click OK.
  8. Click Start, click Run, type iisreset, and then click OK.

MORE INFORMATION

Microsoft CRM 1.2 and 1.0 deployments do not support Microsoft .NET Framework 2.0. Therefore, remove the Microsoft .NET Framework from the Microsoft CRM server and from all Microsoft CRM client computers.

Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kbtshoot kberrmsg kbMBSinstallation kbMBSMigrate kbprb KB914079 kbAudEndUser kbAudKnowledgeWorker