Custom fields prevent activities from being closed when you upgrade from Microsoft CRM 1.2 to Microsoft Dynamics CRM 3.0 (913954)



The information in this article applies to:

  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

Consider the following scenario. You upgrade from Microsoft CRM 1.2 to Microsoft Dynamics CRM 3.0. Custom fields on the activity tables are created. These fields are created from non-custom fields in Microsoft CRM 1.2. In this scenario, the fields prevent activities from being closed in Microsoft Dynamics CRM 3.0.

CAUSE

This problem occurs because some of the activity fields in Microsoft CRM 1.2 are only used for certain activity types. If fields that are not related to a certain activity type are populated before you upgrade to Microsoft Dynamics CRM 3.0, custom fields are created to retain the data that is stored in the fields.

Examples of these types of fields which can be populated by using the Microsoft CRM 1.2 software development kit (SDK) include the following fields:
  • DirectionCode
  • ScheduledDurationMinutes
  • StatusCode
  • Sender
  • ToRecipients
  • ScheduledEnd
  • ScheduledStart

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Business Solutions CRM 3.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this update on computers that are running on a Microsoft Dynamics CRM 3.0 server.

Prerequisites

There are no prerequisites to apply this hotfix.

Removal information

You cannot remove this hotfix.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile sizeDateTime
Invoice status detail.rdl63,43626-Apr-200607:37
Invoice status.rdl31,78826-Apr-200607:37
Sales pipeline.rdl108,50726-Apr-200607:37
Service activity volume detail.rdl100,12426-Apr-200607:37
Service activity volume.rdl65,20001-Jun-200621:05

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MinorLast Reviewed:9/22/2006
Keywords:kbMBSupgrade kbExpertiseBeginner kbHotfixServer kbQFE kbMBSMigrate kbpubtypekc KB913954 kbAudEndUser