A program that allocates a large block of contiguous memory may not start or may intermittently fail in Windows Server 2003 (913409)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition

SYMPTOMS

Consider the following scenario:
  • You have a program that allocates a large block of contiguous memory in Microsoft Windows Server 2003. For example, this program allocates a 1.5-gigabyte (GB) block of memory when the program starts or after it starts.
  • This program loads the Hnetcfg.dll library.
In this scenario, the program may intermittently not start. Or, after the program starts, you may experience intermittent program failures. If you troubleshoot these program failures, you may determine that they occur because the program could not successfully allocate the large block of contiguous memory.

CAUSE

This problem occurs because the Hnetcfg.dll library has an image base address of 5F270000. If the Hnetcfg.dll library is loaded at this address, you may experience memory fragmentation of the Windows user address space. You experience this fragmentation because the Hnetcfg.dll library is loaded at approximately 1.6 GB into the address space.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Microsoft Windows Server 2003 Service Pack 1 (SP1) to apply this hotfix.

Note x64-based versions of Windows Server 2003 include SP1.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Hnetcfg.dll5.2.3790.2625351,74425-Jan-200603:26x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hnetcfg.dll5.2.3790.2625574,46425-Jan-200602:47x64SP1SP1QFE
Whnetcfg.dll5.2.3790.2625351,74425-Jan-200602:47x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hnetcfg.dll5.2.3790.26251,093,63225-Jan-200602:47IA-64SP1SP1QFE
Whnetcfg.dll5.2.3790.2625351,74425-Jan-200602:47x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinServ2003preSP2fix kbHotfixServer kbBug kbfix kbQFE kbpubtypekc KB913409 kbAudITPRO