FIX: A .NET Framework 2.0 application that runs under a user account context when no user profile is associated with the user account context may crash, or you may receive an access violation error message (913384)



The information in this article applies to:

  • Microsoft .NET Framework 2.0


SYMPTOMS

Consider the following scenario:
  • An application is built by using the Microsoft .NET Framework 2.0.
  • The application runs in the Microsoft .NET Framework 2.0.
  • The application runs under a user account context.
  • No user profile is associated with the user account context.
In this scenario, the application may crash, or you may receive an access violation error message. If you debug the crash, you find an access violation in the mscorwks!SecurityConfig::GetCacheEntry function.

If you experience this problem in a Microsoft ASP.NET application, you receive error messages in the event log that are similar to the following:

Error message 1

NET Runtime version 2.0.50727.42 - Fatal Execution Engine Error (7A05E2B3) (80131506)

Error message 2

Faulting application w3wp.exe, version 6.0.3790.1830, stamp 42435be1, faulting module mscorwks.dll, version 2.0.50727.42, stamp 4333e7ec, debug? 0, fault address 0x000e9f96.
Notes
  • Error message 2 immediately follows error message 1.
  • This problem occurs with ASP.NET 2.0 applications. This problem may occur with other types of applications that run under non-interactive accounts, such as Windows services.

CAUSE

This problem occurs when a null reference is in the user policy cache.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mscordacwks.dll2.0.50727.63800,25624-Jan-200611:16x86
Mscorlib.dll2.0.50727.634,308,99224-Jan-200611:16x86
Mscorwks.dll2.0.50727.635,616,64024-Jan-200611:16x86
Sos.dll2.0.50727.63377,34424-Jan-200611:16x86

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

When the common language runtime (CLR) starts, the CLR verifies that the user profile exists. If the user profile does not exist, a null reference is put in the user policy cache. If the user profile is created during policy resolution, the CLR tries to remove the reference to the null reference in the user policy cache. When the CLR cannot remove the reference to the null reference in the user policy cache, the .NET Framework 2.0 crashes.

Hotfix information

Prerequisites

To apply this hotfix, you must have the .NET Framework 2.0 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbfix kbQFE kbtshoot kbpubtypekc kbbug KB913384 kbAudITPRO kbAudDeveloper