SYMPTOMS
When you use an application to extend a partition on a Microsoft Windows Server 2003-based computer, you may receive a Stop error message that is similar to the following:
A problem has been detected and windows has been shut down to prevent damage to your computer.
If this is the first time you've seen this Stop error screen, restart your computer. If this message appears again, follow these steps:
Disable or uninstall any anti virus , disc defragmentation or backup utilities. Check your hard drive configuration, and check for any updated drivers. Run CHKDSK /F to check for hard drive corruption, and then restart your computer.
Technical Information
Stop 0x00000024 (0x0019033c, 0xf016e7a0, 0xf016e49c, 0xe061dcdc)
CAUSE
This problem may occur if the application uses the following IOCTLS and FSCTLS control codes to extend the volume:
IOCTL_DISK_UPDATE_PROPERTIES
IOCTL_DISK_GROW_PARTITION
FSCTL_EXTEND_VOLUME
For example, you may use a third-party utility to resize a partition or to append unused space on a hard disk to an existing partition. If the third-party utility uses these IOCTLS and FSCTLS control codes, a Stop error may occur.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, x86-based versions
|
Ftdisk.sys | 5.2.3790.2607 | 137,216 | 04-Jan-2006 | 02:16 | x86 |
Windows Server 2003, x64-based versions
|
Ftdisk.sys | 5.2.3790.2607 | 240,128 | 04-Jan-2006 | 04:38 | x64 |
Windows Server 2003, Itanium-based versions
|
Ftdisk.sys | 5.2.3790.2607 | 499,200 | 04-Jan-2006 | 04:38 | IA-64 |