You may receive an NDR when you send an e-mail message to an external X400 address through a Defense Messaging System gateway server in Exchange Server 2003 SP2 (912582)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Service Pack 2

SYMPTOMS

Consider the following scenario. You are working in an organization that is running Microsoft Exchange Server 2003 Service Pack 2 (SP2). You send an e-mail message to an external X400 address. This e-mail message is routed through a Defense Messaging System (DMS) gateway server. In this scenario, you may receive a non-delivery report (NDR).

This issue occurs when the e-mail message is also routed over an X400 connector.

CAUSE

This issue occurs because an e-mail message is encapsulated two times when it is also routed over an X400 connector. When the e-mail message is encapsulated two times, the PrintableString representation of the at sign (@) may be split between two Exchange Domain Defined attribute (DDA) extension markers. When this occurs, the message transfer agent (MTA) sends an NDR.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you install the hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mtaroute.dll6.5.7651.667,07221-Feb-200602:10x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The X400 address printable character set uses T.61 extended characters. In this character set, the at sign is represented as "(a)". If the string that represents the at sign is split between two DDA extension markers, the string is represented as one of the following strings:
  • (a;DDA:MSXCHNGE=)
  • (;DDA:MSXCHNGE=a)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbfix kbBug kbpubtypekc KB912582 kbAudITPRO