FIX: Some protected TV content may not play after you change the system time on a computer that is running Windows XP Media Center Edition 2005 with Update Rollup 2 (912453)



The information in this article applies to:

  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2

SYMPTOMS

After you change the system time on a computer that is running Microsoft Windows XP Media Center Edition 2005 with Update Rollup 2 (MCE), some protected TV content may not play. If you have rolled back the system clock, you may receive the following error message when you try to play some protected TV content:
Restricted Content: Restrictions set by the broadcaster and/or originator of the content prohibit playback of the program on this computer

CAUSE

The Microsoft Windows Media Digital Rights Management (WMDRM) system uses various checks to make sure that a user has not tampered with the WMDRM system. When you roll back the system clock, the WMDRM system detects that the system time has changed. Therefore, the WMDRM system may disable playback of content that requires a time-based license.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP Media Center Edition 2005 update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Download information

The following file is available for download from the Microsoft Download Center:
For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Drmv2clt.dll11.0.0.4335579,58412-Jan-200620:37x86

MORE INFORMATION

This hotfix lets you play content that has a valid license, even though the license was created before the new system time. However, you will not be able to play back content that has a license for a future date or time. This hotfix will invalidate that license.

You cannot remove this hotfix by using the Add or Remove Programs tool. If you must remove this hotfix, you can use the System Restore point that is created when you apply this hotfix.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbfix kbQFE kbHotfixServer KB912453 kbAudDeveloper kbAudEndUser kbAudOEM