You receive error messages when you try to set up a clustered instance of SQL Server 2005 (910851)



The information in this article applies to:

  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL Server 2005 Enterprise Edition
  • Microsoft SQL Server 2005 Standard Edition

Bug #: 290175 (SQLBUDT)
Bug #: 299209 (SQLBUDT)
Bug #: 396631 (SQLBUDT)
Bug #: 128877 (Windows SE)
Bug #: 46855 (Content Maintenance)

SYMPTOMS

When you try to set up a clustered instance of Microsoft SQL Server 2005, you receive the following error message:
Remote setup failed/
An entry that is similar to the following entry is recorded in the Task Scheduler log (SchedLgU.txt):
"SQL Server Remote Setup .job" (setup.exe) <Datetime stamp> ** ERROR ** Unable to start task. The specific error is: 0x80070005: Access is denied.

CAUSE

This problem occurs if the security token of the logged-on user account that is used by the Task Scheduler service differs from the security token of an administrator account that is used to set up the clustered instance of SQL Server 2005.

Note The setup packages of SQL Server 2005 that are running on the remote nodes will also cause the setup process to fail.

WORKAROUND

To work around this problem, follow these steps:
  1. Make sure that the Task Scheduler service is running on all the nodes of the cluster.
  2. Log off all the remote nodes of the cluster.
  3. Restart the Setup process for a clustered instance of SQL Server 2005.
  4. If you still receive the error message that is mentioned in the "Symptoms" section after you have completed steps 1 through 3, restart all the remote nodes of the cluster.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To open the Task Scheduler log, follow these steps:
  1. In Control Panel, open Scheduled Tasks.
  2. On the Scheduled Tasks menu, click Advanced, and then click View Log.

Modification Type:MinorLast Reviewed:3/15/2006
Keywords:kbsql2005cluster kberrmsg kbtshoot kbprb KB910851 kbAudDeveloper kbAudITPRO