The horizontal scroll bar that is used in forms may not respond to mouse controls or actions when you use themes on a Windows XP SP2-based computer (908536)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

On a Microsoft Windows XP Service Pack 2 (SP2)-based computer that is configured to use themes, the horizontal scroll bar that is used in forms may appear to be inactive. For example, the scroll bar does not respond to mouse controls or actions. This problem may occur when the scroll bar is part of a form that is, in turn, part of another form.

Note This problem typically occurs when you use forms that are designed in Microsoft.NET programs that use the System.Windows.Forms.Panel module. You may also experience this problem with forms that are created in Borland Delphi programs that use the TScrollBox component. This component is part of the Delphi programming language that is used to create scroll bars in Delphi programs.

CAUSE

This problem may occur if the code in the Uxtheme.dll file incorrectly calculates the horizontal scroll bar position in the form.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP Service Pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Uxtheme.dll6.0.2900.2845218,62411-Feb-200603:31x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbBug kbfix kbpubtypekc KB908536 kbAudITPRO kbAudEndUser