The Windows Installer package does not install when you use the PATCH command-line option try to install the package in Windows Server 2003 or in Windows XP (906219)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows XP Service Pack 1, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

When you use the PATCH command-line option to try to install a Microsoft Windows Installer patch (.msp file) during the initial installation of a Windows Installer package (.msi file) on a Microsoft Windows Server 2003 Service Pack 1-based or a Microsoft Windows XP Service Pack 2-based computer, the package does not install. This problem does not occur if you install the patch separately from the package.

CAUSE

This problem occurs because data in the TypeLib table of the package is not registered. The RegisterTypeLibraries action registers type libraries in the registry. This action is applied to each file referred to in the TypeLib table that is scheduled for installation. If the RegisterTypeLibraries action is skipped, data in the TypeLib table of the package is not registered.

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix on x86-based versions and Itanium-based versions of Windows Server 2003, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.

Note Service Pack 1 is included in x64-based versions of Windows Server 2003.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-bit versions
   Date         Time   Version             Size  File name
   ----------------------------------------------------------
   17-Aug-2005  02:35  3.1.4000.2510  2,891,264  Msi.dll
   17-Aug-2005  00:38  5.2.3790.2510     32,256  Arpidfix.exe
Windows Server 2003, 64-bit Itanium-based versions
   Date         Time   Version             Size  File name
   ----------------------------------------------------------
   17-Aug-2005  02:34  3.1.4000.2510  5,987,328  Msi.dll
   17-Aug-2005  02:34  3.1.4000.2510  2,891,264  Wmsi.dll
   17-Aug-2005  02:34  5.2.3790.2510     74,752  Arpidfix.exe
Windows Server 2003, 64-bit x64-based versions
   Date         Time   Version             Size  File name
   ----------------------------------------------------------
   17-Aug-2005  02:34  3.1.4000.2510  4,477,952  Msi.dll
   17-Aug-2005  02:34  3.1.4000.2510  2,891,264  Wmsi.dll
   17-Aug-2005  02:34  5.2.3790.2510     43,008  Arpidfix.exe

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version             Size  File name
   ----------------------------------------------------------
   23-Aug-2005  03:06  3.1.4000.2510  2,891,264  Msi31.dll
   23-Aug-2005  01:03  5.1.2600.2744     30,720  Arpidfix.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the RegisterTypeLibraries action, visit the following Microsoft Web site: For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003SP1fix kbWinXPsp2fix kbfix kbbug kbpubtypekc KB906219 kbAudEndUser kbAudITPRO