CPU utilization increases on the Exchange server when you are running Antigen (906045)



The information in this article applies to:

  • Microsoft Antigen 9.0 for Exchange
  • Sybari Antigen 8.0 for Microsoft Exchange
  • Sybari Antigen 7.5 for Microsoft Exchange

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you are running Antigen for Microsoft Exchange, you may notice that CPU utilization increases on the Microsoft Exchange server at certain times.

CAUSE

This behavior occurs if Antigen is scanning a message that has a large compressed file as an attachment. Depending on the version of Antigen that you are running, it may take Antigen two minutes to eleven minutes to scan a large compressed file.

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

When you install Antigen, additional processes run on server. These processes use server resources. To eliminate bottlenecks, you can configure Antigen to thread up to ten scanning processes for each scan job.

To configure Antigen to thread multiple scanning processes for each scan job, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE/Software/Sybarisoftware/AntigenforExchange

  3. Double-click the InternetProcessCount registry entry, and then type the thread count that you want to use in the Value box.

    Note You can type a number between 1 any 10. However, we do not recommend that you use a thread count that is greater than 3.
  4. Click OK.
  5. Restart the AntigenService service.
  6. Verify that the specified number of AntigenInternet.exe processes appear in Task Manager.

MORE INFORMATION

For more information about the multiple scanning processes feature, click the following article number to view the article in the Microsoft Knowledge Base:

906010 How to enable the multiple scanning processes feature in Antigen 7.5 and in Antigen 8.0


Modification Type:MinorLast Reviewed:7/3/2006
Keywords:kbtshoot KB906045