Error message when you deploy the Sybari Enterprise Manager Deployment Agent on a remote server: "Failed to Deploy the Agent. Reason: Access is Denied - error creating the deployment Agent on server" (906030)



The information in this article applies to:

  • Sybari Antigen 8.0 for Microsoft Exchange
  • Sybari Antigen 8.0 for IM
  • Sybari Antigen 8.0 for Microsoft SharePoint Portal Server
  • Sybari Antigen 8.0 for SMTP Gateways

SYMPTOMS

When you deploy the Sybari Enterprise Manager Deployment Agent on a remote server, you receive the following error message:
Failed to Deploy the Agent. Reason: Access is Denied - error creating the deploymentAgent on server.
Additionally, the following error may be logged in the event log of a server that is monitored by Sybari Enterprise Manager:
Error "Access is denied" creating notifier on "[ Sybari Enterprise Manager _ComputerName ]"

CAUSE

This issue may occur if you installed Microsoft Windows Server 2003 Service Pack 1 (SP1) on a remote agent on the target server. Windows Server 2003 SP1 has increased security requirements.

RESOLUTION

To resolve this issue, follow these steps on the target server:
  1. Click Start, click Control Panel, and then double-click Administrative tools.
  2. Double-click Component Services.
  3. In the left pane, expand Component Services, and then expand Computers.
  4. Right-click My Computer, and then click Properties.
  5. Click the COM Security tab.
  6. Under Launch and Activation Permissions, click Edit Limits.
  7. Under Group or user names, click Everyone.
  8. Under Permissions for everyone, click to select the Allow check box next to Remote Launch. Then, click to select the Allow check box next to Remote Activation.

MORE INFORMATION

If you previously installed the Sybari Enterprise Manager Deployment Agent on a remote server, you may have to remove the Sybari Enterprise Manager Deployment Agent and then reinstall it. The Sybari Enterprise Manager Deployment Agent may not have been completely installed during the previous installation attempt.

Modification Type:MajorLast Reviewed:12/30/2005
Keywords:kbprb kbhowto kbtshoot KB906030