FIX: You receive an error message in Connected Services Framework Server 2.5 when you try to create more than 1,000 organizations in the Active Directory directory service (905907)



The information in this article applies to:

  • Microsoft Connected Services Framework Server 2.5

SYMPTOMS

When you try to create more than 1,000 organizations in the Active Directory directory service, you receive the following error message in Microsoft Connected Services Framework Server 2.5:
soap:Envelope xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/03/addressing" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">

- <soap:Header>

  <wsa:Action>http://schemas.xmlsoap.org/ws/2004/03/addressing/fault</wsa:Action> 

  <wsa:MessageID>uuid:35d15aba-2c6d-491b-9e9a-84927e8da4da</wsa:MessageID> 

  <wsa:RelatesTo>uuid:8ad62c7c-50ab-4284-894d-011f90f2acbd</wsa:RelatesTo> 

  <wsa:To>http://schemas.xmlsoap.org/ws/2004/03/addressing/role/anonymous</wsa:To> 

- <wsse:Security>

- <wsu:Timestamp wsu:Id="Timestamp-893e57ce-e25e-4afb-a62b-01cc42ed87c7">

  <wsu:Created>2005-08-01T13:50:04Z</wsu:Created> 

  <wsu:Expires>2005-08-01T13:55:04Z</wsu:Expires> 

  </wsu:Timestamp>

  </wsse:Security>

  </soap:Header>

- <soap:Body>

- <soap:Fault>

  <faultcode xmlns:code="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">code:FailedAuthentication</faultcode> 

  <faultstring>Microsoft.Web.Services2.Security.SecurityFault: The security token could not be authenticated or authorized at Microsoft.Web.Services2.Security.Tokens.UsernameTokenManager.OnLogonUserFailed(UsernameToken token) at Microsoft.Web.Services2.Security.Tokens.UsernameTokenManager.LogonUser(UsernameToken token) at Microsoft.Web.Services2.Security.Tokens.UsernameTokenManager.AuthenticateToken(UsernameToken token) at Microsoft.Web.Services2.Security.Tokens.UsernameTokenManager.VerifyToken(SecurityToken securityToken) at Microsoft.Web.Services2.Security.Tokens.SecurityTokenManager.LoadXmlSecurityToken(XmlElement element) at Microsoft.Web.Services2.Security.Tokens.SecurityTokenManager.GetTokenFromXml(XmlElement element) at Microsoft.Web.Services2.Security.Security.LoadToken(XmlElement element, SecurityConfiguration configuration, Int32& tokenCount) at Microsoft.Web.Services2.Security.Security.LoadXml(XmlElement element) at Microsoft.Web.Services2.Security.SecurityInputFilter.ProcessMessage(SoapEnvelope envelope) at Microsoft.Web.Services2.Pipeline.ProcessInputMessage(SoapEnvelope envelope) at Microsoft.Web.Services2.Messaging.SoapReceiver.FilterMessage(SoapEnvelope envelope) at Microsoft.Web.Services2.Messaging.SoapReceiver.ProcessMessage(SoapEnvelope message)</faultstring> 

  <faultactor>http://sdp-test1-iis1:81/identitymanager/usermapmanager.ashx</faultactor> 

  </soap:Fault>

  </soap:Body>

  </soap:Envelope>

CAUSE

When you call the CreateOrganization function, you must belong to the Admins@domain group. Certain versions of Microsoft Windows only allow for a user security access token to belong to 1,000 security identifiers (SIDs). Therefore, when you are validated for permissions to establish a new session with a server, you must not be a member of more than 1,000 groups in the domain of the server. If this limit is exceeded, access to the server is denied, and you receive an error message.

For more information about this issue, click the following article number to view the article in the Microsoft Knowledge Base:

275266 Error message: During a logon attempt, the user's security context accumulated too many security IDs

RESOLUTION

To resolve this problem, you must apply a hotfix. The hotfix modifies the Connected Services Framework Server 2.5 Identity Manager (IDM) code so that any user who creates the organizations is not automatically added to the new groups that are created.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.csf.connector.identitymanager.dll2.5.0.1062188,41608-Sep-200501:23x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kberrmsg kbQFE kbfix kbbug kbpubtypekc KB905907 kbAudDeveloper