Error message when the SMS Agent Host service starts on an SMS client: "CcmExec.exe has encountered a problem and needs to close" (905868)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When the Microsoft Systems Management Server (SMS) Agent Host service (Ccmexec.exe) starts on an SMS client, you receive the following error message:
CcmExec.exe has encountered a problem and needs to close. We are sorry for the inconvenience.
Additionally, an error that is similar to the following is logged in the Excemgr.log file:
Access Violation occurs in CExecutionManager::OnServiceStartupTask
Therefore, the SMS Agent Host service does not start, and the SMS client is not functional.

CAUSE

This problem may occur on SMS clients that are in a time zone in the southern hemisphere. For example, this problem may occur on clients that are using the (GMT +9.30) Adelaide time zone.

The problem typically occurs when a client's time zone is changed when the SMS Agent Host service is processing an SMS execution request. The Msvcrt.dll file incorrectly converts local time to Universal Coordinated Time (UTC).

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How To obtain the latest Systems Management Server 2003 service pack

Hotfix information

On all affected clients, follow the steps in the "Workaround" section, and then install the hotfix that is described in this article.

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

SMS 2003 Service Pack 1.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Ccmcore.dll2.50.3174.1169327,68025-Oct-200415:40x86
Mp.msiNot Applicable6,726,14425-Oct-200415:40Not Applicable
Sms2003ac-sp1-kb905868-x86.mspNot Applicable647,68025-Oct-200415:40Not Applicable

WORKAROUND

Delete any active execution requests to bring the SMS client back to a functional state. To delete active execution requests, follow these steps:
  1. Click Start, click Run, type wbemtest.exe, and then click OK.
  2. In Windows Management Instrumentation Tester, click Connect.
  3. In the Namespace box, type root\ccm\softmgmtagent.

    Note If the client is remote, type \\computer_name\root\ccm\softmgmtagent.
  4. Click Enum Classes, click Recursive, and then click OK.
  5. Double-click CCM_ExecutionRequest(), and then click Instances.
  6. For each line that appears in the Query Result window, note the ContentID value. This is the package ID for the execution request and may be needed later to rerun the program.
  7. Click Delete for each execution request.
  8. Exit Windows Management Instrumentation Tester, and then start the SMS Agent Host service.
  9. If it is necessary, run the programs for the execution requests that you deleted.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbSMSClientHealth kbfix kbBug kberrmsg kbQFE kbpubtypekc KB905868 kbAudITPRO