You experience symptoms if you try to start the Microsoft Systems Management Server (SMS) 2003 Client Health Monitoring Tool for the first time (905798)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

If you try to start the Microsoft Systems Management Server (SMS) 2003 Client Health Monitoring Tool for the first time, you experience the following symptoms:
  • If you click the Info tab in the SMS Client Health Monitoring Tool dialog box, you receive the following error message:
    The SMS Client Health Service could not properly access the Client Health database.

    Possible reasons: 1. The service could not create a new Client Health database. Please make sure that the Client Health Service credential has Database Creator Server Role on the SQL server.
    2. The service could not access the existing Client Health database using the current credential. Please make sure that the Client Health Service credential has "db_owner" Database Role membership on the Client Health database.
    3. The service could not access the Client Health database. Please verify if the SQL server is accessible.
    4. A SQL operation could have failed. Please see the specific errors in CHService.log.
    Note You receive this error message in the Details window under Service Information.
  • The following entry is added to the Chservice.log file in the %SystemDrive%\Program Files\Microsoft SMS Client Health\Logs folder:
    Logging Initialized for .\logs\chService.log 
    <26.04.2005 13:39:34> <5080> Log Created 
    <26.04.2005 13:39:34> <5080> Service Starting 
    <26.04.2005 13:39:34> <4320> Load Settings 
    <26.04.2005 13:39:34> <4320> Done Loading 
    <26.04.2005 13:39:34> <4320> Checking for Database SMS_HEALTH on Server gbhalsmssrv1 
    <26.04.2005 13:39:34> <4320> getting connection to database... this may take up to 300 seconds 
    <26.04.2005 13:39:34> <4320> Database SMS_HEALTH doesn't exist, or couldn't be accessed - attempting to create it. 
    <26.04.2005 13:39:34> <4320> getting connection to database... this may take up to 300 seconds 
    <26.04.2005 13:39:35> <4320> Database successfully created. 
    <26.04.2005 13:39:35> <4320> getting connection to database... this may take up to 300 seconds 
    <26.04.2005 13:39:35> <4320> Database exists 
    <26.04.2005 13:39:35> <4320> Table does not exist: Creating it... ClientHealthMPInfo 
    <26.04.2005 13:39:35> <4320> Invalid SQL connection error - Line 1: Length or precision specification 0 is invalid.
    
    Note The dates and times in this entry will vary.

CAUSE

This problem occurs if the following conditions are true:
  • The Standards and formats section on the Regional Options tab is set to Turkish. The Regional Options tab is located in the Regional and Language Options tool in Control Panel.
  • The Location section on the Regional Options tab is set to Turkey.
  • The Language for non-Unicode programs section on the Advanced tab is set to Turkish. The Advanced tab is located in the Regional and Language Options tool in Control Panel.

RESOLUTION

To resolve this problem, modify the following sections in the Regional and Language Options tool in Control Panel:
  • Standards and formats
  • Location
  • Language for non-Unicode programs

The SMS 2003 Client Health Monitoring Tool is installed on a Microsoft Windows Server 2003-based computer

  1. Start the Regional and Language Options tool in Control Panel.
  2. On the Regional Options tab, click English (United States) under Standards and formats section, and then click United States under Location.
  3. On the Advanced tab, click English (United States) under Language for non-Unicode programs.
  4. Under Default user account settings, click to select the Apply all settings to the current user account and to the default user profile check box, and then click OK.
  5. Restart the computer.

The SMS 2003 Client Health Monitoring Tool is installed on a Microsoft Windows 2000-based computer

  1. Start the Regional Options tool in Control Panel.
  2. On the General tab, click English (United States) under Your locale (location).
  3. Under Language settings for the system, click to select the Western Europe and United States check box, and then click Set default.
  4. Under Select the appropriate locale, click English (United States), and then click OK.
  5. Restart the computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:8/16/2005
Keywords:kbtshoot kberrmsg kbprb KB905798 kbAudITPRO