You receive an "HTTP Error 500" error message when you try to log on to Outlook Web Access from a Windows Server 2003-based computer (905773)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

Consider the following scenario. You use a Microsoft Windows Server 2003-based computer to log on to a Microsoft Outlook Web Access (OWA) server. When you first contact the OWA server, OWA provides a Web-based user interface for authentication purposes. When you try to log on to this Web page, you enter an invalid user name or password. In response, you receive an "HTTP Error 500" error message. In this scenario, the following error message is standard:
The Web page requires the user to enter a valid password and user name.

CAUSE

This issue occurs because the Microsoft Internet Information Services (IIS) server does not handle the error code correctly.

RESOLUTION

Service pack information

To resolve this problem, obtain and install Windows Server 2003 Service Pack 1 (SP1). For more information about how to obtain Windows Server 2003 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirements

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x32-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   16-Aug-2005  02:13  6.0.3790.389        9,728  W3comlog.dll     
   16-Aug-2005  02:13  6.0.3790.389      342,528  W3core.dll
Windows Server 2003, x64-based Enterprise Edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Aug-2005  11:04  6.0.3790.389       21,504  W3comlog.dll     IA-64
   15-Aug-2005  11:04  6.0.3790.389      951,296  W3core.dll       IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE kbpubtypekc KB905773 kbAudITPRO