The list of financial institutions does not appear when you try to set up online services in Money 2005 or later versions (905695)



The information in this article applies to:

  • Microsoft Money 2007 Deluxe
  • Microsoft Money 2007 Home & Business
  • Microsoft Money 2007 Premium
  • Microsoft Money Deluxe 2006
  • Microsoft Money Premium 2006
  • Microsoft Money Small Business 2006
  • Microsoft Money Standard 2006
  • Microsoft Money 2005 Deluxe
  • Microsoft Money 2005 Premium
  • Microsoft Money 2005 Small Business
  • Microsoft Money 2005 Standard
  • Microsoft Money Essentials

SYMPTOMS

When you try to set up online services in Microsoft Money 2005 or later versions, the list of financial institutions does not appear. Instead, you receive an error message that resembles the following:
The list is temporarily unavailable. Please try again later.

CAUSE

This issue may occur if one or more of the following conditions are true:
  • The Microsoft Money data file is damaged.
  • You are not connected to the Internet, or Money does not recognize your Internet connection.
  • You have multiple Invlink.xml files located on the computer.
  • You have firewall software or other similar programs installed on the computer.
  • Your Internet service provider (ISP) is not Winsock compliant.
  • Your installation of Money is damaged.

RESOLUTION

To resolve this issue, follow these methods in the order that they appear in.

Method 1: Test the Money data file

The file that you use to set up online services may be damaged. To test this, follow these steps:
  1. Start Money.
  2. On the File menu, point to New, and then click New File.
  3. In the File name box, type the name of the file, click to select the location in the Save in list where you want to save the file, and then click OK.
  4. If you are prompted to back up the file to a floppy disk, click Don't Back Up.
  5. Follow the instructions to assign Microsoft Passport Network credentials (the e-mail address and password that you use to sign in to the Passport Network) to the Money file.
  6. Click No, I want to start a new file that doesn't use my MSN Money data, and then click Next.
  7. Click Skip Account Setup, and then click Finish.
  8. Click the Banking tab, and then click Add a new account.
  9. Click Banking, and then click Next.
  10. If the list of financial institutions appears, the Money data file may be damaged. For more information about how to diagnose and repair damage in a Money data file, click the following article number to view the article in the Microsoft Knowledge Base:

    182608 How to diagnose and repair damage in a Money data file

If the list of financial institutions does not appear, go to the next method.

Method 2: Verify that Money detects your Internet connection

  1. Connect to the Internet.
  2. Start Money, and then sign by using your Passport Network credentials.
If you can sign in without receiving an error message, Money correctly detects your Internet connection. Go to the next method.

If you only have the option to work offline, Money does not detect your Internet connection. Go to the next method.

Note If you do not have Passport Network credentials associated with your Money data file, follow these steps:
  1. Start Money.
  2. On the File menu, click Password Manager.
  3. Follow the instructions to add your Passport Network credentials.

Method 3: Reset the Microsoft Internet Explorer options, and then remove all the cookies and the temporary Internet files

  1. Click Start, click Run, type inetcpl.cpl, and then click OK.
  2. Click the Privacy tab, and then move the slider to the bottom to select the Accept All Cookies privacy setting.
  3. Click the Security tab, click the Internet Web content zone icon, and then click Custom Level.
  4. In the Reset to list, click Medium-low, and then click Reset.
  5. Click Yes when you are prompted to, and then click OK.
  6. Click the Advanced tab, and then click Restore Defaults.
  7. Click Apply, and then click OK.
Now that you have reset your Internet Explorer options, delete the Internet cache and remove all the Passport Network, Hotmail, and MSN cookies on the computer. To do this, follow these steps.Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, click Run, type inetcpl.cpl, and then click OK.
  2. Under Temporary Internet files, click Delete Files, and then click OK when you are prompted to.
  3. Click Settings, click View Files, and then delete any cookie files that end in "@passport," "@msn," or "@hotmail."

    Note The cookie files store some setting information for Web sites. If you do not have any saved settings, or if you are comfortable with resetting this information, delete all the files that are in this location.
Test your Money data file to see whether the list of financial institutions appears. If the list does not appear, go to the next method.

Method 4: Verify whether you have multiple Invlink.xml files installed on the computer

If you have multiple Invlink.xml files installed on the computer, Money cannot recognize the correct Invlink.xml file. To verify whether you have multiple Invlink.xml files installed on your computer, follow these steps. Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Quit any programs that are running.
  2. Click Start, and then click Search.
  3. Click All files and folders, and then type invlink.xml in the All or part of the file name box.
  4. In the Look in list, click My Computer.
  5. Click the More advanced options drop down list, and then click to select the following check boxes:
    • Search system folders
    • Search hidden files and folders
    • Search subfolders
  6. Click Search.
  7. On the View menu, click Details.
From the search results, verify that there is only one Invlink.xml file for each version of Money that is installed. For example, if you install Microsoft Money 2006 to the default folder, a copy of the Invlink.xml file is located in the following folder:

C:\Program Files\Microsoft Money 2006\MNYCoreFiles\WebCache

If you have more than one Invlink.xml file, the additional file may be the cause of your Internet connection failure. Delete the additional copies of the Invlink.xml file. To do this, follow these steps.

Important Do not delete the Invlink.xml file that is located in the WebCache folder. If you delete the Invlink.xml file that is located in the WebCache folder, you cannot start Money. You must reinstall Money.
  1. For each Invlink.xml file that is found in the search results, make a note of the In Folder information.
  2. Right-click each additional copy of the Invlink.xml file, and then click Delete.
  3. Click Yes when you are prompted to confirm the deletion.
Test your Money data file to see whether the list of financial institutions appears. If the list does not appear, go to the next method.

Method 5: Register msxml files

  1. Click Start, click Run, type regsvr32 msxml.dll, and then click OK.
  2. Repeat step 1 for the following two .dll files:
    • MSXML3.DLL
    • MSXML4.DLL
Test your Money data file to see whether the list of financial institutions appears. If the list does not appear, go to the next method.

Method 7: Verify Winsock compliance

Money requires that your Internet connection be Winsock compliant to make all the required connections. If your ISP is not Winsock compliant, you may have to use a different ISP to work with Money or contact your present ISP for more assistance. To verify Winsock compliance, follow these steps:
  1. Connect to the Internet.
  2. Quit all the programs that are running.
  3. Click Start, click Run, type http://msn.com, and then click OK.
If Internet Explorer starts and the MSN Web site is displayed, your ISP is Winsock compliant. The issue that you experience with Money can be related to other programs that are running on the computer. For more information about how to remove and reinstall Microsoft Money, click the following article number to view the article in the Microsoft Knowledge Base:

895866 How to remove and reinstall Microsoft Money



If you receive an error message when you perform step 3 or if the Web site is not displayed, your ISP is not Winsock compliant. You must use another ISP to work with Money or contact your present ISP for additional assistance.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

891338 Error messages that you receive when you try to open Money by using your Passport Network credentials


Modification Type:MinorLast Reviewed:7/5/2006
Keywords:kberrmsg kbtshoot KB905695 kbAudEndUser