You may lose processor power management features when you update the AMD processor driver on a multiprocessor computer that is running an x64-based version of Windows Server 2003 or Windows XP (905593)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

When you try to update the Advanced Micro Devices (AMD) processor driver for a computer that is running an x64-based version of Microsoft Windows Server 2003 or Microsoft Windows XP, the original Microsoft in-box driver is installed. Therefore, you may lose some processor power management features if you are using a multiprocessor computer.

CAUSE

This problem may occur if a newer AMD processor driver was previously installed.

The problem occurs because of a driver ranking process that assigns the original in-box processor driver a higher ranking than the newer AMD processor driver. This behavior occurs because the in-box .inf file contains a hardware ID that is more specific than the AMD .inf file. The date and version information is not a relevant factor in this particular driver update process.

RESOLUTION

To resolve this issue, restore the processor driver to the AMD version. To do this, follow these steps:
  1. Click Start, right-click My Computer, and then click Manage.
  2. Click Device Manager, and then expand Computer in the right pane.
  3. Right-click the processor device that you want to update, and then click Properties.
  4. Click the Driver tab, and then click Roll Back Driver.
Alternatively, contact AMD to determine whether a newer version of the processor driver is available.

For information about how to contact AMD, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

MORE INFORMATION

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:8/10/2005
Keywords:kbtshoot KB905593 kbAudEndUser