Items are not sorted as expected when you are using a third-party mailbox store in Outlook 2003 (905303)



The information in this article applies to:

  • Microsoft Office Outlook 2003

SYMPTOMS

Consider the following scenario:
  • You are using a third-party mailbox store in Microsoft Office Outlook 2003.
  • You try to group or to sort items in a custom view.
In this scenario, the items are not sorted as expected. Additionally, the rows in the custom view may appear as blank lines. And, the rows may be grouped together in the same group.

CAUSE

This problem may occur if the following conditions are true:
  • The third-party mailbox store is using the IMAPITable implementation.
  • The third-party mailbox store uses the ITableData::HrGetView method to generate an IMAPITable interface.

RESOLUTION

How to obtain the hotfix

This issue is fixed in the Outlook 2003 post-Service Pack 2 Hotfix Package that is dated December 6, 2005. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

899340 Description of the Outlook 2003 post-Service Pack 2 hotfix package: December 6, 2005

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbView kbemail kbOffice2003preSP3fix kbExpertiseInter kbbug kbfix kbHotfixServer kbQFE kbpubtypekc KB905303 kbAudITPRO