Internet Explorer 6 may stop responding when you use it to load a child window (905297)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003 SP1
    • Microsoft Windows XP Professional SP1
    • Microsoft Windows XP Home Edition SP1

SYMPTOMS

You use Microsoft Internet Explorer 6 to load a child window from a parent window on a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP with Service Pack 1. After you do this, Internet Explorer may stop responding.

CAUSE

This problem occurs because of a code defect.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP with Service Pack 1

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-Sep-2005  10:34  6.3.2800.1521     192,512  Dxtrans.dll   

Windows Server 2003

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   07-Sep-2005  02:23  6.3.3790.404      205,312  Dxtrans.dll       

Windows Server 2003 with Service Pack 1

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   07-Sep-2005  02:44  6.3.3790.2524     212,480  Dxtrans.dll      
   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This hotfix applies only to the Iexplore.exe and Explorer.exe processes. You cannot apply this hotfix if you use a third-party browser.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbtshoot kbBug kbfix kbpubtypekc KB905297 kbAudITPRO