FIX: When you try to perform two-phase commit transactions over TCP/IP by using Host Integration Server 2004 Managed Provider for DB2, the transactions fail (904774)



The information in this article applies to:

  • Microsoft Host Integration Server 2004

SYMPTOMS

When you access later versions of DB2 to perform two-phase commit (2PC) transactions over TCP/IP by using Microsoft Host Integration Server 2004 Managed Provider for DB2, a failure occurs and the transaction is rolled back. When you try to perform a 2PC transaction in SQL Query Analyzer, you receive the following error message:
(1 row(s) affected)

Server: Msg 8522, Level 18, State 1, Line 4
Distributed transaction aborted by MSDTC.

CAUSE

Versions of IBM DB2 that support XA Manager return additional data that Host Integration Server 2004 Managed Provider for DB2 cannot process. Therefore, a protocol violation occurs and Microsoft Distributed Transaction Coordinator (MSDTC) aborts the transaction.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ----------------------------------------------------------------------------------
   11-Aug-2005  17:11  6.0.1978.0  487,424  Db2oledb.dll
   11-Aug-2005  17:15               24,516  Db2oledb.h
   11-Aug-2005  17:11  6.0.1978.0   44,032  Ddmstr.dll
   11-Aug-2005  17:11  6.0.1978.0  114,688  Microsoft.hostintegration.msdb2client.dll
   11-Aug-2005  17:11  6.0.1978.0   71,680  Mseidb2c.dll
   11-Aug-2005  17:11  6.0.1978.0  435,200  Mseidb2d.dll
   11-Aug-2005  17:11  6.0.1978.0  693,248  Mseidrda.dll
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the problem

  1. Use the following settings to set up a linked server that is running Microsoft SQL Server:
    • Network = TCP/IP
    • Units of Work = DUW (Distributed Units of Work)
    • Connection Pooling = False
  2. Start SQL Query Analyzer. Then, run a command such as the following.
    SELECT * from LINKDUW.DSNFD037.SAMPLE.TBLA
    Notice that the command succeeds.
  3. Run the following series of commands that use 2PC.
    SET XACT_ABORT ON
    BEGIN DISTRIBUTED TRAN
    UPDATE LINKDUW.DSNFD037.SAMPLE.TBLA SET NAME='New Name' WHERE ID=1
    COMMIT TRAN
    SET XACT_ABORT OFF
    Notice that the series of commands fails. In SQL Query Analyzer, you receive the error message that is mentioned in the "Symptoms" section.
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbHotfixServer kbQFE kbfix kbbug kbpubtypekc KB904774 kbAudDeveloper