FIX: The user cannot log on to the mailbox by using Outlook when an existing Exchange Server mailbox is imported through the Microsoft Provisioning System (MPS) Import namespace (903147)



The information in this article applies to:

  • Microsoft Provisioning System
  • Microsoft Solution Offering - Hosting Messaging and Collaboration Solution

SYMPTOMS

When an existing Microsoft Exchange Server mailbox is imported through the Microsoft Provisioning System (MPS) Import namespace, the user cannot log on to the mailbox by using Microsoft Outlook. Additionally, the user object will not have the showInAddressBook attribute value populated with the domain name (DN) of the organization-specific global address list (GAL) or address list (AL).

CAUSE

The ApplyMailboxPlan procedure that is called by the ImportUser procedure does not correctly stamp the showInAddressBook attribute on users who are being provisioned into a MAPI enabled organization.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size     File name
   -------------------------------------------------------------
   27-Jun-2005  16:07  156,366  Mpsimport_ns.xml
   27-Jun-2005  16:07      581  Allocateexistingmailbox.xml
   27-Jun-2005  16:07      613  Applymailboxplan.xml
   27-Jun-2005  16:07      829  Createmailbox.xml
   27-Jun-2005  16:07      496  Enablecustomerforplans.xml
   27-Jun-2005  16:07      547  Enableorganizationforhosting.xml
   27-Jun-2005  16:07      640  Enableuserforhosting.xml
   27-Jun-2005  16:07      885  Importorganization.xml
   27-Jun-2005  16:07      738  Importuser.xml

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that Microsoft uses when Microsoft corrects software after it is released, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/19/2005
Keywords:kbBug kbfix kbQFE kbprb KB903147 kbAudDeveloper