You cannot connect to a Telnet server that is running on a Windows Server 2003-based computer (902439)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

A Telnet server is enabled to use NTLM authentication on a Microsoft Windows Server 2003-based computer. If no user profile exists for you on the Telnet server, you cannot connect to the server from a telnet client.

CAUSE

The problem occurs because of an access violation error in the Telnet session. The error occurs because a local user profile did not exist for you on the server.

Note The problem will not occur if you enable NTLM authentication after your user profile is created on the Telnet server.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows Server 2003, x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   23-Jun-2005  01:46  5.2.3790.355       77,824  Tlntsess.exe   
           
Microsoft Windows Server 2003 with Service Pack 1, x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   23-Jun-2005  00:51  5.2.3790.2472      81,408  Tlntsess.exe     
Microsoft Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jun-2005  14:42  5.2.3790.355      197,120  Tlntsess.exe     IA-64
Microsoft Windows Server 2003 with Service Pack 1, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jun-2005  14:42  5.2.3790.2472     214,528  Tlntsess.exe     IA-64
Microsoft Windows Server 2003, x64-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jun-2005  14:42  5.2.3790.2472     125,440  Tlntsess.exe     

WORKAROUND

To work around this problem, disable NTLM authentication, and then enable password authentication for the Telnet server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE kbpubtypekc KB902439 kbAudITPRO