Users receive a 401 error message when they try to access a mailbox that is in an Exchange Server 2003 front-end server by using Outlook Web Access (899902)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

If a user tries to access a mailbox that is in a Microsoft Exchange Server 2003 front-end server by using Microsoft Outlook Web Access, they receive a 401 error message.

CAUSE

By default, the Exprox.dll file builds the cache for the Exchange Server 2003 back-end server on the Exchange Server 2003 front-end server. The Exprox.dll file builds the cache by using the Dsaccess.dll file to provide a list of objects that has the msExchPrivateMDB attribute or the msExchPublicMDB attribute.

In a customer environment, if the values of the msExchPrivateMDB attribute are more than one thousand, the cache is incomplete. When a user tries to log on to the Exchange Server 2003 front-end server by using Outlook Web Access, the user receives a 401 error message. Additionally, the user cannot log on to the Exchange Server 2003 front-end server.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 1 (SP1).

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Sep-2005  02:43  6.5.7233.49       412,672  Exprox.dll       

WORKAROUND

To work around this problem, you can perform one of the following methods:
  • Change the authentication method between the Exchange Server 2003 front-end server and the Exchange Server 2003 back-end server to basic authentication.
    For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    899384 You receive an "HTTP Error 403" error message when you try to log on to your mailbox in Outlook Web Access

  • Add a public folder store to the Exchange Server 2003 front-end server.
  • Increase the Lightweight Directory Access Protocol (LDAP) query page size.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the Microsoft Exchange Server 2003 Service Pack 2 version of this fix, click the following article number to view the article in the Microsoft Knowledge Base:

909989 Error message when you log on to Outlook Web Access on an Exchange Server 2003 front-end server: "401"


Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbexchOWA kbQFE kbfix kbBug kbpubtypekc KB899902 kbAudITPRO