You receive a "Remote Assistance connection could not be established" error message when you try to offer unsolicited remote assistance in Windows XP (899862)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition

SYMPTOMS

Consider the following scenario. You try to offer unsolicited assistance to a novice computer for the first time by using Remote Assistance in Microsoft Windows XP. In this scenario, you may receive the following error message:
A Remote Assistance connection could not be established. You may want to check for network issues or determine if the invitation expired or was canceled by the person who sent it.
Note After you connect to a novice computer for the first time, you can always connect to this novice computer on subsequent attempts.

CAUSE

This issue occurs because Terminal Services on the novice computer has not started an RDP-TCP listener thread before the novice computer receives a connection attempt from the expert computer.

RESOLUTION

To resolve this issue, make sure that Remote Desktop functionality is enabled on the novice computer before you offer assistance. To enable Remote Desktop functionality on the novice computer, advise the novice computer user to follow these steps:
  1. Click Start, click Run, type sysdm.cpl, and then click OK.
  2. On the Remote tab, click to select the Allow users to connect remotely to this computer check box, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

By default in Windows XP, Remote Desktop functionality is disabled. Therefore, when a Windows XP-based computer starts, Terminal Services starts without RDP-TCP listener functionality.

When an expert tries to offer remote assistance, the Remote Assistance Remote Protocol generates a ticket and then configures the registry to awaken a Terminal Services thread. This thread starts the RDP-TCP listener and then returns a ticket to the expert.

Note The ticket is part of the authentication process.

Therefore, you receive the error message that is mentioned in the "Symptoms" section when you try to connect to the novice computer before the RDP-TCP listener has started. However, after the first connection attempt, you can always connect to this novice computer, because the RDP-TCP listener is already running.

To verify that the RDP-TCP listener is running on a particular novice computer, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type qwinsta. If the RDP-TCP listener is running, you receive the following output:

    rdp-tcp 65536 Listen rdpwd

Note Network delays frequently prevent this problem, even on the first Remote Assistance connection attempt. When network delays occur, the RDP-TCP listener may have sufficient time to start before a connection attempt is received from the expert computer.

Modification Type:MinorLast Reviewed:6/17/2005
Keywords:kberrmsg kbtshoot kbprb KB899862 kbAudEndUser kbAudITPRO