You receive a "Internet Explorer has encountered a problem and needs to close" error when you use Internet Explorer 6 to view a Web page that hosts an ActiveX control (899812)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • Microsoft Windows XP Service Pack 1
    • Microsoft Windows 2000 Server SP4
    • Microsoft Windows 2000 Professional SP4
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows XP Service Pack 2

SYMPTOMS

When you use Microsoft Internet Explorer 6 to view a Web page that hosts an ActiveX control, you may receive an error message that is similar to the following:
Internet Explorer has encountered a problem and needs to close.
When you click the link at the bottom of the message box to view the details, you receive an error signature that is similar to the following:
Error signature:
AppName: iexplore.exe 
AppVer: 6.0.2800.1106 
ModName: mshtml.dll 
ModVer: 6.0.2800.1498 
Offset: 002291f4 

CAUSE

The issue occurs after you install security update 890923. This update is documented in Microsoft Security Bulletin MS05-020.

This issue occurs because the Mshtml.dll file does not correctly handle a null pointer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Internet Explorer 6 Service Pack 1


Date        Time   Version          Size        File name
----------------------------------------------------------
09-Jun-2005 22:10    6.0.2800.1510  2,704,896   Mshtml.dll


Internet Explorer 6 for Microsoft Windows XP Service Pack 2

Date         Time     Version        Size       File name
----------------------------------------------------------
13-Jun-2005  17:44    6.0.2900.2696  3,015,168  Mshtml.dll

Microsoft Windows Server 2003, x64 versions


Date         Time    Version        Size        File name
----------------------------------------------------------
09-Jun-2005  19:43  6.0.3790.2461   5,932,544  Mshtml.dll       
09-Jun-2005  19:43  6.0.3790.2461   3,109,376  Wmshtml.dll      

Windows Server 2003, x86 versions

Date         Time   Version        Size         File name
----------------------------------------------------------
09-Jun-2005  18:58  6.0.3790.2461   3,109,376  Mshtml.dll   

Windows Server 2003 Service Pack 1

Date         Time   Version        Size         File name
----------------------------------------------------------
09-Jun-2005  20:58  6.0.3790.2461  3,109,376    Mshtml.dll
    
				

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about security update 890923 for Internet Explorer, click the following article number to view the article in the Microsoft Knowledge Base:

890923 MS05-020: Cumulative security update for Internet Explorer

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbfix kbbug kbHotfixServer kbQFE kbpubtypekc KB899812 kbAudITPRO kbAudDeveloper