Outgoing SMTP messages remain in the outgoing message queue, and event ID 4000 is logged on the computer that is running Exchange 2003 (899392)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

You may experience the following symptoms on a computer that is running Microsoft Exchange Server 2003:
  • Incoming Simple Mail Transfer Protocol (SMTP) messages are delivered to e-mail recipients.
  • Outgoing SMTP messages remain in the outgoing message queue on the Exchange computer and are not delivered to some domains.

    Note If you perform additional troubleshooting, you notice that mail is successfully delivered only to e-mail servers that advertise the Extended Simple Mail Transfer Protocol (ESMTP) CHUNKING verb. Examples of e-mail servers that advertise the CHUNKING verb include Exchange 2003 and Microsoft Exchange 2000 Server.
  • The following event is logged in the Application log:Event type: Warning
    Event source: MSExchangeTransport
    Event category: Connection Manager
    Event ID: 4000
    Description: Message delivery to the remote domain 'remotesmtphost.com' failed for the following reason: The handle is invalid.

CAUSE

This issue may occur if the local operating system account (SYSTEM) either cannot read from the temporary directory on the computer or cannot write to the temporary directory on the computer.

RESOLUTION

To troubleshoot this issue, follow these steps:
  1. Right-click My Computer, and then click Properties.

    Note In Microsoft Windows Server 2003, click Start, right-click My Computer, and then click Properties.
  2. Click the Advanced tab, and then click Environment Variables.
  3. In the System variables list, note the values that correspond to the TEMP variable and the TMP variable. For example, note the values from the following table.
    VariableValue
    TEMPC:\WINNT\TEMP
    TMPC:\WINNT\TEMP
  4. For the folder that you noted in step 3, verify all the following:
    • Verify that a valid path to the folder exists.
    • Verify that the drive where the folder is located has sufficient hard disk space available.
    • Verify that the SYSTEM account has Full Control permissions assigned for the folder or that the SYSTEM account has at least Read permissions and Write permissions to the folder. To do this, follow these steps:
      1. Start Windows Explorer, locate and then right-click the folder that the TEMP variable or the TMP variable points to, and then click Properties.
      2. In the Temp Properties dialog box, click the Security tab, and then click SYSTEM in the Name list.
      3. Verify that the Full Control check box is selected in the Allow column.

        Note If the Full Control check box is not selected in the Allow column, verify that the Read check box in the Allow column is selected and that the Write check box in the Allow column is selected.
    • If you are running a file-level antivirus program, make sure that the antivirus program has not locked the files in the TEMP folder. For more information about how to do this, contact the antivirus program vendor. For information about how to contact computer software vendors, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

      65416 Hardware and software vendor contact information, A-K

      60781 Hardware and software vendor contact information, L-P

      60782 Hardware and software vendor contact information, Q-Z

    • If disk quotas are enabled on the volume where the folder is located, verify that the quota has not been reached. To view the quota settings for a particular volume, follow these steps:
      1. Right-click the volume, and then click Properties.
      2. Click the Quota tab.
      For more information about how to manage disk quotas, visit the following Microsoft Web site:

MORE INFORMATION

For more information about how to configure or deploy Exchange 2003, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:2/25/2006
Keywords:kbexchSTORE kbtshoot kbprb KB899392 kbAudITPRO