You receive a "Setup was unable to grant access to the Microsoft CRM databases" error message when you try to install the Microsoft CRM server by using installation content that you copied to a computer (899379)



The information in this article applies to:

  • Microsoft Business Solutions CRM 1.0
  • Microsoft CRM 1.2

SYMPTOMS

After you copy the contents of the installation CD for Microsoft Business Solutions CRM to a folder on a computer, you try to install the Microsoft CRM server from that computer, and you receive the following error message:
Setup was unable to install Microsoft CRM server. Setup was unable to grant access to the Microsoft CRM databases.
You receive the error message immediately after you click Install. No error number is displayed.

CAUSE

You receive the error message because not all the files that are required to install the Microsoft CRM server are successfully copied from the Microsoft CRM server installation CD to the computer.

RESOLUTION

Two resolutions are available for this error. Before you perform either procedure, you must remove any existing Microsoft CRM components from the computer to which you are installing the Microsoft CRM server.

For more information about how to remove Microsoft CRM components, see the topic, "Completely Uninstall the Existing Microsoft CRM Deployment," in Appendix C of the Microsoft CRM Implementation Guide. The Microsoft CRM Implementation Guide can be found on Disk 3 of the Microsoft CRM CD set.

Resolution 1: install by using the installation CD

Install Microsoft CRM server by using the Microsoft CRM Server installation CD.

Resolution 2: copy the contents of the installation CD, and install by using splash.exe

Copy the contents of the Microsoft CRM installation CD to a folder that is located on the computer that you will use to install Microsoft CRM server. Run the Splash.exe program that is located in the installation folder to install the Microsoft CRM server. To use this method, follow these steps:
  1. Log on to the computer that you will use to install the Microsoft CRM server.
  2. Right-click Start and then click Explore.
  3. Locate the folder that you used to store the copied Microsoft CRM installation files.
  4. Right-click the folder, and then select Delete.
  5. Create a new folder named Crminstall on the computer that you will use to install the Microsoft CRM server.
  6. Locate the CD drive that contains the Microsoft CRM server installation CD.
  7. Right-click the drive, and then click Copy.
  8. Locate the Crminstall folder that you created in step 5.
  9. Right-click the Crminstall folder, and then click Paste.
  10. Install Microsoft CRM by double-clicking the Splash.exe file that is located in the Crminstall folder.

MORE INFORMATION

Steps to reproduce the problem

  1. Log on to the computer that you will use to install Microsoft CRM server.
  2. Create a folder named Crminstall on the computer that you will use to install the Microsoft CRM server.
  3. Locate the CD drive that contains the Microsoft CRM server installation CD.
  4. Right-click the CD drive, and then click Copy.
  5. Locate the Crminstall folder that you created in step 2.
  6. Right-click the Crminstall folder, and then click Paste.
  7. Locate the 1.0 folder on the following path:

    crminstall\sql\scripts\

  8. Rename any file that is located in the 1.0 folder.
  9. Install Microsoft CRM by double-clicking the Splash.exe file that is located in the Crminstall folder.
After you click Install, you receive the error message that is mentioned in the "Symptoms" section.

For more information about the error message that is mentioned in the Symptoms section, click the following article numbers to view the articles in the Microsoft Knowledge Base:

874873 "Setup was unable to install Microsoft CRM Server" error message when upgrading or re-installing Microsoft Business Solutions CRM

894283 You may receive an "80040E14" error message when you try to install Microsoft Business Solutions CRM 1.2

870105 Error "Setup was unable to install Microsoft CRM Server." occurs after you enter a license key during the upgrade of Microsoft CRM


Modification Type:MinorLast Reviewed:8/11/2005
Keywords:kbmbsmigrate kbMBSinstallation kberrmsg kbprb KB899379 kbAudEndUser