You may receive a "The system cannot change your password now because the domain is not available" error message in Windows XP after you try to change your password (899338)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition


Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you use a user principal name (UPN) to log on to Microsoft Windows XP, you may be prompted to change your password. When you try to change your password, you may receive an error message that is similar to the following:
The system cannot change your password now because the domain is not available.

CAUSE

The problem occurs when you log on across a forest trust.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Windows XP Service Pack 2.

322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirement
Msgina.dll5.1.2600.2737997,37612-Aug-200510:31x86SP2
Xpsp3res.dll5.1.2600.273717,92012-Aug-200502:14x86SP2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

How to enable the hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then right-click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

  3. Point to New, and then click DWORD Value.
  4. Type ChangePasswordUseKerberos, and then press ENTER.
  5. Double-click ChangePasswordUseKerberos, type 1, and then click OK.
  6. Quit Registry Editor.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug kbHotfixServer kbQFE kbpubtypekc KB899338 kbAudITPRO