Formatting that you configure for an e-mail message is lost when Microsoft CRM 1.2 sends the message by using a workflow rule that you create by using Workflow Manager (899329)



The information in this article applies to:

  • Microsoft CRM 1.2

SYMPTOMS

You perform the following actions in Microsoft Business Solutions CRM 1.2:
  • You create a workflow rule to send an e-mail message by using Workflow Manager.
  • You configure formatting in the message body. (For example, you press ENTER after a particular line in the message body.)
  • You apply the workflow rule to an object by using the Microsoft CRM Web client.
When you view the e-mail message that is sent by using this workflow rule, you notice that the formatting that you configured in the message body is lost.

For example, you configure an e-mail message that has the following format:

A
B
C
End

In this example, when the e-mail message is sent by Microsoft CRM, the e-mail message appears similar to the following:

A B C End

You expect formatting to be retained when you configure an e-mail message workflow rule.

CAUSE

This problem occurs because Workflow Manager does not automatically add formatting to the body of an e-mail message.

WORKAROUND

To work around this problem, manually add formatting to the e-mail message body by using HTML tags such as either of the following tags:

<p>
<br>

To do this, follow these steps:
  1. Log on to the server that is running Microsoft CRM 1.2. Log on as a user account that has CRM System Administrator privileges.
  2. Start Workflow Manager. To do this, click Start, point to Programs, point to Microsoft CRM, and then click Workflow Manager.
  3. In the Microsoft CRM Workflow Manager dialog box, click the workflow rule that you want to modify.
  4. On the Actions menu, click Deactivate.
  5. Double-click the workflow rule to open it.
  6. In the Workflow Rule dialog box, click E-mail To: Action_That_You_Want_To_Modify in the When Microsoft_CRM_Object is created list.
  7. Click Edit Selected.
  8. In the Body text box, type <br> or <p> where you want a line break to occur.

    Note The <br> tag specifies a line break at the location where you type the <br> tag. The <p> tag specifies a line break together with a blank line at the location where you type the <p> tag.

    For example, the text in the Body text box might appear similar to the following:

    A <br>
    B <br>
    C <p>
    End

  9. When you finish adding HTML tags to the Body text box, click OK, and then click Save.
  10. On the Actions menu, click Activate.

Modification Type:MinorLast Reviewed:8/15/2005
Keywords:kbMBSemail kbMBSworkflow kbpending kbBug kbtshoot kbprb kbMBSMigrate kbmsccsearch kbpubtypekc KB899329 kbAudDeveloper