You receive an "An unknown error has occurred, contact your system administrator" error message when you click "Go Offline" in the Outlook client (899178)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales for Outlook, when used with:
    • Microsoft CRM 1.2
  • Microsoft CRM 1.2

SYMPTOMS

When you click Go Offline in Microsoft Business Solutions CRM Sales for Outlook (the Outlook client), you receive the following error message:
An unknown error has occurred, contact your system administrator.
Additionally, if you have turned on Platform Tracing, the following error message is logged in the trace log file:
Call to GetAuthzContextFromGuid_CrmGetUserTeamAndRoleSids() failed.
Error = 0x800706ba
Function: CrmGetUserTeamAndRoleSids
File: drive:\crm\build\3297\src\platform\security\crmsecurity\secmain.cpp
Line: 2875

CAUSE

This problem may occur because of Active Directory enhanced security on computers that are running Microsoft Windows Server 2003. Microsoft CRM 1.2 cannot obtain the required information for an Outlook client user if the Microsoft Internet Information Services (IIS) services on the Microsoft CRM 1.2 server are running under the local system account. The local system account configuration is the default configuration for Microsoft Windows 2000 Server.

RESOLUTION

To resolve this problem if the Microsoft CRM server is Windows Server 2000, follow these steps. If the Microsoft CRM server is Windows Server 2003, go to step 2.
  1. Upgrade the Microsoft CRM 1.2 server from Windows 2000 Server to Windows Server 2003.
  2. Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
  3. Expand Local_Computer_Name, where Local_Computer_Name is the name of the affected computer. Then expand Application Pools.
  4. Right-click CRMAppPool, and then click Properties.
  5. Click the Identity tab.
  6. In the Predefined list, click Local System. Click OK.
  7. Click Start, click Run, type cmd in the Open box, and then click OK.
  8. At the command prompt, type iisreset, and then press ENTER.
  9. At the command prompt, type exit, and then press ENTER.

Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kberrmsg kbMBSMigrate kbprb KB899178 kbAudEndUser