FIX: Performance may be slow on a client computer when you start a Windows Forms application that is deployed on a remote computer (899177)



The information in this article applies to:

  • Microsoft .NET Framework 1.1 Service Pack 1 (SP1)


SYMPTOMS

When you use a client computer to start a Windows Forms application that is deployed on a remote computer, performance may be slow on the client computer if the client computer is running Microsoft .NET Framework 1.1 Service Pack 1 (SP1). For example, when you use the Internet to connect to a remote computer, and then you start an application that is deployed on that computer, the application may appear very slowly on the client computer.

Note This problem does not occur when you start the Windows Forms application locally or when you test the application in the Microsoft Visual Studio .NET IDE.

CAUSE

This problem occurs because of the additional security features that are installed with the .NET Framework 1.1 SP1. This problem does not occur on computers that are running an earlier version of the .NET Framework 1.1.

RESOLUTION

Software update information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft .NET Framework 1.1 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have the Microsoft .NET Framework 1.1 Service Pack 1(SP1) installed on the computer to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this software update.

Software update replacement information

This software update does not replace any other software updates.

File information

The English version of this software update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time      Version        Size        File 
--------------------------------------------------------------
06-May-2005  15:37:26  1.1.4322.2323  2,138,112   Mscorlib.dll
06-May-2005  15:39:36                    10,904   Mscorlib.ldo
06-May-2005  15:48:00  1.1.4322.2323  2,519,040   Mscorsvr.dll
06-May-2005  15:49:00  1.1.4322.2323  2,506,752   Mscorwks.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbNetFrame110SP2fix kbNetFrame110preSP2fix kbBug kbfix kbQFE kbHotfixServer kbpubtypekc KB899177 kbAudITPRO kbAudDeveloper