Memory leaks occur after you configure URL authorization on a Windows Server 2003-based Web server (899029)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition

SYMPTOMS

You configure URL authorization on a Microsoft Windows Server 2003-based Web server by using Authorization Manager in Microsoft Internet Information Services 6.0. Afterward, you see memory leaks in Windows Task Manager when many clients log on to the Web server.

CAUSE

This issue is caused by memory leaks that occur in the Azroles.dll file. When you track the Azroles.dll process by using System Monitor, System Monitor shows a continuous increase in the number of private bytes.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

If you are using the Azroles.dll file when you apply this hotfix, you must restart the computer.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-May-2005  22:13  5.2.3790.325      219,648  Azroles.dll      
Microsoft Windows Server 2003 with Service Pack 1 (SP1)
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-May-2005  22:11  5.2.3790.2438     232,448  Azroles.dll      
Microsoft Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-May-2005  07:48  5.2.3790.325      654,848  Azroles.dll      IA-64
   05-May-2005  07:48  5.2.3790.325      219,648  Wazroles.dll     x86
Microsoft Windows Server 2003 with SP1, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-May-2005  07:48  5.2.3790.2438     703,488  Azroles.dll      IA-64
   05-May-2005  07:48  5.2.3790.2438     232,448  Wazroles.dll     x86
Microsoft Windows Server 2003, x64-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-May-2005  07:48  5.2.3790.2438     414,208  Azroles.dll      x64
   05-May-2005  07:48  5.2.3790.2438     232,448  Wazroles.dll     x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE kbpubtypekc KB899029 kbAudITPRO